Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Слетает выбранное значение из СпискаЗначений

Слетает выбранное значение из СпискаЗначений
Я
   Hipocrisy2013
 
26.10.16 - 10:25
Есть список значений, при выборе всё "ок", всё встаёт как надо. Но только как поменяешь значение любого другого реквизита на форме, выбранное значение из списка пропадает. Кто знает из-за чего? Вот код спискаЗначений:
&НаКлиенте
Процедура ПринтерОбработкаВыбора(Элемент, ВыбранноеЗначение, СтандартнаяОбработка)
    
    СтандартнаяОбработка = Ложь;
    Элемент.ВыделенныйТекст = ВыбранноеЗначение;
    
КонецПроцедуры

&НаКлиенте
Процедура ПринтерНачалоВыбораИзСписка(Элемент, СтандартнаяОбработка)
    
    СписокПринтеров = Новый Массив;
    СписокПринтеров.Очистить();
    Принтеры = Новый COMОбъект ("WScript.Network"); 
    prn = Принтеры.EnumPrinterConnections(); 
    i = 0; 
    Пока i < prn.Count()-1 Цикл 
        СписокПринтеров.Добавить(prn.Item(i+1)); 
        i = i + 2; 
    КонецЦикла; 
    
    Элемент.СписокВыбора.ЗагрузитьЗначения(СписокПринтеров);    
    
КонецПроцедуры
 
 
   Lexey_
 
1 - 26.10.16 - 10:45
(0) смотри код в ПриИзменении() "любого другого реквизита на форме"
   Рэйв
 
2 - 26.10.16 - 10:58
+Или смотри Связи праметров выбора в реквизите Принтер. Там бывают хитровывернутые "Очищать"
   Hipocrisy2013
 
3 - 26.10.16 - 11:47
Вопрос решил, создал отдельный реквизит где храниться значение выбора и при изменении других реквизитов и него подтягиваю уже

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует