Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Чтение\Запись xml 7.7

v7: Чтение\Запись xml 7.7
Я
   myr4ik07
 
25.10.16 - 21:38
Поделитесь пожалуйста как работать с хмл документом в 7.7 (желательно через дом), в интернете находил примеры - не разобрался
 
 
   akaBrr
 
1 - 25.10.16 - 21:41
(0) если файл большой забудь про дом
   myr4ik07
 
2 - 25.10.16 - 21:43
(1) не большой
   GreyK
 
3 - 25.10.16 - 21:47
У меня начало чтения как-то так написано:
    Для СчФайлов = 1 По СписокФайлов.РазмерСписка() Цикл
            
            ИмяВходящегоФайла = СписокФайлов.ПолучитьЗначение(СчФайлов);
            
            гФайл    =    гXMLАнализатор.СоздатьПоследовательноСчитываемыйДокумент();
            
            гФайл.СвязатьСФайлом(ИмяВходящегоФайла);
            
            ТипТега = гФайл.Спуститься();
            СвойстваТекущегоУзла    =    гФайл.СвойстваТекущегоУзла;
            ТипТега = гФайл.Спуститься();
            
            Ошибка = 0;
            СписокНайденных.УдалитьВсе();

            Пока ТипТега = 1 Цикл        //    пока не достигнут конец файла

                
                ИмяТега    =    гФайл.СвойстваТекущегоУзла.Имя;
                
                Если ИмяТега = "Объект" Тогда
                    
                    Объект = гФайл.ТекущийЭлементВВидеОбъекта();
                    ТипОбъекта =  Объект.ПолучитьАтрибут("Тип");
                    Если Найти(ТипОбъекта,"СправочникСсылка.") > 0 Тогда
                        ПолучитьСвойствоОбъекта(Объект,"",СписокНайденных,Объект);
                    Иначе
                        Результат = ЗагрузитьОбъектV8(Объект,СписокНайденных);
                        Ошибка = Макс(Ошибка, ?(ТипЗначения(Результат) = 1,Результат,1));
                    КонецЕсли;
                    
                КонецЕсли;
                
                ТипТега = гФайл.Следующий();
                
            КонецЦикла;
   myr4ik07
 
4 - 25.10.16 - 21:58
(3) а что такое гXMLАнализатор?
   myr4ik07
 
5 - 25.10.16 - 21:59
(3) ааа, вот эту матню нужно подключать AddIn.XMLParser ?
   GreyK
 
6 - 25.10.16 - 22:02
(5) Обязательно.
гXMLАнализатор        =    СоздатьОбъект("AddIn.XMLParser");
   myr4ik07
 
7 - 25.10.16 - 22:03
(6) понял, спасибо большое

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует