Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Установка ставки НДС по умолчанию в табличной части

Установка ставки НДС по умолчанию в табличной части
Я
   Riko669
 
25.10.16 - 19:02
Добрый вечер. В табличной части документа, есть поле "СтавкаНДС", мне нужно чтобы оно заполнялось автоматически, когда выбираешь какой-то товар. Для документа сделана форма и в этой форме для табличной части использовала событие ПриНачалеРедактирования() табличного поля.
Код:
&НаКлиенте
Процедура ТоварыПриНачалеРедактирования(Элемент, НоваяСтрока, Копирование)
    Если НоваяСтрока И Не Копирование Тогда
        Элемент.ТекущиеДанные.СтавкаНДС = Перечисления.СтавкаНДС.НДС18;
    КонецЕсли;
КонецПроцедуры

Но дело в том, что мне выдает ошибку: {Документ.ПоступлениеТоваров.Форма.ФормаДокумента.Форма(23,37)}: Переменная не определена (Перечисления)
        Элемент.ТекущиеДанные.СтавкаНДС = <<?>>Перечисления.СтавкаНДС.НДС18; (Проверка: Тонкий клиент)

Подскажите, пожалуйста, в чем дело?
 
 
   mehfk
 
1 - 25.10.16 - 19:07
Читай СП на ПредопределенноеЗначение.
   Riko669
 
2 - 25.10.16 - 19:40
Изменила с &НаКлиенте на &НаСервере, ошибку перестал выдавать, но заполнение в табличной части все равно не идет.
   Mauser
 
3 - 25.10.16 - 19:42
(2) Что в СП написано было?
   Riko669
 
4 - 25.10.16 - 19:46
Что перечисления делаются не для "&на клиенте", а "&на сервере" ._.'
   MORRoz
 
5 - 25.10.16 - 19:51
&НаКлиенте
Процедура ТоварыПриНачалеРедактирования(Элемент, НоваяСтрока, Копирование) 
    Если НоваяСтрока И Не Копирование Тогда
        Элемент.ТекущиеДанные.СтавкаНДС = ПредопределенноеЗначение("Перечисление.СтавкаНДС.НДС18");
    КонецЕсли;
КонецПроцедуры
   Riko669
 
6 - 25.10.16 - 19:55
Так тоже пробовала, но заполнения при выборе товара все равно нет
   MORRoz
 
7 - 25.10.16 - 19:57
Товар выбирается в колонке таблицы или через кнопку "подбор"?
   MORRoz
 
8 - 25.10.16 - 19:59
&НаКлиенте
Процедура ТоварыНоменклатураПриИзменении(Элемент)
    Элементы.Товары.ТекущиеДанные.СтавкаНДС = ПредопределенноеЗначение("Перечисление.СтавкаНДС.Ставка18");
КонецПроцедуры


возьмем событие - при изменении номенклатуры.
так точно работает
   Riko669
 
9 - 25.10.16 - 20:03
Изначально предполагалось, что при добавление нового товара (номенклатуры), в поле "Ставка НДС" сразу же автоматически будет заполняться.

Ваш вариант сейчас попробовала, ошибку не выдает, но заполнение все равно не идет
не могу понять почему)
   NuLLsoft
 
10 - 25.10.16 - 20:04
Что за конфигурация?
 
 Рекламное место пустует
   MORRoz
 
11 - 25.10.16 - 20:05
Значит что-то не так.
Отладчиком умеете пользоваться?
В процедуру события система заходит?

Реквизит табличной части "СтавкаНДС" - имеет тип Перечисления.СтавкаНДС?
   Riko669
 
12 - 25.10.16 - 20:06
1С: Предприятие 8.3
   MORRoz
 
13 - 25.10.16 - 20:07
Это платформа.
А какая конфигурация? (Управление торговлей, Бухгалтерия, сама написала с нуля - для изучения программированию)
   Riko669
 
14 - 25.10.16 - 20:09
Точно! Спасибо огромное! Вот голова дырявая, я в реквизите табличной части не тот тип указала. Спасибо Большое еще раз!)
   MORRoz
 
15 - 25.10.16 - 20:12
На здоровье.
Удачного освоения программирования.Рекомендую купить книгу Радченко ("Практическое пособие разработчика") и учиться по ней.
   Riko669
 
16 - 25.10.16 - 20:14
Спасибо, поняла)

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует