Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Условное оформление списка документов (фон строки)

Условное оформление списка документов (фон строки)
Я
   Cancell
 
25.10.16 - 16:11
Всем привет, не могу понять почему не отрабатывает простейший код установки УО... есть список документов реализации (в УТ форма Документы продажи) на ней динамическая таблица документов реализации, настраиваю УО на поле СостояниеОтгрузки и никак не отрабатывает =\

    // Условное оформление динамического списка "СписокРеализацииТоваровУслуг"

    Если ОбщегоНазначенияКлиентСервер.ЭтоПлатформа83БезРежимаСовместимости() Тогда        
        СписокУсловноеОформлениеРеал = СписокРеализацииТоваровУслуг.КомпоновщикНастроек.Настройки.УсловноеОформление;        
    Иначе        
        СписокУсловноеОформлениеРеал = СписокРеализацииТоваровУслуг.УсловноеОформление;        
    КонецЕсли;
     
    СписокУсловноеОформлениеРеал.Элементы.Очистить();
    
    // Желтый фон для нового документа

    Элемент = СписокУсловноеОформлениеРеал.Элементы.Добавить();
    Элемент.Представление = НСтр("ru = 'Новый документ'");
    
    ОтборЭлемента = Элемент.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
    ОтборЭлемента.ЛевоеЗначение = Новый ПолеКомпоновкиДанных("СостояниеОтгрузки");
    ОтборЭлемента.ВидСравнения = ВидСравненияКомпоновкиДанных.Равно;
    ОтборЭлемента.ПравоеЗначение = Перечисления.СостоянияОтгрузки.НеРассчитано;

    Элемент.Оформление.УстановитьЗначениеПараметра("ЦветФона", ЦветаСтиля.ВысокийПриоритетДокумента);
 
 
   Cancell
 
1 - 25.10.16 - 16:13
+ в поле СостояниеОтгрузки таблицы галочку ИспользоватьВсегда установил. Пробовал даже условие НеРавно ставить и все равно не работало...
А если в режиме предприятия делать УО через настройку
списка то все работает... ппц
   iceman2112
 
2 - 25.10.16 - 16:17
щас папка скинет 100% рабочий код
   Cancell
 
3 - 25.10.16 - 16:18
Брал за основу код УО на другую таблицу, и в предприятие эти элементы УО видны в настройке списка, а мой нет.

    // Условное оформление динамического списка "СписокРаспоряженияНаОформление"

    Если ОбщегоНазначенияКлиентСервер.ЭтоПлатформа83БезРежимаСовместимости() Тогда
        
        СписокУсловноеОформление = СписокРаспоряженияНаОформление.КомпоновщикНастроек.Настройки.УсловноеОформление;
        
    Иначе
        
        СписокУсловноеОформление = СписокРаспоряженияНаОформление.УсловноеОформление;
        
    КонецЕсли;
    
    СписокУсловноеОформление.Элементы.Очистить();
    
    // Документ имеет высокий приоритет

    Элемент = СписокУсловноеОформление.Элементы.Добавить();
    Элемент.Представление = НСтр("ru = 'Документ имеет высокий приоритет'");
    
    ОтборЭлемента = Элемент.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
    ОтборЭлемента.ЛевоеЗначение = Новый ПолеКомпоновкиДанных("Приоритет");
    ОтборЭлемента.ВидСравнения = ВидСравненияКомпоновкиДанных.Равно;
    ОтборЭлемента.ПравоеЗначение = Справочники.Приоритеты.ПолучитьВысшийПриоритет();
    
    ОтборЭлемента = Элемент.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
    ОтборЭлемента.ЛевоеЗначение = Новый ПолеКомпоновкиДанных("ПометкаУдаления");
    ОтборЭлемента.ВидСравнения = ВидСравненияКомпоновкиДанных.Равно;
    ОтборЭлемента.ПравоеЗначение = Ложь;

    Элемент.Оформление.УстановитьЗначениеПараметра("ЦветФона", ЦветаСтиля.ВысокийПриоритетДокумента);
   iceman2112
 
4 - 25.10.16 - 16:19
ЭлементОтбора = ЭлементОформления.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
    ЭлементОтбора.ЛевоеЗначение = Новый ПолеКомпоновкиДанных(ПутьКПоказателю); 
    ЭлементОтбора.ВидСравнения  = ВидСравненияКомпоновкиДанных.Равно;// либо задаем свой

    ЭлементОтбора.ПравоеЗначение = 1;
    ЭлементОтбора.Использование = Истина;
        
    ЭлементОформления.Оформление.УстановитьЗначениеПараметра("ЦветФона", WebЦвета.СветлоЗеленый);
    
    Если ПолеОформленияИмя <> Неопределено Тогда 
        
        ПолеОформления = ЭлементОформления.Поля.Элементы.Добавить();
        ПолеОформления.Поле = Новый ПолеКомпоновкиДанных(ПолеОформленияИмя);
        ПолеОформления.Использование = Истина;    
        
    КонецЕсли;
   iceman2112
 
5 - 25.10.16 - 16:20
(3) чиститься возможно где то, настройки не?
   Cancell
 
6 - 25.10.16 - 16:32
ну я свою переменную для этого делаю - СписокУсловноеОформлениеРеал
и чищу ее перед добавлением, потом уже ничего нет. Причем в отладке смотрю после добавления - там все есть.

Просто потом на форме любое событие отлавливаю и смотрю СписокРеализацииТоваровУслуг.КомпоновщикНастроек.Настройки.УсловноеОформление - так же все на месте...
   Cancell
 
7 - 25.10.16 - 16:34
Разобрался... в этом условии
    Если ОбщегоНазначенияКлиентСервер.ЭтоПлатформа83БезРежимаСовместимости() Тогда
        
        СписокУсловноеОформлениеРеал = СписокРеализацииТоваровУслуг.КомпоновщикНастроек.Настройки.УсловноеОформление;
        
    Иначе
        
        СписокУсловноеОформлениеРеал = СписокРеализацииТоваровУслуг.УсловноеОформление;
        
    КонецЕсли;

выбиралось первое значение... убрал условие и оставил
СписокУсловноеОформлениеРеал = СписокРеализацииТоваровУслуг.УсловноеОформление;
- все заработало... странно, но некогда разбираться =\

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует