Вход | Регистрация


1С:Предприятие :: 1С:Предприятие 8 общая

Как вывести данные введенные пользователем в печатную форму?

Как вывести данные введенные пользователем в печатную форму?
Я
   Yrii-ay
 
25.10.16 - 16:07
Есть форма документа где пользователь выберает данные  из списка в группах и подгруппах  , неопходимо выводить эти данные на печатную форму.Как реализовать это в модуле формы?
 
 
   butterbean
 
1 - 25.10.16 - 16:07
что из перечисленного вызывает вопросы?
   Yrii-ay
 
2 - 25.10.16 - 16:09
Если Объект.Отделка1 
        Тогда Область.Параметры.Красочность=Область.Параметры.Красочность +   " Отделка1  " ;
    КонецЕсли;
   Yrii-ay
 
3 - 25.10.16 - 16:10
Выводит только отделку, а нужно ещё данные выбранные из списка в группе Материалы.
   Yrii-ay
 
4 - 25.10.16 - 16:29
что никто не поможет?
   pv94384
 
5 - 25.10.16 - 16:33
Попробуй собрать все данные в одну переменную и переменную передай в параметр
   Fedor-1971
 
6 - 25.10.16 - 16:36
(4) твой макет видишь только ты, в Область.Параметры.??? заполни все параметры пред выводом или сначала полностью сформируй строку для вывода
ИнфСтрокой=ИнфСтрокой+"?????"+Символы.ПС; - дополняй всем чем нужно
и потом Область.Параметры.Красочность=ИнфСтрокой;
   Yrii-ay
 
7 - 25.10.16 - 17:51
Если Объект.Отделка1   
        Тогда Материал ПринадлежитЭлементу.Группа.ПленкиДляЛаминации  
    КонецЕсли;
   aleks_default
 
8 - 25.10.16 - 17:55
(7) мало, мало точек
   Базис
 
9 - 25.10.16 - 18:07
(0) Тебе же говорили - изучи сперва работу программы в пользовательском режиме. Сейчас ты - какими бы тебе аллегориями объяснить - ну, например, решил впустить в кровь глицерина и плавно замёрзнуть. Как лягушка. Чтоб проснуться уже в мае. А то, что учиться надо - так это ж Ленин предлагал, он уже не актуален.
   Yrii-ay
 
10 - 26.10.16 - 10:35
Если Объект.Отделка1.ПринадлежитЭлементу (Справочники.Номенклатура.Материалы.Сырьеиматериалядляпеч.продукции.Самоклеящиесяматериалы.ПленкиДляламинации )  Тогда
 
 Рекламное место пустует
   Yrii-ay
 
11 - 26.10.16 - 10:36
Если Объект.Отделка1.ПринадлежитЭлементу (Справочники.Номенклатура.Материалы.Сырьеиматериалядляпеч.продукции.Самоклеящиесяматериалы.ПленкиДляламинации )  Тогда
     Сообщить("Принадлежит");
КонецЕсли;
   Yrii-ay
 
12 - 26.10.16 - 10:37
Что в нём не правильно?
   Lexey_
 
13 - 26.10.16 - 10:38
(12) об этом тебе скажет платформа в сообщении об ошибке
   butterbean
 
14 - 26.10.16 - 10:40
(12) что ты пытаешься вообще сделать? вывести какой-то текст в печатную форму? ничего вообще не понятно
   Yrii-ay
 
15 - 26.10.16 - 10:43
Да текст, то есть пользователь выбирает из группы иерархии "Пленки для Ламинации" мне нужно их вывести на печ.форму !
   butterbean
 
16 - 26.10.16 - 10:44
(15) кого "их"?
   Yrii-ay
 
17 - 26.10.16 - 10:45
Пленки для Ламинации
   Yrii-ay
 
18 - 26.10.16 - 10:45
названия этих пленок
   Fish
 
19 - 26.10.16 - 10:45
(11) Это что за ад? "Справочники.Номенклатура.Материалы.Сырьеиматериалядляпеч.продукции.Самоклеящиесяматериалы.ПленкиДляламинации"
   Yrii-ay
 
20 - 26.10.16 - 10:47
Ну как тогда превратить это в Рай?
   Lexey_
 
21 - 26.10.16 - 10:49
(20) начать с изучения теории
   butterbean
 
22 - 26.10.16 - 10:51
(18) как называется реквизит, который выбирает пользователь?
   БледноЗолотистый
 
23 - 26.10.16 - 10:53
А а Как в коде написать сравнение? написал что сделал, обманул значит?
   Yrii-ay
 
24 - 26.10.16 - 10:53
Отделка1
   DDwe
 
25 - 26.10.16 - 10:56
(24) Нет Отделка2!
   Yrii-ay
 
26 - 26.10.16 - 10:59
Вы просто предположили что Отделка2 ? Или мы друг друга знаем?
   Yrii-ay
 
27 - 26.10.16 - 11:00
DDwe?
   dva1c
 
28 - 26.10.16 - 11:09
(27) А на простых примерах не пробовал понять, как нужно делать?
   Yrii-ay
 
29 - 26.10.16 - 11:19
Например?
   DDwe
 
30 - 26.10.16 - 11:22
(29) Например что?
   Митяйский
 
31 - 26.10.16 - 11:22
Например, взять любую уже существующую распечатку и посмотреть, как она заполняется
   Fish
 
32 - 26.10.16 - 11:23
(31) И тут мы возвращаемся опять к (21). Т.к. без этого, смотри, не смотри - всё одно.
   DDwe
 
33 - 26.10.16 - 11:25
(32) Если долго смотреть в существующую распечатку, распечатка начинает... (закончить по своему желанию)
 
 
   DDwe
 
34 - 26.10.16 - 11:30
ТС смотрит в распечатку,
   Yrii-ay
 
35 - 26.10.16 - 11:35
Глупый старается погубить другого, умный старается помочь другому.
   Yrii-ay
 
36 - 26.10.16 - 11:35
Вдумайтесь лучше
   Митяйский
 
37 - 26.10.16 - 11:35
(32) Хз я печатные формы дорисовывал еще будучи разносчиком дисков, не зная теории. И существующих примеров распечаток мне было вполне достаточно.
   Митяйский
 
38 - 26.10.16 - 11:37
(36)
>>Вдумайтесь лучше

Вот это поворот©
   DDwe
 
39 - 26.10.16 - 11:38
(36) А нам-то вот на хрена вдумываться? Сам и дума.
   DDwe
 
40 - 26.10.16 - 11:38
(39) Думай )
   DDwe
 
41 - 26.10.16 - 11:39
(38) Такова теперь молодежь, ничего не хочет и не умеет, лишь бы сделали за него.
   Yrii-ay
 
42 - 26.10.16 - 11:43
А вы сразу 1Спрограммистом родились?
   DDwe
 
43 - 26.10.16 - 11:44
(42) Что ты, задолго до рождения.
   Yrii-ay
 
44 - 26.10.16 - 11:52
Гордыня
   DDwe
 
45 - 26.10.16 - 11:52
(44) Угу, она самая.
   DDwe
 
46 - 26.10.16 - 11:54
(45) Можно еще добавить "гордость", за молодежь особенно после (11)
   Yrii-ay
 
47 - 26.10.16 - 11:56
Вы всегда так уверены в то чего не знаете?
   dva1c
 
48 - 26.10.16 - 11:58
(44) Быстрее придешь к результату, если будешь задавать более конкретные вопросы
   Yrii-ay
 
49 - 26.10.16 - 11:59
Спасибо.Согласен!
 
 Рекламное место пустует
   dva1c
 
50 - 26.10.16 - 11:59
(49) Макет печатной формы у тебя есть?
   Yrii-ay
 
51 - 26.10.16 - 12:00
Есть
   dva1c
 
52 - 26.10.16 - 12:02
(51) Теперь в процедуре печати, тебе нужно заполнить значениями все переменные макета и вывести его (макет).
   Yrii-ay
 
53 - 26.10.16 - 12:40
Если Объект.МатериалОтделка1. ПринадлежитЭлементу ( Справочники.Номенклатура.НайтиПоКоду("00000010366")) Тогда
          Область.Параметры.Красочность =  Область.Параметры.Красочность +  "Ламинация " ;
 КонецЕсли;
   Yrii-ay
 
54 - 26.10.16 - 12:40
Вот что я хотел!


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует