Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Из поля справочника вызываю форму другого справочника, передаю

Из поля справочника вызываю форму другого справочника, передаю
Я
   Ivan_495
 
25.10.16 - 16:04
Из поля справочника вызываю форму другого справочника, передаю параметры в эту формы, нажимаю кнопку записать . Открываю элемент поля в которые писал параметры пустые записалось только наименование?

&НаСервере
Функция ПолучитьПараметрыОткрываемойФормы()
       
   СтруктураПараметров = Новый Структура;
   СтруктураПараметров.Вставить("Н",Объект.Материал);
   СтруктураПараметров.Вставить("Р",Объект.Родитель);
   СтруктураПараметров.Вставить("М",Объект.Марка);
   СтруктураПараметров.Вставить("Е",Объект.ЕдИзм);
   

   Возврат СтруктураПараметров;
    
КонецФункции

&НаКлиенте
Процедура СоздатьЭлемент(Команда)
    пар=ПолучитьПараметрыОткрываемойФормы();
    ОткрытьФорму("Справочник.урскКлассификаторТМЦ.Форма.ФормаЭлементаУправляемая",пар);    

КонецПроцедуры
 
 
   mikecool
 
1 - 25.10.16 - 16:06
нихрена не понял
а зачем за структурой на сервер бегать?
   Ivan_495
 
2 - 25.10.16 - 16:08
(1) да хрен с ней со структурой вопрос не в том, почему данные не записываются?
   Ivan_495
 
3 - 25.10.16 - 16:09
параметры в поля попадают
   Ivan_495
 
4 - 25.10.16 - 16:09
&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    Объект.Наименование=Параметры.Н;
    Объект.ПолноеНаименованиеМТР=Параметры.Н;
    Объект.Родитель=Параметры.Р;
    Объект.Марка_условноеОбозначение=Параметры.М;

КонецПроцедуры
   Ivan_495
 
5 - 25.10.16 - 16:15
как правильно использовать для создания нового элемента справочника КлассификаторТМЦ ?
ОткрытьФорму("Справочник.КлассификаторТМЦ.Форма.ФормаЭлеме
нтаУправляемая",пар);
   Ivan_495
 
6 - 25.10.16 - 16:16
как правильно использовать 
ОткрытьФорму("Справочник.КлассификаторТМЦ.Форма.ФормаЭлеме
нтаУправляемая",пар);

для создания нового элемента справочника КлассификаторТМЦ ?
   singlych
 
7 - 25.10.16 - 16:32
Если я правильно понял (0), то когда ты открываешь свой классификатор второй раз, у тебя опять отрабатывает (4), и твои поля опять заполняются из параметров, в которых на этот раз пустые значения.
   Ivan_495
 
8 - 25.10.16 - 16:34
(7) точно , благодарю
   Ivan_495
 
9 - 25.10.16 - 16:47
&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)


    Если Параметры.Ключ.Пустая() = Истина тогда
    Попытка
    
    Объект.Наименование=Параметры.Н;
    Объект.ПолноеНаименованиеМТР=Параметры.Н;
    Объект.Родитель=Параметры.Р;
    исключение 
КонецПопытки;
    КонецЕСли;


КонецПроцедуры

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует