Вход | Регистрация


программная установка типа реквизита на вид одного из справочников

программная установка типа реквизита на вид одного из справочников
Я
   falselight
 
25.10.16 - 13:00
На форме документа есть реквизит типа перечисление.
2 значения. Как программно устанавливать тип другого поля,
в зависимости от выбранного перечисления типа одного или
другого справочника?
 
 
   Ёпрст
 
1 - 25.10.16 - 13:08
ПривыбореПеречисления устанваливай тип
   mehfk
 
2 - 25.10.16 - 13:09
Автору поможет только живительная эвтаназия.
   falselight
 
3 - 25.10.16 - 13:22
(1) я имел ввиду как задавать тип реквизита программно, какой код будет примерно
   Ёпрст
 
4 - 25.10.16 - 13:30
тип того

ОписаниеТипа = Новый ОписаниеТипов("СправочникСсылка.Организации");
ЭлементыФормы.Организация.ОграничениеТипа = ОписаниеТипа;
ЭлементыФормы.Организация.Значение = .... ОписаниеТипа.ПривестиЗначение();
ЭлементыФормы.ВыбиратьТип = Ложь;
   falselight
 
5 - 25.10.16 - 14:01
(4) это так обязательно?????
   Ёпрст
 
6 - 25.10.16 - 14:01
нет
   Альбатрос
 
7 - 25.10.16 - 14:02
(5) можешь просто написать: тип того
   falselight
 
8 - 25.10.16 - 14:02
(6) ну а можно так как то задавать
если это то
значение = тип справочник такой то ?
   falselight
 
9 - 25.10.16 - 14:03
(7) можете по синтаксису привести пример?
   Альбатрос
 
10 - 25.10.16 - 14:06
(9) Тебе в (4) чем не пример?
 
 Рекламное место пустует
   Fragster
 
11 - 25.10.16 - 14:06
снять галочку "выбирать тип" и присваивать пустое значение нужного типа
   torgm
 
12 - 25.10.16 - 14:13
(8) значение = Справочники.Организации.ПустаяСсылка()
Так хотел?
   falselight
 
13 - 25.10.16 - 14:15
(12) ну то есть так будет присваивать тип справочника такого то реквизиту?!
(11) попробую
(10) это нужно задавать для каждого справочника???? Там для одного задано
   Альбатрос
 
14 - 25.10.16 - 14:16
(13) Задавть нужно в зависимости от товего перечисления, ты ж сам так сказал. Вариант (12) тоже рабочий, по-своему...
   falselight
 
15 - 25.10.16 - 15:07
(12) так почему то не работает. Какого типа должен быть реквизит, которому нужно задать тип?

&НаКлиенте
Процедура ВидОперацииПриИзменении(Элемент)
    УстановитьТипРеквизита(Объект.ВидОперации);
КонецПроцедуры
//

 &НаСервере
 Процедура УстановитьТипРеквизита(ВидОперации)
    Если Объект.ВидОперации = Перечисления.ВидОперации.Личные Тогда
        Объект.РаботникПрофессия = Справочники.Сотрудники.ПустаяСсылка();     
    Иначе
        Объект.РаботникПрофессия = Справочники.Профессии.ПустаяСсылка();
    КонецЕсли;  
 КонецПроцедуры
   Fragster
 
16 - 25.10.16 - 15:13
(15) составного
   falselight
 
17 - 25.10.16 - 15:18
(9) пример нужен для управляемого приложения, интерфейс такси

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует