Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

выбор в одной ТЧ из другой ТЧ в документе

выбор в одной ТЧ из другой ТЧ  в документе
Я
   leobrn
 
25.10.16 - 09:26
Подскажите, как реализовать...

Допустим у нас есть две ТЧ в документе. В первой заполняем номенклатуру и т.д. Во второй ТЧ нам нужно в одном из полей выбрать номенклатуру, которая в первой ТЧ документа.

пробвоал так ( с тонким клиентом запары(( )
&НаКлиенте
Процедура РесурсыПредприятияНоменклатураНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
    
    СтандартнаяОбработка = Ложь;
    СпНоменклатуры         = Новый СписокЗначений;
    МассивНоменклатуры = ПолучитьТЗНоменклатуры(); 
    
    СпНоменклатуры.ЗагрузитьЗначения(МассивНоменклатуры);
    
    ФормаСписка = ПолучитьФормуСписка(Элемент);
    ФормаСписка.Отбор.Ссылка.ВидСравнения  = ВидСравнения.ВСписке; 
    ФормаСписка.Отбор.Ссылка.Значение      = СпНоменклатуры; 
    ФормаСписка.Отбор.Ссылка.Использование = Истина;
    ФормаСписка.РежимВыбора                = Истина;
  //ФормаСписка.ПараметрТекущаяСтрока      = Элемент.Значение;

 
    ФормаСписка.Открыть(); 
    
КонецПроцедуры
// Конец СтандартныеПодсистемы.Свойства

 
#КонецОбласти

 
Функция ПолучитьФормуСписка(ЭлементП)
    
    ФормаСписка = Справочники.Номенклатура.ПолучитьФормуСписка(,ЭлементП,);
    
    Возврат ФормаСписка;
 
 
КонецФункции
 
Функция ПолучитьТЗНоменклатуры()
    
    ТЗ = Объект.Продукция.Выгрузить(); 
    МассивНоменклатуры = ТЗ.ВыгрузитьКолонку("Номенклатура");
    
    Возврат МассивНоменклатуры;
 
 
КонецФункции
Ошибка

{Документ.ЗаказНаПроизводство.Форма.ФормаДокумента.Форма(1668)}: Ошибка при вызове метода контекста (ПолучитьФормуСписка)
ФормаСписка = ПолучитьФормуСписка(Элемент);
по причине:
Ошибка передачи данных между клиентом и сервером. Значение недопустимого типа.
по причине:
Ошибка преобразования данных XDTO:
Запись значения свойства 'param':
форма: Элемент
имя: {http://v8.1c.ru/8.2/managed-application/modules}param
по причине:
Ошибка отображения типов:
Отсутствует отображение для типа 'ПолеФормы'
 
 
   FIXXXL
 
1 - 25.10.16 - 09:28
(0) нет ТЗ на клиенте
сделай реквизит формы с типом СписокЗначений, клади туда номенклатуру из первой ТЧ и выбирай из второй
   Альбатрос
 
2 - 25.10.16 - 09:44
Ты форму на сервере что ли получаешь?
   Альбатрос
 
3 - 25.10.16 - 09:44
(1) У него не с ТЗ ошибка связана. Вроде...
   Альбатрос
 
4 - 25.10.16 - 09:45
(0) ФормаСписка = ПолучитьФормуСписка(Элемент) - строчки с ошибкой нет в представленном тобой коде

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует