Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Размножить область печати ТабДока грамотно на лист.

Размножить область печати ТабДока грамотно на лист.
Я
   AneJIbcuH
 
25.10.16 - 09:19
Всем привет! Есть область ТабДока:

http://s012.radikal.ru/i320/1610/9a/2bb20850ef7b.png

Как грамотно размножить его на лист. Т.е. по горизонтали вывожу две эти области (настройки принтера - по ширине страницы).
Далее, ниже ещё две и так до конца страницы, и вот если не влазит, необходимо вывести горизонтальный разделитель и продолжить вывод.
Делаю:

ОбластьПечати = Макет.ПолучитьОбласть("ОбластьМакетаГоризонталь|ОбластьМакетаВертикаль");
    
ВыводимыеОбласти = Новый Массив();
ВыводимыеОбласти.Добавить(ОбластьПечати);

i = 1;    
Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
        ОбластьПечати.Параметры.Заполнить(ВыборкаДетальныеЗаписи);        
        
ВыводВСтроку = (Цел(i/2)<>i/2);
        
Если ВыводВСтроку  Тогда
            
НеУмещаетсяНаСтраницу = ТабДок.ПроверитьВывод(ВыводимыеОбласти);
            
Если НеУмещаетсяНаСтраницу Тогда
                ТабДок.ВывестиГоризонтальныйРазделительСтраниц();                
КонецЕсли;
            
ТабДок.Вывести(ОбластьПечати);
            
Иначе                
            
ТабДок.Присоединить(ОбластьПечати);
            
КонецЕсли; 
        
i = i + 1;

КонецЦикла; 

И чего-то ТабДок.ПроверитьВывод постоянно Ложь даёт.
 
 
   НЕА123
 
1 - 25.10.16 - 09:23
ПроверитьПрисоединение
?
   НЕА123
 
2 - 25.10.16 - 09:24
(1)
не, похоже не то...
   AneJIbcuH
 
3 - 25.10.16 - 09:26
(2) Пока ширину страницы не рассматривал.
   Lexey_
 
4 - 25.10.16 - 09:31
(0) если что, не умещается на страницу это  ТабДок.ПроверитьВывод(ВыводимыеОбласти) = Ложь, так что: НеУмещаетсяНаСтраницу = Не ТабДок.ПроверитьВывод(ВыводимыеОбласти);
   AneJIbcuH
 
5 - 25.10.16 - 09:38
(4) Спасибо. Затупил, так использовал процедуру конфигурации: ФормированиеПечатныхФорм.ПроверитьВыводТабличногоДокумента(ТабДок, ВыводимыеОбласти)

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует