Вход | Регистрация


1С:Предприятие :: 1С:Предприятие 8 общая

Как применить директиву &Перед &После &Вместо на 8.3.9

Как применить директиву &Перед &После &Вместо на 8.3.9
Я
   emcmecemc2
 
24.10.16 - 18:17
Здравствуйте! Вопрос знатокам.

Пытаюсь в конфигурации 1С Розница 2.2 сделать расширение обработки РМКУправляемыйРежим. Отправил в расширение форму ФОРМА.
В модуле описываю:

&Перед("ПодготовитьДанныеДляПробитияЧека")
&НаСервере
Функция Расш1_ПодготовитьДанныеДляПробитияЧека(ЧекККМСсылка, ТранспортныйМодуль, ДанныеЕГАИСДостаточны, ТекстСообщения, ЕстьАлкогольнаяПродукцияЕГАИС = Неопределено)
.
.
.
КонецФункции

При проверке выходит ошибка
{ДолговойУчёт Обработка.РМКУправляемыйРежим.Форма.Форма.Форма(1,7)}: Ожидается определение процедуры/функции
&Перед<<?>>("ПодготовитьДанныеДляПробитияЧека") (Проверка: Сервер)
{ДолговойУчёт Обработка.РМКУправляемыйРежим.Форма.Форма.Форма(1,7)}: Ожидается определение процедуры/функции
&Перед<<?>>("ПодготовитьДанныеДляПробитияЧека") (Проверка: Тонкий клиент)

В соседней ветке подобный вопрос поднимался. Решили со снятием режима совместимости.
В этой конфигурации режим совместимости был изначально отключен.
Не знаю, что ещё ковырять...
 
 
   GROOVY
 
1 - 24.10.16 - 18:44
Платформу обновить до  8.3.9.1818.
   emcmecemc2
 
2 - 25.10.16 - 21:08
Платформу обновил.
Ещё раз проверил отключение Режима совместимости.
Ошибка осталась.
Что делать?
   emcmecemc2
 
3 - 25.10.16 - 21:11
в модуле формы оставил только строчку
&Перед("ПодготовитьДанныеДляПробитияЧека")

ошибки те же

{ДолговойУчёт Обработка.РМКУправляемыйРежим.Форма.Форма.Форма(1,43)}: Ожидается определение процедуры/функции
&Перед("ПодготовитьДанныеДляПробитияЧека")<<?>> (Проверка: Сервер)
{ДолговойУчёт Обработка.РМКУправляемыйРежим.Форма.Форма.Форма(1,43)}: Ожидается определение процедуры/функции
&Перед("ПодготовитьДанныеДляПробитияЧека")<<?>> (Проверка: Тонкий клиент)
   emcmecemc2
 
4 - 27.10.16 - 15:03
Какие идеи ещё есть?
Кто работал с расширениями, отзовитесь!
   singlych
 
5 - 27.10.16 - 15:53
(4) методом тыка - убери директиву &НаСервере
   korppinen
 
6 - 27.10.16 - 16:01
В основной то обработке есть эта процедура?
Очень активно применяю все вкусности 8.3.9.. все наработки вынес в расширения.. в основной конфе только объекты добавленные остались))) пока все работает. единственное конструктор запросов в расширении не работает с регистрами бухгалтерии.
   Filippov
 
7 - 27.10.16 - 16:06
Режим совместимости Не использовать должен быть установлен и у конфигурации, и у расширения
   emcmecemc2
 
8 - 27.10.16 - 16:07
(5) в расширении оставлял только одну строчку

&Перед("ПодготовитьДанныеДляПробитияЧека")
те же ошибки 

(6) название процедуры копировал прямо из основной конфы
   emcmecemc2
 
9 - 27.10.16 - 16:17
как вставить картинку, хочу принт-скрин показать?
   Filippov
 
10 - 27.10.16 - 16:22
А (7) сделано? Это обязательно
 
 Рекламное место пустует
   singlych
 
11 - 27.10.16 - 16:22
(8) Разные ошибки, <<?>> в разных местах. В случае (3) он хочет определение функции после &Перед("ПодготовитьДанныеДляПробитияЧека"), потому и предлагаю тебе его написать, типа
   singlych
 
12 - 27.10.16 - 16:22
&Перед("ПодготовитьДанныеДляПробитияЧека")
Функция Расш1_ПодготовитьДанныеДляПробитияЧека(ЧекККМСсылка, ТранспортныйМодуль, ДанныеЕГАИСДостаточны, ТекстСообщения, ЕстьАлкогольнаяПродукцияЕГАИС = Неопределено)
.
.
.
КонецФункции
   singlych
 
13 - 27.10.16 - 16:23
правда, ничего не гарантирую, с расширениями не работал :)
   Filippov
 
14 - 27.10.16 - 16:27
С функцией можно использовать только &Вместо
   Filippov
 
15 - 27.10.16 - 16:31
И внутри неё ПродолжитьВызов(), если нужно
(https://wonderland.v8.1c.ru/blog/rasshirenie-moduley/)
   emcmecemc2
 
16 - 27.10.16 - 16:42
(7) Режим совместимости Не использовать установлен и у конфигурации, и у расширения
   emcmecemc2
 
17 - 27.10.16 - 16:43
(14) а вот этот момент я прохлопал...
   Dmitry1c
 
18 - 27.10.16 - 16:45
&ВоЧтоБыТоНиСтало
   emcmecemc2
 
19 - 27.10.16 - 16:45
поставил &Вместо

{ДолговойУчёт Обработка.РМКУправляемыйРежим.Форма.Форма.Форма(1,45)}: Ожидается определение процедуры/функции
&Вместо ("ПодготовитьДанныеДляПробитияЧека")<<?>>; (Проверка: Сервер)
{ДолговойУчёт Обработка.РМКУправляемыйРежим.Форма.Форма.Форма(1,45)}: Ожидается определение процедуры/функции
&Вместо ("ПодготовитьДанныеДляПробитияЧека")<<?>>; (Проверка: Тонкий клиент)
   emcmecemc2
 
20 - 27.10.16 - 16:46
(18) или &хочухочухочу
   singlych
 
21 - 27.10.16 - 16:46
точку с запятой убери
   emcmecemc2
 
22 - 27.10.16 - 16:48
убрал

{ДолговойУчёт Обработка.РМКУправляемыйРежим.Форма.Форма.Форма(3,1)}: Ожидается определение процедуры/функции (Проверка: Сервер)
{ДолговойУчёт Обработка.РМКУправляемыйРежим.Форма.Форма.Форма(3,1)}: Ожидается определение процедуры/функции (Проверка: Тонкий клиент)
   singlych
 
23 - 27.10.16 - 16:49
а функцию написал?
   Filippov
 
24 - 27.10.16 - 16:49
И со следующей строки
Функция Расш1_П.....
......
КонецФункции
   emcmecemc2
 
25 - 27.10.16 - 16:54
Всем откликнувшимся огромное спасибо!

Функцию скопировал пока из основной конфы. Заработало!

Решено.


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует