Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Не работает отбор в в Журналезвонков.

Не работает отбор в в Журналезвонков.
Я
   KOlik
 
23.10.16 - 05:16
Вроде в отладке показаывает что значение Отбора следующее:

ТипЗвонка Равно "Входящий" И Дата Больше или равно "21.10.2016 0:00:00" И Дата Меньше "22.10.2016 0:00:00"

Нов выводит все звонки. Если ТипЗвонка только выставить то да фильтрует по типу звонка. А если добавить вот дату фильтр, выводит все записи Журналазвонков.




#Если МобильноеПриложениеКлиент Тогда

        
        ЖурналЗвонков = СредстваТелефонии.ПолучитьЖурналЗвонков();
        Отбор = Новый ОтборКомпоновкиДанных;
        ЭлементОтбора = Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
        ЭлементОтбора.ЛевоеЗначение= Новый ПолеКомпоновкиДанных("ТипЗвонка");
        ЭлементОтбора.ВидСравнения = ВидСравненияКомпоновкиДанных.Равно;
        ЭлементОтбора.ПравоеЗначение = ТипЗвонкаЖурналаЗвонков[Переключатель];
        ЭлементОтбора.Использование = Истина;
        
        
        
        Если ЗначениеЗаполнено(Дата) Тогда
            ЭлементОтбора = Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
            ЭлементОтбора.ЛевоеЗначение= Новый ПолеКомпоновкиДанных("Дата");
            ЭлементОтбора.ВидСравнения = ВидСравненияКомпоновкиДанных.БольшеИлиРавно;
            ЭлементОтбора.ПравоеЗначение = НачалоДня(Дата);
            ЭлементОтбора.Использование = Истина;
            
            СледующийДень =Дата + 60 * 60 * 24;
            ЭлементОтбора = Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
            ЭлементОтбора.ЛевоеЗначение= Новый ПолеКомпоновкиДанных("Дата");
            ЭлементОтбора.ВидСравнения = ВидСравненияКомпоновкиДанных.Меньше;
            ЭлементОтбора.ПравоеЗначение = НачалоДня(СледующийДень);
            ЭлементОтбора.Использование = Истина;

            
        КонецЕсли  ;
        
        СписокЗаписейЖурналаЗвонков = ЖурналЗвонков.НайтиЗаписи(Отбор);
        
        
        ТЗ.Очистить();
            
        
        Для каждого ТекСтрока из СписокЗаписейЖурналаЗвонков Цикл
            НоваяСтрока = ТЗ.Добавить();
            НоваяСтрока.Телефон = ТекСтрока.НомерТелефона;
            НоваяСтрока.Дата = ТекСтрока.Дата;
            
            
        КонецЦикла;
        
            
    #КонецЕсли
 
 
   Йохохо
 
1 - 23.10.16 - 09:33
пример добавления группового условия
http://its.1c.ru/db/metod8dev/content/3450/hdoc
   KOlik
 
2 - 24.10.16 - 05:53
(1) Спасибо)))

Список тем форума
Рекламное место пустует  Рекламное место пустует
Здесь во втором сообщении вам дадут решение, а в двадцатом дадут правильное решение. Ymryn
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует