Вход | Регистрация


Как обработать такое событие.

Как обработать такое событие.
Я
   lanc2233
 
22.10.16 - 11:49
Есть периодический регистр сведений, СтатусыЗаказов, подчиненный регистратору, движения делают несколько видов документов.

Задача : выполнить некоторый код, при изменении статуса на сегодняшнюю дату.

Проблема : непонятно где это делать. Если в модуле проведения документа, то там не получается сделать проверку.
Например, есть единственный документ, заказ 1, делает движение "Заказ1" - "В обработке".

При проведении, если проверять, то этого движения нет. Тоесть любое перепроведение будет выдавать что статус заказа изменился.

Как можно организовать проверку?
 
 
   Рэйв
 
1 - 22.10.16 - 11:52
>>непонятно где это делать
В модуле менеджера РС.
   lanc2233
 
2 - 22.10.16 - 11:57
В модуле набора записей, или в модуле менеджера?

Пробовал в модуле набора записей

Процедура ПриЗаписи(Отказ, Замещение)
    Для Каждого ТекСтрока из ЭтотОбъект Цикл
      // в этот цикл не всегда заходит, при проведении

      // непонятно по какому принципу        

    КонецЦикла;
КонецПроцедуры
   iceman2112
 
3 - 22.10.16 - 14:48
По принципу НаборЗаписей.Записать()
   PR
 
4 - 22.10.16 - 14:57
(0) Анализировать перед записью, если это проведение и протягивать в проведение
   arsik
 
5 - 22.10.16 - 15:00
(2) 2 раза в эту процедуру попадает. Первый раз очищает старые движения (в нем на каких строк не будет). И второй раз когда движения новые формирует
   arsik
 
7 - 22.10.16 - 18:07
(6) Ты гонишь.
(0) Только нужна переменная модуляДокумента - типа "НужноПровестиПоНашему регистру" - "ПередЗаписью"
В модуле документа - процедура "ПередЗаписью"
Типа так
Перем НужноПерепровестиМойРегистр;
Процедура ПередЗаписью(Отказ, РежимЗаписи, РежимПроведения)
    Если РежимЗаписи = РежимЗаписиДокумента.Проведение и Ссылка.Проведен Тогда
        //Это перепроведение

        //лезем в движения этого документа. Здесь пока еще старые движения

        если намвсеженужноегоизменить тогда
            НужноПерепровестиМойРегистр = истина;
        КонецЕсли;
    КонецЕсли;
КонецПроцедуры

Процедура ОбработкаПроведения(Отказ, РежимПроведения)
    Если НужноПерепровестиМойРегистр Тогда
        //Делаем движения

    КонецЕсли;
КонецПроцедуры


Список тем форума
Рекламное место пустует  Рекламное место пустует
Здесь можно обсудить любую тему при этом оставаясь на форуме для 1Сников, который нужен для работы. Ymryn
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует