Вход | Регистрация


установка значения поля при добавлении строки

установка значения поля при добавлении строки
Я
   falselight
 
22.10.16 - 09:07
Управляемые формы. Интерфейс такси.
Подскажите пожалуйста когда правильно задавать программно значение поля строки табличной части, при добавлении в неё строки?
Нужно при добавлении строки программно задавать значение одного поля.
 
 
   Рэйв
 
1 - 22.10.16 - 09:13
ПередНачаломДобавления , кажется
   Рэйв
 
2 - 22.10.16 - 09:14
или чтото вроде. Посмотри свойства таб поля
   falselight
 
3 - 22.10.16 - 09:19
(2) я сейчас перебираю все их, запустался в этих событиях, пытаюсь наладить алгоритм

но в этой процедуре ещё нет строки, как добавлять то значение в поле, если его нет?

&НаКлиенте
Процедура АлгоритмыПередНачаломДобавления(Элемент, Отказ, Копирование, Родитель, Группа, Параметр)
КонецПроцедуры
   Jija Grenkov
 
4 - 22.10.16 - 09:33
Приначалередактирования
   falselight
 
5 - 22.10.16 - 12:03
(4) да это правильно
   falselight
 
6 - 22.10.16 - 12:03
&НаКлиенте
Процедура АлгоритмыПриНачалеРедактирования(Элемент, НоваяСтрока, Копирование)
    Если НоваяСтрока И Не Копирование Тогда
        УнИд                             = Новый УникальныйИдентификатор;
        Элемент.ТекущиеДанные.КлючСвязи = Строка(УнИд);
    КонецЕсли;
КонецПроцедуры

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует