Вход | Регистрация

  1  2   
1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Карточка клиента не подтягивает расходную накладную.

v7: Карточка клиента не подтягивает расходную накладную.
Я
   Lesine
 
21.10.16 - 11:47
7.7 Торговля и склад для Украины.7.70.007 
Очень старая.
Прошу помощи, на торговле не работала.
В карточке клиента не видит расходную накладную. ПКО видит.
Не могу понять в чем проблема?
В движении все нормально.
 
 
   HawkEye
 
1 - 21.10.16 - 11:49
(0) что отладчик на это говорит?
   VladZ
 
2 - 21.10.16 - 11:51
Возможные причины:
1. Нет движения по указанному контрагенту (возможно есть дубль по этому контрагенту).
2. Карточка клиента - это что? Отчет? СМотреть код отчета. Возможно, по расходной накладной там в коде условие прописано.

Самый надежный способ - отладчик
   Lesine
 
3 - 21.10.16 - 11:53
Отладку не запускала
   HawkEye
 
4 - 21.10.16 - 11:54
(3) ну и правильно, чего зря отладку запускать, само починиться.
   Lesine
 
5 - 21.10.16 - 12:01
Была база Торговля,она работала, потом просто скопировала МДшник и запустили базу без доков, а когда сформировали отчет, в старой есть, а в новой нет
   Lesine
 
6 - 21.10.16 - 12:01
Код не трогали вообще
   HawkEye
 
7 - 21.10.16 - 12:03
(6) отладчик не для того, чтобы трогать код, а для того чтобы понимать как этот код работает, если по самому коду этого не понятно...
   Lesine
 
8 - 21.10.16 - 12:19
(7) Он не ругается
   Ёпрст
 
9 - 21.10.16 - 12:26
(5)
>>>>  потом просто скопировала МДшник и запустили базу без доков, а когда сформировали отчет, в старой есть, а в новой нет

неудивительно, ведь в новой базе НЕТ документов
   Lesine
 
10 - 21.10.16 - 12:28
(9) Документы введи, расходные, расх.розничные, ПКО, но в карточке клиента видит только ПКО
 
 Рекламное место пустует
   Lesine
 
11 - 21.10.16 - 12:29
Уже месяц работаем
   aka AMIGO
 
12 - 21.10.16 - 12:30
(0) Обновлять базу, копируя МД-ник в старую - верный способ эту базу испортить окончательно.
(10) что это за карточка клиента? как ты её запускаешь?
   Lesine
 
13 - 21.10.16 - 12:30
(9) Тоже самое во взаиморасчетах
   Lesine
 
14 - 21.10.16 - 12:32
(12)Я так поступала с бухгалтерией, прекрасно было все..
Отчет>карточка клиента>дальше как пользователь выбирает параметры.. Вот в них и не видит расходные
   RoRu
 
15 - 21.10.16 - 12:34
(14) параметры сравните
   Ёпрст
 
16 - 21.10.16 - 12:36
(14) расходные накладные не толкают регистры/не делают проводки. Верояность второго - 99%. Открой движения документа и сморти
   aka AMIGO
 
17 - 21.10.16 - 12:39
(14) Жаль, у меня нет такого отчета в ТиСе.
Сможешь в конфигураторе сохранить этот свой отчет, как внешний, и прислать мне его на почту?
   aka AMIGO
 
18 - 21.10.16 - 12:40
+17 вот что в моем ТиСе: http://pastenow.ru/13WNI
   RoRu
 
19 - 21.10.16 - 12:42
(17) сначала по правилам, надо фото в профиле поместить)))
   Lesine
 
20 - 21.10.16 - 12:48
(18) У меня примерно также выводится взаиморасчеты
   aka AMIGO
 
21 - 21.10.16 - 12:50
(20) Вот что с "настройкой" : http://pastenow.ru/13WPX
   Lesine
 
22 - 21.10.16 - 12:55
Ребята, ну где ошибка????

Процедура ДвиженияВзаиморасчеты()
        
    ФлагОтгрузки = 1;
    
    спДоговора = глПолучитьСписокКредДоговоров(Контекст);
    
    Если (ВидОперации = 1) Тогда
        ЗнакОплаты = +1; 
        ФлагВозврата = 1;
    КонецЕсли;
    Если (ВидОперации <> 1) Тогда
        ЗнакОплаты = -1; 
        ФлагВозврата = 0;
    КонецЕсли;
    
    ВремРег = СоздатьОбъект("Регистры");    
    
    Для Инд=1 по спФирмы.РазмерСписка() Цикл
        текФирма = спФирмы.ПолучитьЗначение(Инд);
        тбСуммыПогашения = глПолучитьСуммыДляПогашения(Контекст, текФирма);

        // Проверяем возможность кредита 

        Если (ВидОперации <> 1) и (ВидТорговли = Перечисление.ВидыТорговли.Кредит ) 
            и (Константа.РазрешитьПревышениеКредита = Нет) Тогда
                
            глРассчитатьИтогиВзаиморасчетов(Контекст,ВремРег,спФирмы,ЗнакОплаты,Контрагент,);
            тбДолги = глПолучитьИтогиВзаиморасчетов(Контекст,ВремРег, текФирма,ЗнакОплаты, Контрагент,);            
            ДолгКонтрагента = 0;
            ВалютаДолга = ?(ПустоеЗначение(текФирма)=0,Гривня,глВалютаВзаиморасчетов(Контрагент));
            
            Просрочено = 0;
            ПросроченныйДолг = 0;
            
            тбДолги.ВыбратьСтроки();
            Пока тбДолги.ПолучитьСтроку()=1 Цикл
                
                ДолгКонтрагента = ДолгКонтрагента + глПересчет(тбДолги.Долг,ВалютаДолга,Дата_курса,Контрагент.ВалютаВзаиморасчетов,Дата_курса);
                
                Если тбДолги.Долг <= 0 Тогда
                    Продолжить;
                КонецЕсли;
                
                ВидДокКред = тбДолги.КредДокумент.Вид();
                                                        
                Если глЕстьРеквизитШапки("ДатаОплаты",ВидДокКред)=Да Тогда
                    ДатаОплаты = тбДолги.КредДокумент.ДатаОплаты;
                    Если ПустоеЗначение(ДатаОплаты)=1 Тогда
                        ДатаОплаты = тбДолги.КредДокумент.ДатаДок;
                    КонецЕсли;
                Иначе 
                    ДатаОплаты = тбДолги.КредДокумент.ДатаДок + Контрагент.Глубина.Получить(тбДолги.КредДокумент.ДатаДок);
                КонецЕсли;
                
                Если ДатаДок > ДатаОплаты Тогда
                    ПросроченныйДолг = ПросроченныйДолг + тбДолги.Долг;
                    Если Просрочено<(ДатаДок-ДатаОплаты) Тогда
                        Просрочено = ДатаДок-ДатаОплаты;
                    КонецЕсли;
                КонецЕсли;
                
            КонецЦикла;
            
            ДолгКонтрагента = ДолгКонтрагента + глПересчет(Итог("СуммаСНДС"),Валюта,Курс,Контрагент.ВалютаВзаиморасчетов,Дата_Курса);
            СуммаКредита = Контрагент.СуммаКредита.Получить(ДатаДок);                                            
            СуммаКредита = глПересчет(СуммаКредита,Контрагент.ВалютаКредита,ДатаДок,Контрагент.ВалютаВзаиморасчетов,ДатаДок);
            Если ДолгКонтрагента > СуммаКредита Тогда
                глНеПроводить(Контекст,Шаблон("Сумма накладной вместе с текущим долгом клиента ([глФРМ(ДолгКонтрагента,Контрагент.ВалютаВзаиморасчетов,1)]) превышает сумму кредита ([глФРМ(СуммаКредита,Контрагент.ВалютаВзаиморасчетов,1)]). "));
                Возврат;
            КонецЕсли;
            
            Если Просрочено>0 Тогда
                глНеПроводить(Контекст,Шаблон("Просрочена оплата [глФРМ(ПросроченныйДолг,ВалютаДолга,1)] на [Просрочено] дней."));
                Возврат;
            КонецЕсли;
            
        КонецЕсли;               

        глРассчитатьИтогиВзаиморасчетов(Контекст,ВремРег,спФирмы,?(ВидТорговли = Перечисление.ВидыТорговли.Бартер,-ЗнакОплаты,ЗнакОплаты),Контрагент, спДоговора);
        тбДолги = глПолучитьИтогиВзаиморасчетов(Контекст,ВремРег, текФирма,?(ВидТорговли = Перечисление.ВидыТорговли.Бартер,-ЗнакОплаты,ЗнакОплаты), Контрагент, спДоговора);            
        
        глПровестиПоВзаиморасчетам(Контекст, ФлагОтгрузки, ЗнакОплаты, ФлагВозврата, текФирма, тбДолги, тбСуммыПогашения, Контрагент, спДоговора, ВидТорговли, ДокументОснование);
    КонецЦикла;

КонецПроцедуры
   VladZ
 
23 - 21.10.16 - 12:57
(22) Отладчик в руки!
   Lesine
 
24 - 21.10.16 - 12:58
(23)Я проверила
   HawkEye
 
25 - 21.10.16 - 13:02
(24) в руках? )))
   Ёпрст
 
26 - 21.10.16 - 13:02
(24)
1. смотри движения документа в ПРЕДПРИЯТИИ
2. потом уже открывай пофигуратор и смотри в код

ЗЫ: то что в (22) мрак
   HawkEye
 
27 - 21.10.16 - 13:04
(12) судя по "скопировала МДшник и запустили базу без доков" из (5) девчушка просто скопировала метаданные в пустую папочку, так что там нормально все... наверное )
   HawkEye
 
28 - 21.10.16 - 13:05
(24) начни с того, что объясни собравшимся, что такое "Карточка клиента" - это форма? отчет? документ?
   Lesine
 
29 - 21.10.16 - 13:07
(28) Отчет по взаиморасчетам с клиентами
   Это_mike
 
30 - 21.10.16 - 13:08
(22) "Где ошибка?" - там, где всегда. В ДНК!
   Lesine
 
31 - 21.10.16 - 13:08
(27) Нормально, код не трогали
   Lesine
 
32 - 21.10.16 - 13:09
(30)прекрасно.. я не сомневалась..
   RoRu
 
33 - 21.10.16 - 13:09
(31) сч (19) )))
 
 
   HawkEye
 
34 - 21.10.16 - 13:09
(29) уже тепелее... теперь убедись, что у того документа который должен попасть в "отчет по взаиморасчетам", есть движения... видио по регистру Взаиморасчеты....

(31) там не в коде дело, а в объектах и их реквизитах...
   HawkEye
 
35 - 21.10.16 - 13:10
(32) ну и как бы (33) +100
   Масянька
 
36 - 21.10.16 - 13:12
(31) Если "код не трогали":
1. сравнить контрагентов: ПКО и расходная - один и тот же? Дубль?
2. расходная проведена? Что в движениях?

PS Стопудово - дубль контрагентов.
   RoRu
 
37 - 21.10.16 - 13:13
я своё мнение на основании (14) выразил в (15) но ответа не получил
   Это_mike
 
38 - 21.10.16 - 13:15
(36) вангую, что документ не поведен...
   Масянька
 
39 - 21.10.16 - 13:15
(38) Пудов десять... Хотя, нет... Пудов восемь. Два пуда - период не тот.
   uno-group
 
40 - 21.10.16 - 13:16
Константа движение по кассе только ордерами. нетот вид учета. не включен какой то вид учета.
   uno-group
 
41 - 21.10.16 - 13:17
конфы по разному настроены. там многое к константах и реквизитах фирм настраивается. а скопировали только мдшник. вот какуюто настройку и пропустили. исправить настройки и перепровести
   Lesine
 
42 - 21.10.16 - 13:21
(36) Дубля нет, т.к. их всего 10 и все разные
(38) Доки проведены.
(39) период верный
   Lesine
 
43 - 21.10.16 - 13:22
(41) финучет по фирме не выбрали при первом запуске настройки констант.. мешать может??
   Это_mike
 
44 - 21.10.16 - 13:22
(42) ну дык скрин движений в студию...
   aka AMIGO
 
45 - 21.10.16 - 13:23
(42) Посмотри движения регистров документа, который не показывается в отчете.
И покажи картинку в ветке.
   aka AMIGO
 
46 - 21.10.16 - 13:23
(43) вряд-ли.. тут что-то попроще.
   Ёпрст
 
47 - 21.10.16 - 13:25
Она не знает, что такое движение документа и где ЭТО смотрят, о чём вы ?

я ужо справшивал
   HawkEye
 
48 - 21.10.16 - 13:25
(42) перефразируя..... "Движение, Олеся, Движение!" (с)
   Это_mike
 
49 - 21.10.16 - 13:26
(47) тогда ошибка все-таки там, где всегда...
 
 Рекламное место пустует
   Это_mike
 
50 - 21.10.16 - 13:26
(48) "Алло, это Лена из бухгалтерии. У меня на Билайн не встаёт!"©
   HawkEye
 
51 - 21.10.16 - 13:28
(50) ты хотел написать "Олеся"? )
   aka AMIGO
 
52 - 21.10.16 - 13:30
Ладно вам, мужики..

Как смотреть движения: http://pastenow.ru/13WX1

И сами движения: http://pastenow.ru/13WXA
   HawkEye
 
53 - 21.10.16 - 13:31
(52) мы фото ждем...
   Это_mike
 
54 - 21.10.16 - 13:32
(52) в ее конфигурации может не быть ни кнопки "действия", ни пункта "Отчет о движениях", ни самого отчета...
   Это_mike
 
55 - 21.10.16 - 13:32
(53) ню-ню...
   HawkEye
 
56 - 21.10.16 - 13:33
(53) можно и ню )) мы не гордые
   Lesine
 
57 - 21.10.16 - 13:34
Я пришлю движения.. Где и как их брать я знаю, просто отлучилась..
   Lesine
 
58 - 21.10.16 - 13:35
минутку
   Lesine
 
59 - 21.10.16 - 13:41
   Lesine
 
60 - 21.10.16 - 13:41
(47) Умно)) Спасибо на добром слове))
   Это_mike
 
61 - 21.10.16 - 13:42
(60) так сами подтверждаете в (59)...
   HawkEye
 
62 - 21.10.16 - 13:43
(60) эх Олеся Олеся....
   Lesine
 
63 - 21.10.16 - 13:43
(61) подтверждаю что??
   Это_mike
 
64 - 21.10.16 - 13:44
(63) ошибку при репликации
   HawkEye
 
65 - 21.10.16 - 13:45
(63) взаиморасчеты где?
   Lesine
 
66 - 21.10.16 - 13:48
   Это_mike
 
67 - 21.10.16 - 13:50
Беда, коль пироги начнет печи сапожник,
А сапоги тачать пирожник...
©И.А,Крылов, 1813
   aka AMIGO
 
68 - 21.10.16 - 13:52
(66) еще настройки отчета на диалоге покажи
   Это_mike
 
69 - 21.10.16 - 13:53
(68) а зачем? у нее реализация сразу двигает "деньги". раз "сразу деньги" - значит, это розница...
   aka AMIGO
 
70 - 21.10.16 - 13:55
(69) Ну, глянь в (21) - у неё могут не стоять маркеры на доках
   aka AMIGO
 
71 - 21.10.16 - 13:55
(69) А вообще-то ты прав..
   Lesine
 
72 - 21.10.16 - 13:56
   aka AMIGO
 
73 - 21.10.16 - 13:56
.. только откуда взялась таня брусничкина?
   Это_mike
 
74 - 21.10.16 - 13:57
(73) оттуда, откуда все берутся...
   Lesine
 
75 - 21.10.16 - 13:57
С Расходной накладной, по ней же идет и учет
   aka AMIGO
 
76 - 21.10.16 - 13:59
(72) сможешь сохранить этот отчет, как внешний? и выслать мне на почту..
(75) понятно, что с расходной
   Это_mike
 
77 - 21.10.16 - 13:59
(75) ту так _где_ он "идет"? ткните меня носом в "таню брусницу" в (59)
   HawkEye
 
78 - 21.10.16 - 13:59
(75) покажи или сама посмотри движения ПКО который попадает в отчет))
   HawkEye
 
79 - 21.10.16 - 14:00
(76) а чем тебе поможет отчет, если в движениях накладной Брусничку не подвинули? )))
   Масянька
 
80 - 21.10.16 - 14:00
(77) Там все по фирме :)))))))))))))))))))))))))
   Lesine
 
81 - 21.10.16 - 14:00
   aka AMIGO
 
82 - 21.10.16 - 14:02
(81) нет маркера на "ВзаиморасчетахПокупателей"..
   Lesine
 
83 - 21.10.16 - 14:02
(80) по фирме идет списание товара, это управленческий учет по списании партии товара.
   Масянька
 
84 - 21.10.16 - 14:03
(83) Феерично :)
   Lesine
 
85 - 21.10.16 - 14:03
(82)Его нельзя изменить, я на это смотрела
   HawkEye
 
86 - 21.10.16 - 14:04
(81) посмотри движения ПКО убедись, что ПКО двигает Взаиморасчеты.... и поверь, что отчет строится по движениям регистра(-ов) Взаиморасчеты...

после чего выясняй, почему в накладной нет этих движений.
   HawkEye
 
87 - 21.10.16 - 14:05
(84) неее... феерично, это (85)
   Это_mike
 
88 - 21.10.16 - 14:06
(87) ага. пятнично...
   Это_mike
 
89 - 21.10.16 - 14:06
(86) и так понятно. по 81
   Масянька
 
90 - 21.10.16 - 14:07
(87) Только при чем тут Таня? :)))
PS Пятница удалась...
   aka AMIGO
 
91 - 21.10.16 - 14:08
а если перепровести сию Расходную.. Авось движения и появятся :)

ЗЫ. Настораживает это "копирование файла МД.. Нонсенс :)
   Это_mike
 
92 - 21.10.16 - 14:09
(91) для создания новой базы - почему бы и нет?
   aka AMIGO
 
93 - 21.10.16 - 14:09
(90) Как то-есть "причем"? - Таня купила и ушла, а у продавца взаиморасчеты пропали :)
   aka AMIGO
 
94 - 21.10.16 - 14:09
(92) Ммм.. опять ты прав..
   HawkEye
 
95 - 21.10.16 - 14:09
(89) пусть сама лично убедиться... ))

(91) так она же ее провела и так... пустая же база была )
   Это_mike
 
96 - 21.10.16 - 14:10
(93) ну так деньги сразу появились....
   Lesine
 
97 - 21.10.16 - 14:10
(90)При том, что на нее выписана расходная, На нее же я сделала карточку клиента-отчет..
Что не так?
   Масянька
 
98 - 21.10.16 - 14:11
(97) Дурдом...
1. "Деньги" - это самописка?
2. В ПКО есть "Деньги"?
   Масянька
 
99 - 21.10.16 - 14:11
(93) Так не надо было продавать Тане...
   Масянька
 
100 - 21.10.16 - 14:12
Соточка
  1  2   

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует