Вход | Регистрация


1С:Предприятие :: 1С:Предприятие 8 общая

Как в коде написать сравнение?

Как в коде написать сравнение?
Я
   Yrii-ay
 
21.10.16 - 11:42
В документе пользователь выбирает " Склад1 или Склад2  " далее в Материалах он выбирает Номенклатура > Материалы > Сырье и материал для печ. продукции> Самоклеящиеся материалы > Пленки для ламинации и далее выбирает пленки, то что он выбрал нужно вывести на печатную форму.На печатную форму вывести я могу, а вот алгоритм  выбора?
 
 
   butterbean
 
1 - 21.10.16 - 11:44
какой алгоритм выбора? он же уже все выбрал
   Yrii-ay
 
2 - 21.10.16 - 11:46
Нужно вывести на печатную форму все что он выбрал. Вот напр: Если Объект.ГорячееТиснение 
        Тогда  Область.Параметры.Красочность= Область.Параметры.Красочность +     " .Горячее Тиснение" ;
    КонецЕсли;
    
Это я вывел Горячее Тиснение на печать
   Yrii-ay
 
3 - 21.10.16 - 11:48
То есть, он может это выбрать как от первого склада, так и от второго
   Ёпрст
 
4 - 21.10.16 - 11:49
(2)
Область.Параметры.Красочность = ?(Объект.ГорячееТиснение,"Вася горячий","Вася уже остыл");
   Ёпрст
 
5 - 21.10.16 - 11:50
вот какое отношение склад имеет к реквизиту какого-то объекта ? хз.
ТС, можешь по-русски излагать свои мысли ?
А то в (0) и (2) - набор несвязанных букв
   Zamestas
 
6 - 21.10.16 - 11:51
Хоть кто нить понял, что хочет ТС? Или это пятничный квест такой?
   CHerypga
 
7 - 21.10.16 - 11:53
я щас бухше отправил (4) потому что у неё мужа зовут Вася :-D
   Yrii-ay
 
8 - 21.10.16 - 11:54
Придумал как! Всем спасибо.
   ASU_Diamond
 
9 - 21.10.16 - 11:54
(8) код в студию, чтобы потом самому не придумывать
   CHerypga
 
10 - 21.10.16 - 11:55
(8) блеа, а как??? расскажи нам
 
 Рекламное место пустует
   Гипервизор
 
11 - 21.10.16 - 11:57
(8) Будьте добры, помедленнее, я записываю.
   Zamestas
 
12 - 21.10.16 - 12:00
(8) Давай уже колись как реализовал, на основе данных из (0) не получается.
   bolder
 
13 - 21.10.16 - 12:03
(0) ТС , ещё сморозь что нибудь))Да здравствует пятница!
   ajax_new
 
14 - 21.10.16 - 12:06
ТС всех заинтересовал, и соскочил с темы....
   Yrii-ay
 
15 - 21.10.16 - 12:07
Не хочу чтобы смеялись над кодом
   Ёпрст
 
16 - 21.10.16 - 12:08
(15) выкладывай, всё будет по-взрослому. Просто укажут на ошибки, если они есть. Иначе, будет смеятся потом работодатель при твоём увольнении, что гораздо хуже.
   CHerypga
 
17 - 21.10.16 - 12:10
(16) ну я прямо не знаю, а стоит ли ему выкладывать. я конечно могу предположить что пол был ошибочно не изменен в профиле. но Юрий... слегка смущает
   Yrii-ay
 
18 - 21.10.16 - 12:13
Рассмешили)
   novichok79
 
19 - 21.10.16 - 12:15
жесть какая-то, я ничего не понял...
   Yrii-ay
 
20 - 21.10.16 - 12:17
я тоже)
   aleks_default
 
21 - 21.10.16 - 12:20
он хочет вывод всех родителей номенклатуры +склад
   Zamestas
 
22 - 21.10.16 - 12:20
(20) Дык ты выложишь алгоритм  выбора или нет?
   aleks_default
 
23 - 21.10.16 - 12:23
ПолноеНаименование короче
   newbling
 
24 - 21.10.16 - 12:23
(15) Мы ходь по коду поймём что ты в (0) хотел. Не можешь по-русски, пиши по-1сски
   novichok79
 
25 - 21.10.16 - 12:26
вот делал когда-то для справочника Номенклатурные группы

[CODE]
    ТипСтрока = Новый ОписаниеТипов("Строка", , Новый КвалификаторыСтроки(0, ДопустимаяДлина.Переменная));
    СтрокаРезультат = "";

    Если ЗначениеЗаполнено(НоменклатурнаяГруппа) Тогда

        Запрос = Новый Запрос;
        Запрос.Текст = 
        "ВЫБРАТЬ РАЗРЕШЕННЫЕ
        |    НоменклатурныеГруппы.Ссылка КАК Ссылка
        |ИЗ
        |    Справочник.НоменклатурныеГруппы КАК НоменклатурныеГруппы
        |ГДЕ
        |    НоменклатурныеГруппы.Ссылка = &НоменклатурнаяГруппа
        |ИТОГИ ПО
        |    Ссылка ИЕРАРХИЯ";
        
        Запрос.УстановитьПараметр("НоменклатурнаяГруппа", НоменклатурнаяГруппа);
        Результат = Запрос.Выполнить();
        Выборка = Результат.Выбрать(ОбходРезультатаЗапроса.Прямой);
        ПутьКЭлементу = "";

        Пока Выборка.Следующий() Цикл
            
            Если Выборка.ТипЗаписи() = ТипЗаписиЗапроса.ИтогПоИерархии Тогда
                
                Разделитель = ?(ПустаяСтрока(СокрЛП(ПутьКЭлементу)), "", "/");
                ПутьКЭлементу = ПутьКЭлементу + Разделитель + ТипСтрока.ПривестиЗначение(Выборка.Ссылка);

            Иначе Прервать;
            КонецЕсли;

        КонецЦикла;

    //    Если ПустаяСтрока(ПутьКЭлементу) Тогда СтрокаРезультат = "Путь к ном. группе: в корне справочника";

    //    Иначе СтрокаРезультат = "Путь к ном. группе: " + ПутьКЭлементу;

    //    КонецЕсли;


    //Иначе СтрокаРезультат = "Путь к ном. группе: группа не указана";

    
        Если ПустаяСтрока(ПутьКЭлементу) Тогда СтрокаРезультат = "";
        Иначе СтрокаРезультат = "Группа: " + ПутьКЭлементу;
        КонецЕсли;

    Иначе СтрокаРезультат = "Группа не указана";
    
    КонецЕсли;

    ЭлементыФормы.НадписьНоменклатурнаяГруппаРодитель.Заголовок = СтрокаРезультат;
[/CODE]
   aleks_default
 
26 - 21.10.16 - 12:42
я ж говорил
   Базис
 
27 - 21.10.16 - 12:45
Послепечатную обработку учитывать достаточно сложно. Сложней, чем просто полиграфию - но и печать содержит достаточно подводных камней.

Начните с изучения готовых возможностей системы складского учёта. Листы-пачки-килограммы, комплектация. Это для начала.
Потом, сформулировав пожелания, изучите штатные возможности отраслевых решений.
Код первые 3-6 месяцев писать не надо.
   newbling
 
28 - 21.10.16 - 13:30
(27) > Код первые 3-6 месяцев писать не надо.

Я на 2-й день начал писать. Что в этом плохого.


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует