Вход | Регистрация



УПП писали люди с чувством юмора...

УПП писали люди с чувством юмора...
Я
   Господин ПЖ
 
20.10.16 - 12:04
1.3.83.2

ОМ.УправлениеЗапасамиПартионныйУчетФормированиеПроводокРегл

ЗаполнитьСубконтоПоСписаниюТоваровРегл()

*************
            ИначеЕсли ВидСубконто.ВидСубконто = ВидСубконтоДоговоры Тогда
                
                Проводка.СубконтоДт.Вставить(ВидСубконто.ВидСубконто, СтрокаДокумента.ДоговорКонтрагента);
                
            ИначеЕсли ВидСубконто.ВидСубконто = ВидСубконтоКонтрагенты Тогда
                
                Контрагент = Неопределено;
                
                // Для товаров принятых субконто Контрагент - это комитент

                Если СчетВИерархии(Проводка.СчетДт, СчетТоварыПринятые, СтруктураПараметров) Тогда
                    
                    Если НЕ ЗначениеЗаполнено(Контрагент) Тогда
                        Если Движение<>Неопределено Тогда
                            Контрагент = ПолучитьКонтрагентаИзДокументаОприходования(Движение.ДокументОприходования);
                        КонецЕсли;
                    КонецЕсли;
                    
                Иначе
                    
                    Если ЗначениеЗаполнено(СтрокаДокумента.ДоговорКонтрагента) Тогда
                        Контрагент = ПолучитьКонтрагентаИзДоговора(СтрокаДокумента.ДоговорКонтрагента, СтруктураПараметров);
                    КонецЕсли;
                    
                КонецЕсли;
                
                Проводка.СубконтоДт.Вставить(ВидСубконто.ВидСубконто, Контрагент);



что будет в проводках по аналитике если контрагент/договор пустые?

счет/субконто1/субконто2/субконто3

10.7.1/гвоздь/неопределено/пустая ссылка на спр. договоры
 
 
   ShAV
 
1 - 20.10.16 - 12:13
Глядя на типовые я бы сказал, что в 1С работают вообще одни юмористы. И, кстати, иногда кажется, что между собой они очень редко общаются.
   Джинн
 
2 - 20.10.16 - 12:13
На 10.07 всегда есть контрагент и договор.
   Господин ПЖ
 
3 - 20.10.16 - 12:22
>На 10.07 всегда есть контрагент и договор.

еще раз. они могут быть не заполнены
   Джинн
 
4 - 20.10.16 - 12:29
(3) Еще раз - на 10.07 всегда есть контрагент и договор. И они всегда заполнены.
   Ёпрст
 
5 - 20.10.16 - 12:29
(3) ну, наверняка есть проверка на это в коде
   Господин ПЖ
 
6 - 20.10.16 - 12:33
> ну, наверняка есть проверка на это в коде

нет никаких проверок

достаточно буху указать счет не "в том документе" и привет
   lucbak
 
7 - 20.10.16 - 12:34
>>что будет в проводках по аналитике если контрагент/договор пустые?

А это уже не проблема 1С - это проблема пользователя а как известно на пользователей 1су.... :) кушайте, что дают :)
   Джинн
 
8 - 20.10.16 - 12:37
(6) Для переработки давальческого сырья есть свои схема документооборота. Если бух своими кривыми руками лезет мимо нее, то проблемы в заполнением контрагента будут просто цветочками.
   Господин ПЖ
 
9 - 20.10.16 - 12:37
>А это уже не проблема 1С 

угу... ну не смогли аналитику подтянуть - ладно, пользователь кривой-косой-дурак

но субконто проинициалировать адекватно почему нельзя?
   Boleev
 
10 - 20.10.16 - 12:38
(0) вообще этот код не показателен, чтобы ухахатываться над ним всем форумом. (2) прав.
 
 Рекламное место пустует
   MikhaNik
 
11 - 20.10.16 - 12:38
да там много косяков.. которым много лет и никто их не правит

самый простой в "Заявка на расходование средств" подставляется договор по умолчанию... ну ... слов нет .. а если у пользователя нет доступа до этого договора

смысл.. "договор по умолчанию" при множественности организаций где то теряется в далеком прошлом
   Джинн
 
12 - 20.10.16 - 12:39
(9) Дело не в аналитике. Дело в кривых руках пользователя. Исключительно в них.
   Господин ПЖ
 
13 - 20.10.16 - 12:39
>Дело в кривых руках пользователя. Исключительно в них.

чушь собачья
   Джинн
 
14 - 20.10.16 - 12:40
(11) Опять какая-то левая претензия. Если у пользователя нет доступа к договору, то на кой ляд он платеж по нему инициирует?
   Масянька
 
15 - 20.10.16 - 12:40
(12) На "кривые руки пользователя" есть - указки, пистолеты и пр.
А то эску писали (и пишут) - люди с прямыми руками.
   HeKrendel
 
16 - 20.10.16 - 12:40
(14) Потому что разработчики криворукие, но не те кто это придумал, а те кто продукт разработал ;-)
   H A D G E H O G s
 
17 - 20.10.16 - 12:41
УПП прекрасна.
   Джинн
 
18 - 20.10.16 - 12:41
(13) Чушь - это всякие левые наезды в ситуации, когда Вы не разобрались с вопросом. Душите в себе рефлекторные позывы критиковать то, что чем не разобрались до конца.
   Масянька
 
19 - 20.10.16 - 12:42
(17) Согласна - не бывает некрасивых женщин, бывает мало ... (С)
   Мойдодыр
 
20 - 20.10.16 - 12:43
Это ты еще ЕРП не видел )))
   MikhaNik
 
21 - 20.10.16 - 12:43
УПП прекрасна.. когда почти на каждое проведение есть исправление регистров... для УСН там.. вообще ничего нормально не работает в сложных случаях
   Господин ПЖ
 
22 - 20.10.16 - 12:44
>когда Вы не разобрались с вопросом

с каким пилять вопросом???


Контрагент = Неопределено;
                
                // Для товаров принятых субконто Контрагент - это комитент


                Если СчетВИерархии(Проводка.СчетДт, СчетТоварыПринятые, СтруктураПараметров) Тогда
                    
                    Если НЕ ЗначениеЗаполнено(Контрагент) Тогда
                        Если Движение<>Неопределено Тогда
                            Контрагент = ПолучитьКонтрагентаИзДокументаОприходования(Движение.ДокументОприходования);
                        КонецЕсли;
                    КонецЕсли;
                    
                Иначе
                    
                    Если ЗначениеЗаполнено(СтрокаДокумента.ДоговорКонтрагента) Тогда
                        Контрагент = ПолучитьКонтрагентаИзДоговора(СтрокаДокумента.ДоговорКонтрагента, СтруктураПараметров);
                    КонецЕсли;
                    
                КонецЕсли;
                
                Проводка.СубконтоДт.Вставить(ВидСубконто.ВидСубконто, Контрагент);



какого банана тут есть возможность установить неопределено в субконто, если тип определен?
   H A D G E H O G s
 
23 - 20.10.16 - 12:45
(21) Ты просто не видел УТ11/ERP
   Dmitrii
 
24 - 20.10.16 - 12:47
Правильно!
Давайте, как в клюшечных конфигурациях было - пусть зашьют жестко все проводки прямо в код, и чтобы нельзя было ни счет учета(списания) поменять, ни аналитику. Это же круто - всегда есть нужное субконто и всегда на нужном месте и проверку заполнения в проводках запилить (вместо или в дополнение проверки в документе)
   Джинн
 
25 - 20.10.16 - 12:49
(22) С вопросом учета переработки давальческого сырья. Там свои схема документооборота и каждый документ в ней имеет контрагента и договор. Обязательные к заполнению.

Если кто кривыми руками лезет мимо, то это проблема кривых рук. А в данном случае все даже серьезнее - вопрос не в заполнении аналитики, а в том, что сие действие с левыми проводками напрочь рвет партионный учет. С крайне хреновыми последствиями.
   шаэс
 
26 - 20.10.16 - 12:51
(25) а напомните... можно в качестве счета по умолчанию номенклатуре поставить 10.07?
   lucbak
 
27 - 20.10.16 - 12:53
(24) а сейчас, что проводки не в код зашиты?! (к счастью не знаю типовые, но что-то мне подсказывает, что именно там они и находятся)
   Джинн
 
28 - 20.10.16 - 12:54
(26) Да хоть 07 или 21. Вы хотите, чтобы разработчики внедрили искусственный интеллект и заменили им мозг бухгалтера или экономиста?
   Джинн
 
29 - 20.10.16 - 12:55
(27) Где зашиты, где нет. Где жестко прописаны, где автоподстановка с возможностью правки, где вручную. По-разному.
   Господин ПЖ
 
30 - 20.10.16 - 12:55
>Давайте, как в клюшечных конфигурациях было - пусть зашьют жестко все проводки прямо в код
а они их и так "зашили"

ЭтоИнвентарь = (СчетУчета = ПланыСчетов.Налоговый.ИнвентарьИХозяйственныеПринадлежности);

    МассивКодовОпераций = Новый Массив;
    МассивКодовОпераций.Добавить(Перечисления.КодыОперацийПартииМатериаловВЭксплуатации.ВозвратИзЭксплуатации);
    МассивКодовОпераций.Добавить(Перечисления.КодыОперацийПартииМатериаловВЭксплуатации.ВозвратИзЭксплуатацииФикс);
    МассивКодовОпераций.Добавить(Перечисления.КодыОперацийПартииМатериаловВЭксплуатации.СписаниеИзЭксплуатации);
    МассивКодовОпераций.Добавить(Перечисления.КодыОперацийПартииМатериаловВЭксплуатации.СписаниеИзЭксплуатацииФикс);
    
    Если МассивКодовОпераций.Найти(КодОперации) <> Неопределено Тогда
        УчетПоКоличеству = Не ЭтоИнвентарь;
    Иначе
        УчетПоКоличеству = ЭтоИнвентарь;
    КонецЕсли;
    
    Если Не УчетПоКоличеству Тогда
        Количество = 0;
    КонецЕсли;


т.е. наличие "количества" определяется не свойствами счета, а им самим. если счет такой - есть количество, не такой - нет.

это натуральный "magic number" за который принято ипашить подсвечником во всех учебниках
   klikotold
 
31 - 20.10.16 - 12:56
Все проводки и субконто настраиваются в регистре сведений и это очень удобно.
   Господин ПЖ
 
32 - 20.10.16 - 12:56
>Вы хотите, чтобы разработчики внедрили искусственный интеллект и заменили им мозг бухгалтера или экономиста?

мы хотим предсказуемого результата работы
   Krendel
 
33 - 20.10.16 - 13:00
(32) Напиши свое
 
 
   kittystark
 
34 - 20.10.16 - 13:00
вот названия переменных типа
мУдалятьОбъект
мЕстьНДС
действительно вызывают улыбку при быстром аля безрегистровом прочтении, особенно когда начинаешь фантазировать как же тебе НДС-то будет мстить
   Господин ПЖ
 
35 - 20.10.16 - 13:00
(33) сперва добейся?

писали уже.
   Krendel
 
36 - 20.10.16 - 13:00
ВЫ сейчас обсуждаете продукт, который уже с 2012 года имеет устоявшийся функционал
   Джинн
 
37 - 20.10.16 - 13:01
(31) Далеко не все.

(32) Работайте по правилам, предусмотренными конфигурацией и все будет предсказуемо. Будете работать через жпо - получите точно такой же результат. Это компромисс между универсальностью и жесткостью. Закроешь все напрочь - любая нестандартная ситуация в учете остановит работу. Сделаешь очень гибко - первый же залетевший дятел разрушит учет.

В описываемой Вами ситуации проблема в дятле. Научите этого дятла пользоваться предусмотренными для ситуации документами. Самодеятельность в УПП чревата последствиями.
   Boleev
 
38 - 20.10.16 - 13:03
(35) если считаешь, что это ошибка напиши 1С на линию поддержки (если конечно есть подписка на ИТС ПРОФ).
В чем проблема то?
Или хочешь показать, какой ты умный, мол, нашел вот криворукий код и все дураки, один ты в белом платьишке?
   Мойдодыр
 
39 - 20.10.16 - 13:04
(37) От этого г..нокод не перестает быть г..нокодом
   Мойдодыр
 
40 - 20.10.16 - 13:04
(37) Мне кажется что ты поклонник эппл:
Это вы просто телефон не так в руке держите
   Джинн
 
41 - 20.10.16 - 13:04
(34) Вы мне напоминаете слеваря, который критикует Гелентваген не за ходовые или эксплуатационные свойства, а за то, что шильдик под капотом не тем шрифтом написан. Или что откручивать болт крепления тяги нужно ключом на 13, а не на 14. Поверьте, что владелец его оперирует совершенно другими критериями оценки.
   Krendel
 
42 - 20.10.16 - 13:04
(37) EGG это фигня, вот ERP $-)
   Джинн
 
43 - 20.10.16 - 13:07
(39) Нет пределов совершенству. Быдлокода в УПП пачками везде напихано. Как и всяких логических косяков и недоработок. Но в контексте сабжа претензии не совсем обоснованные. Я бы понял еще претензию, что не запретили дятлам делать деструктивные действия с учетом ТМЦ.
   Krendel
 
44 - 20.10.16 - 13:08
(43) И правильно что не запретили, человек умнее машины, а если на работу наняли животных, то фигли плакать?
   Господин ПЖ
 
45 - 20.10.16 - 13:11
>В описываемой Вами ситуации проблема в дятле.

причем тут "дятел"?

это он кривую процедуру написал?

или он ее "не так держит"?
   Мойдодыр
 
46 - 20.10.16 - 13:12
(43) Ты путаешь код и интерфейси методологию
   kittystark
 
47 - 20.10.16 - 13:16
(41) да....  видно сразу - с чуйством юмора тяжело
   Джинн
 
48 - 20.10.16 - 13:16
(45) Вы реально не врубаетесь, что проблема не в заполнении аналитики, а в разрушении учета ТМЦ криворукими пользователями в обход принятой схемы учета?

Мы можете мне мозг тут парить своей упертостью сколько угодно, но жпо всплывет не у меня, а у Вас. А всплывет оно неизбежно. И разгребать придется его потом Вам, а не мне. Вы думаете, что с чувством собственной правоты Вам это делать будет приятнее? Мне то будет ни горячо, ни холодно от этого.
   Джинн
 
49 - 20.10.16 - 13:19
(46) Отнюдь. Проблемы есть во всем перечисленном :)
 
 Рекламное место пустует
   Масянька
 
50 - 20.10.16 - 13:20
(41) ИМХО, владельцы Гелентваген 1С не занимаются. Ни в каком качестве.
И с другой стороны, 1С не позицинируется для владельцев этой хрени. 1С - для ларьков.
   Господин ПЖ
 
51 - 20.10.16 - 13:22
>Вы реально не врубаетесь, что проблема не в заполнении аналитики, а в разрушении учета ТМЦ криворукими пользователями в обход принятой схемы учета?

юзер ничего не рушит. рушит увы упп которая не в состоянии корректно обработать простейшую ситуацию - заполнить аналитику

>в обход принятой схемы учета

кем принята схема в которой количество есть только на ИнвентарьИХозяйственныеПринадлежности ?
   Господин ПЖ
 
52 - 20.10.16 - 13:23
>Работайте по правилам, предусмотренными конфигурацией и все будет предсказуемо.

фантастика на втором этаже
   H A D G E H O G s
 
53 - 20.10.16 - 13:23
Работайте, братья.
   Джинн
 
54 - 20.10.16 - 13:26
(51)
1. Если юзверь делает левую проводку по счету 10.07, то он рушит учет. Данные проводки делаются исключительно специализированными документами типа Передача товаров, Возврат переданных товаров, Получение услуг по переработке и т.п. Во всех есть контрагент и договор.

2. ИнвентарьИХозяйственныеПринадлежности к счету 10.07 не имеет ни малейшего отношения. Вы уже в лирику куда0то.
   Джинн
 
55 - 20.10.16 - 13:28
(53) Работаем таки. 121 лист инструкции для своих дятлов уже. С картинками. Мозг кипит. Передышки требует.
   Aleksey
 
56 - 20.10.16 - 13:29
Джинн
А зачем вообще документы? Пусть юзеры сразу в документ операция пишут цифры
   ShAV
 
57 - 20.10.16 - 13:30
(56) здравая мысль
   Господин ПЖ
 
58 - 20.10.16 - 13:33
(56) низя. в упп за это сразу расстрел положен
   Fish
 
59 - 20.10.16 - 13:33
(50) "ИМХО, владельцы Гелентваген 1С не занимаются. Ни в каком качестве." - Я знаю одного. Правда занимается не в качестве программиста, но тем не менее.
   Вася Теркин
 
60 - 20.10.16 - 13:35
Когда уже голосовалку добавите?
Джин прав
1С не прав
Не хватает прав
Ждите версию PRO
   Джинн
 
61 - 20.10.16 - 13:35
(56) Дык и тут претензии будут - разработчики дали юзверям вписать неправильную цифру. Или не дали возможность ввести отрицательную цифру на 01 счете. Или не дали возможность корреспондировать балансовый с забалансовым счетом. Или "эта ваша программа неправильно баланс заполняет". Или еще 100500 претензий.
   brznzglwgn
 
62 - 20.10.16 - 13:37
Все правильно - написано криво.

Нужно всегда учитывать "криворукость" пользователя.
Тем более здесь это очень легко сделать.

Но есть умники, которые любят покричать что пользователь НЕПРАВ!!!
Хотя написать предохраняющий код 5-10 минут.
   Джинн
 
63 - 20.10.16 - 13:45
(62) Вы затрахаетесь писать "предохраняющий код". Вы исходите из неправильной посылки "да тут на 5 минут" в ситуации, когда проблема известна. Причем еще раз - в данном случае проблема не в заполнении аналитики. Она гораздо серьезнее. Но Вы не сможете заранее знать что взбредет в голову дятлам, чтобы пресечь все 100500 потенциально деструктивных действий, которые они могут изобрести. Более того, потенциально деструктивное действие может в какой-то ситуации быть необходимым. Например чтобы поправить какой-то уже имеющийся косяк дятла малой кровью, но Ваш "предохраняющий код" не даст это.

Более того, категорически утверждаю, что во всем написанном лично Вами я смогу при желании обойти все ваши "предохраняющие коды" и найти массу мест, Вами упущенных. Ваше утверждение посему является голым теоретизированием, сферическим конем в вакууме.
   Господин ПЖ
 
64 - 20.10.16 - 13:48
>Причем еще раз - в данном случае проблема не в заполнении аналитики

опять 25 за корову деньги...
   Джинн
 
65 - 20.10.16 - 13:51
(64) Вы не расслабляетесь тут, а морально готовьтесь сводить в кучу данные регистров и счетов учета. Ручки закупите, чтобы крыжить, бумаги побольше. Вспомните какими отчетами что получать.
   Масянька
 
66 - 20.10.16 - 13:53
(64) Бесполезно...
   Мойдодыр
 
67 - 20.10.16 - 13:55
(63) Именно так итерационно, закрываются все дыры
   Господин ПЖ
 
68 - 20.10.16 - 13:55
(65) это мне говорят люди имеющие 120 листов инструкций...
   Господин ПЖ
 
69 - 20.10.16 - 13:56
>Более того, категорически утверждаю, что во всем написанном лично Вами я смогу при желании обойти все ваши "предохраняющие коды" и найти массу мест, Вами упущенных

п.э. надо сидеть на ж.пе ровно и не делать ничего.

само рассосется
   Мойдодыр
 
70 - 20.10.16 - 13:57
(69) Только показательные расстрелы спасут фирму
   Krendel
 
71 - 20.10.16 - 14:01
(68) Всего 120 листов инструкций
   Джинн
 
72 - 20.10.16 - 14:03
(68) Это только одна по бюджету расходов на производство :) Таких чемодан уже написано и еще чемодан нужно написать.

Увы, понабирают по объявлению, а потом у них отмазки "А мы не знаем как нужно было сделать... У нас инструкции нет". Проблема в том, что инструкция дятлам помочь не может в принципе, если мозга нет. Это все равно что обезьяне дать инструкцию по управлению автомобилем. При этом опытному водителю достаточно показать только особенности данной модели. Но шеф упорно надеется, что нужно переставлять кровати, а не менять млядей.
   oslokot
 
73 - 20.10.16 - 14:05
(58) вдобавок к операциям пусть делают КЗР.
+еще 100500 страниц документации)
   Джинн
 
74 - 20.10.16 - 14:09
(73) Человек, способный правильно заполнить КЗР, априори настолько хорошо знает конфигурацию, что отпадает необходимость вводить такие документы. В противном случае это снова обезьяна с гранатой.
   Krendel
 
75 - 20.10.16 - 14:11
(74) Не уверен что есть люди, которые без подготовки смогут шпарить КЗР, не используя штатных механизмов заполнения регистров ;-)


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует