Вход | Регистрация


отображение в табличной части на форме

отображение в табличной части на форме
Я
   falselight
 
20.10.16 - 06:47
У справочника есть табличная честь.
Она выведена на форму. Есть реквизит актуальность типа булево.
Как по кнопке задать отображение актуальных и не актуальных строк
в этой табличной части?
 
 
   DDwe
 
1 - 20.10.16 - 06:55
(0) ПКМ- установить отбор.
   falselight
 
2 - 20.10.16 - 07:04
как это сделать программно?

&НаКлиенте
Процедура ПриОткрытии(Отказ)
    Для каждого Стр Из Объект.Алгоритмы Цикл
        Если  Стр.Актуальность = Истина Тогда
            Стр.Видимость = Ложь;
        КонецЕсли;
    КонецЦикла; 
КонецПроцедуры
   falselight
 
3 - 20.10.16 - 07:05
(1) по правой кнопке мыши нет установить отбор
   falselight
 
4 - 20.10.16 - 07:09
возможно как то это сделать программно?
   areaho0ray
 
5 - 20.10.16 - 07:12
Табличная часть наверняка как динамический список выведена на форму. Распилите запрос этому списку.
   falselight
 
6 - 20.10.16 - 07:12
(5) сам создал табличную часть у справочника и вывел на форму

так тоже не получается

&НаКлиенте
Процедура ПриОткрытии(Отказ)
    Для каждого Стр Из Объект.Алгоритмы Цикл
        Если  Стр.Актуальность = Ложь Тогда
            Элементы.Алгоритмы.ТекущаяСтрока.Видимость = Ложь;
        КонецЕсли;
    КонецЦикла; 
КонецПроцедуры
// <-
   areaho0ray
 
7 - 20.10.16 - 07:18
(6) И вряд ли получится. Попробуйте сделать это через настройку динамического списка. Настройка происходит через запрос, т.е. вам нужно только в запросе прописать условие вроде
ГДЕ
   ТабличнаяЧасть.Актуальность = &ПараметрОтбора

Сам же параметр передавать через элемент управления на форме, сделать галочку, например.
   falselight
 
8 - 20.10.16 - 07:24
(7) Галочка есть в табличной части, поле актуальность
А как сделать через настройку этого списка? я его нигде не нащел.
   falselight
 
9 - 20.10.16 - 07:31
(7) то есть на форме будет не таблица????
   falselight
 
10 - 20.10.16 - 07:35
(7) туда же нужно и вводить данные и выводить
 
 Рекламное место пустует
   falselight
 
11 - 20.10.16 - 07:40
как же это сделать? задача проще некуда
отображать в таблице строки с полем активность = истина
и не отображать строки с полем активность = ложь
или отображать те и те
как это сделать?????
динамический список только для вывода же?????
мне нужно и для отображения и для ввода данных в табличную часть
   DDwe
 
12 - 20.10.16 - 08:02
(11) УФ?
   falselight
 
13 - 20.10.16 - 08:14
(12) да.
как на счет такого?

&НаКлиенте
Процедура АктуальныеВсе(Команда)
    Если Элементы.Алгоритмы.ОтборСтрок = Неопределено Тогда
        Элементы.Алгоритмы.ОтборСтрок = Новый ФиксированнаяСтруктура("Актуальность", Истина);        
    Иначе
        Элементы.Алгоритмы.ОтборСтрок = Неопределено;            
    КонецЕсли; 
КонецПроцедуры
//

&НаКлиенте
Процедура ПриОткрытии(Отказ)
    //Для каждого Стр Из Объект.Алгоритмы Цикл

    //КонецЦикла;

    Элементы.Алгоритмы.ОтборСтрок = Новый ФиксированнаяСтруктура("Актуальность", Истина);    
КонецПроцедуры

Список тем форума
  Рекламное место пустует
Пользователь не знает, чего он хочет, пока не увидит то, что он получил.
Э. Йодан
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует