Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Получить значение текущей строки в 1С8.3 УТ Уф

Получить значение текущей строки в 1С8.3 УТ Уф
Я
   Casper211
 
19.10.16 - 15:36
Делал это в ОФ вот так.

Процедура СписокДокументовКомментарийПриИзменении(Элемент)
        Заказ = ЭлементыФормы.СписокДокументов.ТекущиеДанные.Ссылка;
    ОбъектДокумента = Заказ.ПолучитьОбъект();
    ОбъектДокумента.Комментарий = Элемент.Значение;
    ОбъектДокумента.Записать();
КонецПроцедуры


 А как сделать на Уф??

&НаКлиенте
Процедура ТоварыНоменклатураПриИзменении(Элемент)
    ТоварыНоменклатураПриИзмененииНаСервере();
КонецПроцедуры

&НаСервере
Процедура ТоварыНоменклатураПриИзмененииНаСервере()
      // вот тут ??

КонецПроцедуры


Спасибо.
 
 
   Casper211
 
1 - 19.10.16 - 15:38
Нужно при изменении номенклатуры переписать ее в документе. Ссылка есть в текущей строке, где есть номенклатура
   Casper211
 
2 - 19.10.16 - 15:54
Есть Управляемая форма
На форме расположена таблица "Товары"
Одна из колонок таблицы "Номенклатура"

В событии формы ПриИзменении для указанной формы я хочу получить ссылку на заказ, который указан в текущей строке.

Пробовал :

ЭтаФорма.ЭлементыФормы.Товары.ТекущиеДанные.Номенклатура
или
ЭтаФорма.Элементы.Товары.ТекущиеДанные.Номенклатура

не работает
   программистище
 
3 - 19.10.16 - 15:57
Элементы.Товары.ТекущиеДанные.Номенклатура
   Casper211
 
4 - 19.10.16 - 16:04
(3)Спасибо!!! И потом вот так?

&НаКлиенте
Процедура ТоварыНоменклатураПриИзменении(Элемент)
    НужныйЗаказ = Элементы.Товары.ТекущиеДанные.Заказ;
    НужнаяНоменклатура=Элементы.Товары.ТекущиеДанные.Номенклатура;
    ТоварыНоменклатураПриИзмененииНаСервере(НужныйЗаказ,НужнаяНоменклатура);
КонецПроцедуры


&НаСервере
Процедура ТоварыНоменклатураПриИзмененииНаСервере()
      ОбъектДокумента = НужныйЗаказ.ПолучитьОбъект();


КонецПроцедуры
   Casper211
 
5 - 19.10.16 - 16:10
(2) Вот так будет норм?

&НаКлиенте
Процедура ТоварыНоменклатураПриИзменении(Элемент)
    НужныйЗаказ = Элементы.Товары.ТекущиеДанные.Заказ;
    НужнаяНоменклатура=Элементы.Товары.ТекущиеДанные.Номенклатура;
    НужныйНомерСтроки =Элементы.Товары.ТекущиеДанные.НомерСтрокиВТчТоварыЗаказа;
    ТоварыНоменклатураПриИзмененииНаСервере(НужныйЗаказ,НужнаяНоменклатура,НужныйНомерСтроки);
КонецПроцедуры

&НаСервере
Процедура ТоварыНоменклатураПриИзмененииНаСервере(НужнийЗаказ,НужнаяНоменклатура,НужныйНомерСтроки)
        ОбъектДокумента = НужнийЗаказ.ПолучитьОбъект();
    Для каждого СтрокаТЧТовары из ОбъектДокумента.Товары Цикл
        Если СтрокаТЧТовары.НомерСтроки =НужныйНомерСтроки Тогда
            СтрокаТЧТовары.Номенклатура=НужнаяНоменклатура;
        КонецЕсли;
    КонецЦикла;
    ОбъектДокумента.Записать();
КонецПроцедуры
   mpei
 
6 - 19.10.16 - 16:14
(5) СтрокаТЧТовары.Номенклатура=НужнаяНоменклатура;

это что?
ты ж коммент хотел записать вроде в тек строке..
   программистище
 
7 - 19.10.16 - 16:47
(5) это из обработки ты хочешь менять номенклатуру в документе, при этом сразу записывать документ при изменении номенклатуры

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует