Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

УФ. Как изменить элемент на форме?

УФ. Как изменить элемент на форме?
Я
   Zareshivatel
 
19.10.16 - 09:37
На форму вынесена константа, в которой будет храниться путь к файлу.
Вот так ее выбираю:

&НаКлиенте
Процедура АдресХранилищаФайловНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
    СтандартнаяОбработка = Ложь;
    РежимДиалога = РежимДиалогаВыбораФайла.ВыборКаталога;
    ДиалогВыбораКаталога = Новый ДиалогВыбораФайла(РежимДиалога);
    ДиалогВыбораКаталога.МножественныйВыбор = Ложь;
    ДиалогВыбораКаталога.Заголовок = "Выберите путь для сохранения файлов";
    Если ДиалогВыбораКаталога.Выбрать() Тогда
        УстановитьКонстанту(ДиалогВыбораКаталога.Каталог);
    КонецЕсли;    
КонецПроцедуры

&НаСервере
Процедура УстановитьКонстанту(Значение)
    Константы.АдресХранилищаФайлов.Установить(Значение);
КонецПроцедуры

Константа сохраняется. Но значение в поле формы остается старым. Если закрыть форму и открыть снова, то и поле меняется, соответственно. 
Пробовал         Элементы.АдресХранилищаФайлов.ОбновитьТекстРедактирования();
Видимо, что-то не то. Подскажите, что нужно дописать, чтобы поле формы сразу менялось?
 
 
   Timon1405
 
1 - 19.10.16 - 09:42
ОбновитьИнтерфейс()
   trooba
 
2 - 19.10.16 - 09:43
(0) ОбновитьОтображениеДанных() ?
   Zareshivatel
 
3 - 19.10.16 - 09:51
(1) (2) оба варианта мое поле не изменяют, к сожалению
   IlyaSR
 
4 - 19.10.16 - 09:54
ОповеститьОбИзменении()
   Lexey_
 
5 - 19.10.16 - 09:56
(0) АдресХранилищаФайлов реквизит формы?
тогда: АдресХранилищаФайлов = ДиалогВыбораКаталога.Каталог
   Zareshivatel
 
6 - 19.10.16 - 09:57
(4) а в качестве ссылки мне что передавать?
   IlyaSR
 
7 - 19.10.16 - 10:06
(6) точно, пардон не посмотрел, что ссылка на объект передается
   Aleksandr N
 
8 - 19.10.16 - 10:09
(0) Это нужно делать на клиенте через основной реквизит формы (как правило "НаборКонстант" он называется).
   Zareshivatel
 
9 - 19.10.16 - 10:14
(8) Спасибо!!!

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует