Вход | Регистрация


Режим отладки

Режим отладки
Я
   ZloyRafa
 
19.10.16 - 07:43
Привет.
Есть документ, в нем кнопка, как мне при нажатии на нее посмотреть какой программный код начинает работать ?
На примере, кнопка заполняет ТЧ, на обработчике события кнопки не вижу ничего кроме диалоговых сообщений, но заполнение происходит, хотел бы увидеть, куда при нажатии начинает "заползать" команда
 
 
   DDwe
 
1 - 19.10.16 - 07:48
(0) Привет.
А какие сообщения?
   ZloyRafa
 
2 - 19.10.16 - 07:49
Процедура Заполнить(Команда)
    
    Если НЕ ЗарплатаКадрыКлиент.ОрганизацияЗаполнена(Объект) Тогда 
        Возврат;
    КонецЕсли;
    
    Если Объект.РасчетРезерваОтпусков.Количество() > 0 Тогда
        Оповещение = Новый ОписаниеОповещения("ЗаполнитьЗавершение", ЭтотОбъект);
        ТекстВопроса = Нстр("ru = 'Табличные части документа будут очищены. Продолжить?'");
        ПоказатьВопрос(Оповещение, ТекстВопроса, РежимДиалогаВопрос.ДаНет);
    Иначе
        ЗаполнитьЗавершение(КодВозвратаДиалога.Да, Неопределено);
    КонецЕсли;

КонецПроцедуры
   ZloyRafa
 
3 - 19.10.16 - 07:50
ЗаполнитьЗавершение(КодВозвратаДиалога.Да, Неопределено)
как всегда, пока писал вопрос, нашел ответ
   Mauser
 
4 - 19.10.16 - 07:55
(3) Это что же получается, если писать вопросы в комментариях к коду, то можно и без форума обойтись, что-ли? Не верю!
   ZloyRafa
 
5 - 19.10.16 - 08:21
Ну, хотя, хотел бы узнать, если ли какие-то способы отслеживать какая часть модуля сейчас выполняется ? процедуры нашел, но точек останова там тьму нужно, хотел бы посмотреть как работает сама кнопка по шагам.
Сможет кто подсказать, как можно это сделать?

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует