Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Получить значение при изменении

Получить значение при изменении
Я
   alexshape
 
18.10.16 - 14:59
Есть документ расходная накладная с таблицей, при добавлении в него товара и заполнении колонки Номенклатура, это значение должно записываться в переменную,

в чем моя ошибка 

&НаКлиенте
Процедура СписокНоменклатурыНоменклатураПриИзменении(Элемент)
    ЗначениеСтроки = ЭтаФорма.Элементы.СписокНоменклатуры.ТекущаяСтрока; 
    Строка = ЗначениеСтроки.СписокНоменклатурыНоменклатура;    
КонецПроцедуры
 
 
   Lexey_
 
1 - 18.10.16 - 15:02
(0) Синтаксических ошибок не обнаружено!
   Vadim_37
 
2 - 18.10.16 - 15:05
мб заменить строка на моястрока
   Лефмихалыч
 
3 - 18.10.16 - 15:07
при добавлении в кого "в него"?
которое значение надо в переменную записывать?
в какую переменную?
зачем?
   Лефмихалыч
 
4 - 18.10.16 - 15:10
хотя, очевидно, проблема в том, что СписокНоменклатурыНоменклатура - это элемент формы, а реквизит табличной части называется Номенклатура.
   polosov
 
5 - 18.10.16 - 15:11
(0)
СписокНоменклатуры - это что? Табличная часть?
Тогда

&НаКлиенте
Процедура СписокНоменклатурыНоменклатураПриИзменении(Элемент)
  МояПеременная = Элементы.СписокНоменклатуры.ТекущиеДанные.Номенклатура; 
КонецПроцедуры
   polosov
 
6 - 18.10.16 - 15:12
+(5)
Или

&НаКлиенте
Процедура СписокНоменклатурыНоменклатураПриИзменении(Элемент)
  МояПеременная = Элемент.ТекущиеДанные.Номенклатура; 
КонецПроцедуры
   alexshape
 
7 - 18.10.16 - 15:45
(5) да, все решилось, спасибо

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует