Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

проблемы с загрузкой xml

проблемы с загрузкой xml
Я
   dimidoff
 
18.10.16 - 13:54
Процедура ПутьКФайлуНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
    СтандартнаяОбработка = Ложь;
    ДиалогОткрытияФайла = Новый     ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
    ДиалогОткрытияФайла.ПроверятьСуществованиеФайла = Истина;
    ДиалогОткрытияФайла.МножественныйВыбор = Ложь;
    ДиалогОткрытияФайла.Заголовок = "Выберите загружаемый файл";
 
    Если ДиалогОткрытияФайла.Выбрать() Тогда             
                ПутьКФайлу = ДиалогОткрытияФайла.ПолноеИмяФайла;
    Иначе
        Возврат;
    КонецЕсли; 

КонецПроцедуры

файл не выбирается почему-то. это в Бух 3.0. на управляемой форме. реквизит ПутьКФайлу строковый создал, на форме в свойствах поля ввода все указал. че ему не нравится, не понятно
 
 
   azernot
 
1 - 18.10.16 - 14:09
&НаКлиенте
Процедура ДиалогВыбораФайлаДляЗагрузкиЗавершение(ВыбранныеФайлы, ДополнительныеПараметры) Экспорт
    
    Если ВыбранныеФайлы <> Неопределено Тогда
        
        Объект.ПутьКФайлу = ВыбранныеФайлы.Получить(0);
        
    КонецЕсли;
    
КонецПроцедуры

&НаКлиенте
Процедура ПутьКФайлуНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
    ДополнительныеПараметры = Новый Структура("Форма", ЭтаФорма);
    
    ОписаниеОповещения = Новый ОписаниеОповещения("ДиалогВыбораФайлаДляЗагрузкиЗавершение", ЭтотОбъект, ДополнительныеПараметры);
    ДиалогВыбора = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
    ДиалогВыбора.Фильтр                  = НСтр("ru = 'Файл загрузки данных'") + " (*.xml)|*.xml";
    ДиалогВыбора.Заголовок               = НСтр("ru = 'Выберите загружаемый файл'");
    ДиалогВыбора.ПредварительныйПросмотр = Ложь;
    ДиалогВыбора.Расширение              = "xml";
    ДиалогВыбора.ИндексФильтра           = 0;
    ДиалогВыбора.ПолноеИмяФайла          = "*.xml";
    ДиалогВыбора.МножественныйВыбор      = Ложь;
    ДиалогВыбора.Показать(ОписаниеОповещения);
    
КонецПроцедуры

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует