Вход | Регистрация



команда на открытие отчета

команда на открытие отчета
Я
   falselight
 
18.10.16 - 08:56
Подскажите как лучше открывать один и тот же отчет из разных документов?
Отчет показывает движения документа.
 
 
   birkoFFFF
 
1 - 18.10.16 - 08:59
Создать общую команду
   falselight
 
2 - 18.10.16 - 09:12
(1) подскажите пожалуйста как правильно будет команда?



&НаКлиенте
Процедура ОбработкаКоманды(ПараметрКоманды, ПараметрыВыполненияКоманды)
    //Вставить содержимое обработчика.

    //ПараметрыФормы = Новый Структура("", );

    //ОткрытьФорму("ОбщаяФорма.", ПараметрыФормы, ПараметрыВыполненияКоманды.Источник, ПараметрыВыполненияКоманды.Уникальность, ПараметрыВыполненияКоманды.Окно, ПараметрыВыполненияКоманды.НавигационнаяСсылка);

КонецПроцедуры
   falselight
 
3 - 18.10.16 - 09:13
(1) как сделать что бы команда вызывалась из каждого документа? Это в команде прописывается?
   DDwe
 
4 - 18.10.16 - 09:18
(3) Посмотри как в типовой сделано.
   falselight
 
5 - 18.10.16 - 09:20
(4) какую именно команду?
   falselight
 
6 - 18.10.16 - 09:45
как что бы она поячвилась в документах?
   Lexey_
 
7 - 18.10.16 - 09:47
(6) в типовых смотрел уже?
   DDwe
 
8 - 18.10.16 - 09:49
(5) Ту, которая открывает отчет.
   falselight
 
9 - 18.10.16 - 10:03
(7) смотрю
создал команду


&НаКлиенте
Процедура ОбработкаКоманды(ПараметрКоманды, ПараметрыВыполненияКоманды)
    //Вставить содержимое обработчика.

    //ПараметрыФормы = Новый Структура("", );

    //ОткрытьФорму("ОбщаяФорма.", ПараметрыФормы, ПараметрыВыполненияКоманды.Источник, ПараметрыВыполненияКоманды.Уникальность, ПараметрыВыполненияКоманды.Окно, ПараметрыВыполненияКоманды.НавигационнаяСсылка);

    ОткрытьФорму("Отчет.ДвиженияДокумента.Форма.ФормаОтчета")//, ПараметрыФормы, ПараметрыВыполненияКоманды.Источник, ПараметрыВыполненияКоманды.Уникальность, ПараметрыВыполненияКоманды.Окно, ПараметрыВыполненияКоманды.НавигационнаяСсылка);

КонецПроцедуры

в свойствах группа, -
Командная панель формы.Важное

но она все равно не появляется у документа
   falselight
 
10 - 18.10.16 - 10:06
(7) в типовых там через кнопку отчеты все делается
она формируется прогруммно
 
 Рекламное место пустует
   DDwe
 
11 - 18.10.16 - 10:11
(10) Ну так и ты прогруммно формируй, загвоздка в чем?
   falselight
 
12 - 18.10.16 - 10:15
муторно там программно
я хочу так вывести
   falselight
 
13 - 18.10.16 - 10:17
создал команду
в свойствах группа, - 
Командная панель формы.Важное 
в режиме конфигуратора она есть
в см. также
но в предприятии нет
   falselight
 
14 - 18.10.16 - 10:45
Подскажите сейчас как мне открывая этот отчет передавать туда ссылку на документ? Что бы он открывал уже по документу, на котором этот отчет и формируется?
   falselight
 
15 - 18.10.16 - 10:45
&НаКлиенте
Процедура ОбработкаКоманды(ПараметрКоманды, ПараметрыВыполненияКоманды)
    //Вставить содержимое обработчика.

    ПараметрыФормы = Новый Структура("Документ", ПараметрКоманды.Ссылка);
    //ОткрытьФорму("ОбщаяФорма.", ПараметрыФормы, ПараметрыВыполненияКоманды.Источник, ПараметрыВыполненияКоманды.Уникальность, ПараметрыВыполненияКоманды.Окно, ПараметрыВыполненияКоманды.НавигационнаяСсылка);

    ОткрытьФорму("Отчет.ДвиженияДокумента.Форма.ФормаОтчета")//, ПараметрыФормы, ПараметрыВыполненияКоманды.Источник, ПараметрыВыполненияКоманды.Уникальность, ПараметрыВыполненияКоманды.Окно, ПараметрыВыполненияКоманды.НавигационнаяСсылка);

КонецПроцедуры
   falselight
 
16 - 18.10.16 - 10:55
всего лишь

&НаКлиенте
Процедура ОбработкаКоманды(ПараметрКоманды, ПараметрыВыполненияКоманды)
    //Вставить содержимое обработчика.

    ПараметрыФормы = Новый Структура("Документ", ПараметрКоманды.Ссылка);
    //ОткрытьФорму("ОбщаяФорма.", ПараметрыФормы, ПараметрыВыполненияКоманды.Источник, ПараметрыВыполненияКоманды.Уникальность, ПараметрыВыполненияКоманды.Окно, ПараметрыВыполненияКоманды.НавигационнаяСсылка);

    ОткрытьФорму("Отчет.ДвиженияДокумента.Форма.ФормаОтчета", ПараметрыФормы);
КонецПроцедуры


и в тип параметра команды нужно проставить документы
   falselight
 
17 - 18.10.16 - 12:52
   falselight
 
18 - 18.10.16 - 12:53
как вывести меню перейти в документах????
оказывается не в меню печать нужно делать вывод
   falselight
 
19 - 18.10.16 - 12:54
   falselight
 
20 - 18.10.16 - 12:59
ставлю в свойствах команды
Группа - панель навигации формы- перейти

но ничего в режиме предприятия не появляется
   falselight
 
21 - 18.10.16 - 16:25
вроде простая задача
вывести отчет в разделе 
панель навигации формы перейти
делаю в команде это
но её нет на форме ((((


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует