Вход | Регистрация


1С:Предприятие :: 1С:Предприятие 8 общая

Проверка на несоответствие 2х типов

Проверка на несоответствие 2х типов
Я
   88g88
 
17.10.16 - 13:45
Приветствую форумчвне.
Есть код. Заполняет строку результатом запроса.
В результате интересующий параметр находится в одном поле.
кодом пытаюсь исключить ненужные параметры из перебора.
Пока Результат2.Следующий() цикл
Если не Результат2.ТипСвязи = Перечисления.ТипыКонтактнойИнформации.Телефон или Перечисления.ТипыКонтактнойИнформации.АдресЭлектроннойПочты тогда
Продолжить;
ИначеЕсли Результат2.ТипСвязи = Перечисления.ТипыКонтактнойИнформации.Телефон тогда
Данные.Параметры.Телефон = Результат2.Представление;
ИначеЕсли Результат2.ТипСвязи = Перечисления.ТипыКонтактнойИнформации.АдресЭлектроннойПочты тогда    
Данные.Параметры.Почта = Результат2.Представление;
КонецЕсли;
КонецЦикла;    



Если не Результат2.ТипСвязи = Перечисления.ТипыКонтактнойИнформации.Телефон или Перечисления.ТипыКонтактнойИнформации.АдресЭлектроннойПочты тогда


на один параметр реагирует нормально, на два ругается. подскажите как исключить ненужные строки.
 
 
   88g88
 
1 - 17.10.16 - 13:46
{Форма.ФормаОтчета.Форма(116)}: Преобразование значения к типу Булево не может быть выполнено
                Если не Результат2.ТипСвязи = Перечисления.ТипыКонтактнойИнформации.Телефон или Перечисления.ТипыКонтактнойИнформации.АдресЭлектроннойПочты тогда
   Lexey_
 
2 - 17.10.16 - 13:55
(1) Результат2.ТипСвязи = Перечисления.ТипыКонтактнойИнформации.Телефон
Или Результат2.ТипСвязи = Перечисления.ТипыКонтактнойИнформации.АдресЭлектроннойПочты
   Рэйв
 
3 - 17.10.16 - 14:20
НЕ Результат2.ТипСвязи = (Перечисления.ТипыКонтактнойИнформации.Телефон или Перечисления.ТипыКонтактнойИнформации.АдресЭлектроннойПочты)
   Рэйв
 
4 - 17.10.16 - 14:22
хотя не..(3)-  сторно:-) Это я погоряился:-)
   88g88
 
5 - 17.10.16 - 14:29
(2) Ну да, все логично.
Я понадеялся что так поймет а до этого не догадался))))
Спасибо!!!!
   88g88
 
6 - 17.10.16 - 14:32
(2) Хоты этот париант второй параметр не включает в условие.
отрабатывает
на продолжить
   88g88
 
7 - 17.10.16 - 14:33
то - есть не рассматривает его вообще. (6)
   88g88
 
8 - 17.10.16 - 14:48
и ошибок не выдает. ни контекстных ни в обработке. (2)
   88g88
 
9 - 17.10.16 - 14:48
(8) прикольно))
   88g88
 
10 - 17.10.16 - 14:49
пока вопрос открыт
 
 Рекламное место пустует
   catena
 
11 - 17.10.16 - 14:50
(10)Наверное после НЕ надо в скобки взять выражение, а ?
   catena
 
12 - 17.10.16 - 14:51
У логического НЕ самый высокий приоритет. Если скобок нет, сначала выполняются все НЕ, потом уже И, ИЛИ...
   88g88
 
13 - 17.10.16 - 14:54
(12) убрать не и поставить <> вместо = ?
   88g88
 
14 - 17.10.16 - 14:55
по человечески напишу)))

убрать "не" и поставить "<>" вместо "=" ?
   catena
 
15 - 17.10.16 - 14:56
(14)Ну или так... Скобки платно выдают, да?
   88g88
 
16 - 17.10.16 - 14:58
Так все не заполнил))) и опять ошибок не выдал. все норм но не работает))))))))))))))
Если Результат2.ТипСвязи <> Перечисления.ТипыКонтактнойИнформации.Телефон или Результат2.ТипСвязи <> Перечисления.ТипыКонтактнойИнформации.АдресЭлектроннойПочты тогда
   singlych
 
17 - 17.10.16 - 15:01
(16) И

(0)
Если Результат2.ТипСвязи = Перечисления.ТипыКонтактнойИнформации.Телефон тогда
Данные.Параметры.Телефон = Результат2.Представление;
ИначеЕсли Результат2.ТипСвязи = Перечисления.ТипыКонтактнойИнформации.АдресЭлектроннойПочты тогда    
Данные.Параметры.Почта = Результат2.Представление;
Иначе
// тот самый случай, когда ТипСвязи ни Телефон, ни АдресЭлектронной почты

КонецЕсли;
   88g88
 
18 - 17.10.16 - 15:05
(12) Читай, и придет озарение)))))))))))))

первый раз такой код использую, что это такое? )))))

Если не (Результат2.ТипСвязи = Перечисления.ТипыКонтактнойИнформации.Телефон или Результат2.ТипСвязи = Перечисления.ТипыКонтактнойИнформации.АдресЭлектроннойПочты) тогда
   88g88
 
19 - 17.10.16 - 15:06
(18) И блин работает (12) Спасибо!!!
   88g88
 
20 - 17.10.16 - 15:07
(3) этот попробую сейчас
   88g88
 
21 - 17.10.16 - 15:09
(20) не, тоже на булево ругается
   singlych
 
22 - 17.10.16 - 15:10
   88g88
 
23 - 17.10.16 - 15:14
(22) да с логикой норм вроде.
вот что скобки так использовать можно не знал)))))))))))))))
как то не доводилось до этого)))))))))))
   88g88
 
24 - 17.10.16 - 15:14
(22) все смайлики ими рисую ))))))


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует