Вход | Регистрация



не удается записать характеристику

не удается записать характеристику
Я
   falselight
 
17.10.16 - 09:45
Ошибка выходит на строке записать.
От чего это может быть?

||

                НайденнаяХарактеристика = Справочники.ХарактеристикиНоменклатуры.НайтиПоНаименованию(СокрЛП(СтрТ.СерияНоменклатуры),1,, НоваяСтрока.Номенклатура);
                Если НайденнаяХарактеристика = Справочники.ХарактеристикиНоменклатуры.ПустаяСсылка() Тогда
                    НоваяХарактеристика              = Справочники.ХарактеристикиНоменклатуры.СоздатьЭлемент();
                    НоваяХарактеристика.Владелец     = НоваяСтрока.Номенклатура;
                    НоваяХарактеристика.Наименование = СокрЛП(СтрТ.СерияНоменклатуры);
                    НоваяХарактеристика.Записать();
                    НоваяСтрока.Характеристика = НоваяХарактеристика.Ссылка;
                    Сообщить("У номенклатуры " + СТРОКА(НоваяСтрока.Номенклатура) + " создана новая характеристика " + СТРОКА(НоваяХарактеристика.Ссылка));
                Иначе
                    НоваяСтрока.Характеристика = НайденнаяХарактеристика;
                КонецЕсли;
||
{Форма.Форма.Форма(377)}: Ошибка при вызове метода контекста (Записать)
                    НоваяХарактеристика.Записать();
по причине:
Не удалось записать: "Характеристика номенклатуры"!
 
 
   butterbean
 
1 - 17.10.16 - 09:47
ну дык в отладчике посмотри
   Mauser
 
2 - 17.10.16 - 09:47
Отказ = Истина
Ищи.
   falselight
 
3 - 17.10.16 - 09:47
в сообщить ещё последнее вот это вывелось

Наименование должно состоять из 20 цифр!
   Nuobu
 
4 - 17.10.16 - 09:48
(3) Так найди это сообщение в конфигураторе.
   falselight
 
5 - 17.10.16 - 09:48
(1) я там и смотрю
всегда нормально загружалось, сейчас вот так
не пойму в чем дело

(2) отказ в своем коде?
   falselight
 
6 - 17.10.16 - 09:50
(2) отказ только тут

&НаКлиенте
Процедура ПриОткрытии(Отказ)
    //Объект.КаталогДляФайлов = "C:\Обмен из КА в Розницу";

    Объект.КаталогДляФайлов = "C:\";
    ПроводитьДокументы      = Истина;
КонецПроцедуры
   falselight
 
7 - 17.10.16 - 09:50
(4) нет у меня в коде такого
   Dyspho
 
8 - 17.10.16 - 09:52
(7) а при чем твой твой код? ctrl +shift+F галка на Модули и в строке поиска Наименование должно состоять из 20 цифр!
не?
   torgm
 
9 - 17.10.16 - 09:54
На всяк случай поиск запусти так "Наименование должно состоять из" а то вдруг число програмно формируется.
   falselight
 
10 - 17.10.16 - 10:01
(8)(9) в не запароленных модулях не найдено!
мне не понятно почему перестал работать код в (0)
что за ерунда, и что править?
 
 Рекламное место пустует
   Lexey_
 
11 - 17.10.16 - 10:03
(10) код в (0) перестал работать потому, что "Наименование должно состоять из 20 цифр!"
   falselight
 
12 - 17.10.16 - 10:08
ну это в модуле типовой конфигурации

        Если ПроверятьНаименованиеХарактеристикиНаНаличие20Цифр Тогда
            
            Если КоличествоЦифрПроверки = 0 Тогда
                КоличествоЦифрПроверки = 20;
            КонецЕсли;
                
            Если СтрДлина(Наименование)<>КоличествоЦифрПроверки Тогда
                
                ОбщегоНазначенияКлиентСервер.СообщитьПользователю("Наименование должно состоять из "+КоличествоЦифрПроверки+" цифр!",,,,Отказ);
                
            Иначе
   falselight
 
13 - 17.10.16 - 10:08
(11) первый раз это вижу, ранее же все работало!!!!
может это нововведенный код?
   Dyspho
 
14 - 17.10.16 - 10:10
(13) Ну попробуй  сделать наименование 1245678901234567890 )
   Lexey_
 
15 - 17.10.16 - 10:11
(13) ну, значит, ранее условие выполнялось, что тут удивительного?
   falselight
 
16 - 17.10.16 - 10:13
(14) что значит сделать?????
в наименование идет серия
   Dyspho
 
17 - 17.10.16 - 10:15
(16) И какая там серия? И какая у тех, где "всё работало!!!!"?
   Dark_Warrior
 
18 - 17.10.16 - 10:22
Доработка старая, а релиз новый?
   falselight
 
19 - 17.10.16 - 10:23
отказ есть да!!!!
сейчас там сделано если наименование серии меньше 20 символов то все ломается
что за бред не пойму (((((
   falselight
 
20 - 17.10.16 - 10:24
(19+)  наименование характеристики точнее
   falselight
 
21 - 17.10.16 - 10:24
(17) да не имеет значения какая, по разному было
что вбито то и работало
   falselight
 
22 - 17.10.16 - 10:25
ломается сейчас на этой 79530161014
так как оно менее 20 символов
   Dyspho
 
23 - 17.10.16 - 10:25
(19) ну убери отказ если тееб пофигу
   Dyspho
 
24 - 17.10.16 - 10:26
(22) а почему раньше было не менее 20 ?
   falselight
 
25 - 17.10.16 - 10:26
(23) это в коде конфигурации
и отказ истина только в процедуре сообщение пользователю
   chelentano
 
26 - 17.10.16 - 10:26
(22) а чё, отключить это "ПроверятьНаименованиеХарактеристикиНаНаличие20Цифр" - не вариант?
   falselight
 
27 - 17.10.16 - 10:28
(24) номенклатура сейчас вроде говорят приходит с 20 значными сериями
   falselight
 
28 - 17.10.16 - 10:28
(26) это же в коде нужно
   FIXXXL
 
29 - 17.10.16 - 10:30
вот это ПроверятьНаименованиеХарактеристикиНаНаличие20Цифр  что?
переменная, параметр сеанса, константа? чего включали в последнее время в базе?
   chelentano
 
30 - 17.10.16 - 10:32
(28) см. (29)
Может, это какая-то настройка и её можно отключить
   ColonelAp4u
 
31 - 17.10.16 - 10:37
А можешь еще показать что написано в модуле справочника при записи или перед записью?
   ColonelAp4u
 
32 - 17.10.16 - 10:37
что бы мы не гадали вдруг кто то константу включил на проверку длины вводимой характеристики


Список тем форума
  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует