Вход | Регистрация


При переносе УТ 10.3 - БП 2.0 пытается записать Документ с нулевой датой

При переносе УТ 10.3 - БП 2.0 пытается записать Документ с нулевой датой
Я
   kIR
 
13.10.16 - 15:09
Доброго дня!
Переносу из общей базы ут 10.3 по различным организациям  в бп 2.0
По некоторым организациям переносит без проблем,а по одной в момент  переноса выпадает след.ошибка
Ошибка записи объекта
    ТипОбъекта             =  Поступление товаров и услуг
    Объект                 =  Поступление товаров и услуг  от 01.01.0001 0:00:00
    ОписаниеОшибки         =  Ошибка при вызове метода контекста (Записать): Значение поля "Дата" не может быть пустой датой
    ПозицияМодуля          =  ВнешняяОбработка.УниверсальныйОбменДаннымиXML.МодульОбъекта(4788)
    КодСообщения           =  26

Ошибка при загрузке данных: {ВнешняяОбработка.УниверсальныйОбменДаннымиXML.МодульОбъекта(4795)}: Ошибка записи объекта
    ТипОбъекта             =  Поступление товаров и услуг
    Объект                 =  Поступление товаров и услуг  от 01.01.0001 0:00:00
    ОписаниеОшибки         =  Ошибка при вызове метода контекста (Записать): Значение поля "Дата" не может быть пустой датой
    ПозицияМодуля          =  ВнешняяОбработка.УниверсальныйОбменДаннымиXML.МодульОбъекта(4788)
    КодСообщения           =  26


При этом таких документов у меня нет нигде с 0й датой. нип о одной организации. пеоренос  свойств типовой, при загрузке дописано следующее:
Объект.ВидОперации = Перечисления.ВидыОперацийПоступлениеТоваровУслуг.ПокупкаКомиссия;
Объект.СпособЗачетаАвансов = Перечисления.СпособыЗачетаАвансов.Автоматически;
Объект.СчетУчетаРасчетовСКонтрагентом = ПланыСчетов.Хозрасчетный.РасчетыСПоставщиками;
Объект.СчетУчетаРасчетовПоАвансам = ПланыСчетов.Хозрасчетный.РасчетыПоАвансамВыданным;

Если Объект.товары.Количество()>0 Тогда
    Для Каждого Строка из Объект.Товары Цикл
        СчетаУчета = БухгалтерскийУчет.ПолучитьСчетаУчетаНоменклатуры(Объект.Организация, Строка.Номенклатура, Объект.Склад);
        МетаданныеДокумента = Объект.Метаданные();
        Строка.СчетУчета  = СчетаУчета.СчетУчетаДоп;
        Строка.СчетУчетаНДС = СчетаУчета.СчетУчетаНДС;
    КонецЦикла;
КонецЕсли;

Если Объект.Услуги.Количество()>0 Тогда
    Для Каждого Строка из Объект.Услуги Цикл
        СчетаУчета = БухгалтерскийУчет.ПолучитьСчетаУчетаНоменклатуры(Объект.Организация, Строка.Номенклатура, Объект.Склад);
        МетаданныеДокумента = Объект.Метаданные();
        Строка.СчетЗатрат   = СчетаУчета.СчетУчета;
        Строка.СчетУчетаНДС = СчетаУчета.СчетУчетаНДС;
        Строка.Субконто1     = СчетаУчета.Субконто1;
        Строка.Субконто2   = СчетаУчета.Субконто2;
        Строка.Субконто3   = СчетаУчета.Субконто3;

    КонецЦикла;
КонецЕсли;




Куда рыть?откуда беда может быть?

Спасибо
 
 
   kIR
 
1 - 13.10.16 - 15:10
Ой,не ПРИ загрузке, а ПОСЛЕ загрузки
   kIR
 
2 - 13.10.16 - 15:53
Пробовал бить периоды - все равно порой находит какой нибудь подобный документ
   kIR
 
3 - 14.10.16 - 11:49
Все,нашел косяк - было 5 полученных счет-фактур кривых,  у которых основание было "объект не найден"

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует