Вход | Регистрация


заполнение регистра сведений штрихкоды

заполнение регистра сведений штрихкоды
Я
   falselight
 
13.10.16 - 13:08
Необходимо заполнить независимый непериодический регистр сведений штрихкоды. Подскажите пожалуйста как заполнять поля:

измерения:

Штрихкод     - Характеристика.ТипыШтрихКодов
типШтрихКода - ПланВидовХарактеристик.ТипыШтрихКодов

реквизит:

ПредставлениеШтрихКода - Характеристика.ТипыШтрихКодов

||

    //

    Для каждого СтрТ Из Таблица Цикл
        НаборЗаписей          = РегистрыСведений.Штрихкоды.СоздатьНаборЗаписей(); 
        ТекущаяНоменклатура   = Справочники.Номенклатура.НайтиПоНаименованию(СокрЛП(СтрТ.Номенклатура), 1);
        ТекущаяХарактеристика = Справочники.ХарактеристикиНоменклатуры.НайтиПоНаименованию(СокрЛП(СтрТ.Серия), 1,, ТекущаяНоменклатура); 
        Если ТекущаяНоменклатура = Справочники.Номенклатура.ПустаяСсылка() Тогда
            Сообщить("Номенклатура " + СокрЛП(СтрТ.Номенклатура) + " не найдена !");
            Продолжить;
        КонецЕсли;
        Если ТекущаяХарактеристика = Справочники.ХарактеристикиНоменклатуры.ПустаяСсылка() Тогда
            Сообщить("Характеристика номенклатуры " + СокрЛП(СтрТ.Номенклатура) +" - "+ СокрЛП(СтрТ.Серия) + " не найдена !");
            Продолжить;
        КонецЕсли;
        НаборЗаписей.Отбор.Владелец.Установить(ТекущаяНоменклатура);
        НаборЗаписей.Отбор.Характеристика.Установить(ТекущаяХарактеристика); 
        НоваяЗапись                 = НаборЗаписей.Добавить(); 
        НоваяЗапись.Владелец        = ТекущаяНоменклатура; 
        НоваяЗапись.Характеристика = ТекущаяХарактеристика; 
        УпакНоменкл                = Справочники.УпаковкиНоменклатуры.НайтиПоНаименованию(СокрЛП(СтрТ.ЕдиницаИзмерения), "1",, ТекущаяНоменклатура);
        Если УпакНоменкл <> Справочники.УпаковкиНоменклатуры.ПустаяСсылка() Тогда
            НоваяЗапись.Упаковка = УпакНоменкл; 
        КонецЕсли;
        НоваяЗапись.Штрихкод     =
        НоваяЗапись.ТипШтрихКода =
        НаборЗаписей.Записать();           
    КонецЦикла;
КонецПроцедуры
//
 
 
   mehfk
 
1 - 13.10.16 - 13:12
2000 р.
   falselight
 
2 - 13.10.16 - 13:13
это можно так наверное

        НоваяЗапись.ТипШтрихКода = ПланыВидовХарактеристик.ТипыШтрихкодов.НайтиПоНаименованию(СокрЛП(СтрТ.ТипШтрихКода));


А что прописывать в штрихкод ?
Имеет тип Характеристика.ТипыШтрихКодов.
   falselight
 
3 - 13.10.16 - 13:20
Как найти вот это программно Характеристика.ТипыШтрихКодов по значению СтрТ. Штрихкод ?
   falselight
 
4 - 13.10.16 - 13:21
конфигурация Розница
   falselight
 
5 - 13.10.16 - 13:24
НоваяЗапись.ШтрихКод = СокрЛП(СтрТ.ШтрихКод);

наверное так?
если ШтрихКод имеет тип Характеристика.ТипыШтрихКодов.
   falselight
 
6 - 13.10.16 - 13:52
почему может не записывать данные в регистр?
||
    Для каждого СтрТ Из Таблица Цикл
        НаборЗаписей          = РегистрыСведений.Штрихкоды.СоздатьНаборЗаписей(); 
        ТекущаяНоменклатура   = Справочники.Номенклатура.НайтиПоНаименованию(СокрЛП(СтрТ.Номенклатура), 1);
        ТекущаяХарактеристика = Справочники.ХарактеристикиНоменклатуры.НайтиПоНаименованию(СокрЛП(СтрТ.Серия), 1,, ТекущаяНоменклатура); 
        Если ТекущаяНоменклатура = Справочники.Номенклатура.ПустаяСсылка() Тогда
            Сообщить("Номенклатура " + СокрЛП(СтрТ.Номенклатура) + " не найдена !");
            Продолжить;
        КонецЕсли;
        Если ТекущаяХарактеристика = Справочники.ХарактеристикиНоменклатуры.ПустаяСсылка() Тогда
            Сообщить("Характеристика номенклатуры " + СокрЛП(СтрТ.Номенклатура) +" - "+ СокрЛП(СтрТ.Серия) + " не найдена !");
            Продолжить;
        КонецЕсли;
        НаборЗаписей.Отбор.Владелец.Установить(ТекущаяНоменклатура);
        НаборЗаписей.Отбор.Характеристика.Установить(ТекущаяХарактеристика); 
        НоваяЗапись                 = НаборЗаписей.Добавить(); 
        НоваяЗапись.Владелец        = ТекущаяНоменклатура; 
        НоваяЗапись.Характеристика = ТекущаяХарактеристика; 
        УпакНоменкл                = Справочники.УпаковкиНоменклатуры.НайтиПоНаименованию(СокрЛП(СтрТ.ЕдиницаИзмерения), 1,, ТекущаяНоменклатура);
        Если УпакНоменкл <> Справочники.УпаковкиНоменклатуры.ПустаяСсылка() Тогда
            НоваяЗапись.Упаковка = УпакНоменкл; 
        КонецЕсли;
        НоваяЗапись.ТипШтрихКода           = ПланыВидовХарактеристик.ТипыШтрихкодов.НайтиПоНаименованию(СокрЛП(СтрТ.ТипШтрихКода));
        НоваяЗапись.Штрихкод                = СокрЛП(СтрТ.Штрихкод);
        НоваяЗапись.ПредставлениеШтрихкода = СокрЛП(СтрТ.Штрихкод);
        НаборЗаписей.Записать();           
    КонецЦикла;
   falselight
 
7 - 13.10.16 - 13:55
не заполняется только вот эта запись

НоваяЗапись.Упаковка = УпакНоменкл;

но это же не критично наверное?
проверка заполнения стоит не проверять

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует