Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Удалить периодические реквизиты

v7: Удалить периодические реквизиты
Я
   work92
 
13.10.16 - 11:04
Может кто подскажет есть справочник  Основные Средства Нужно удалить периодические реквизиты Идентификатор ВосстановительнаяСтоимость как  правильно прописать коде.
Процедура Выполнить()
     Основные = СоздатьОбъект("Справочник.ОсновныеСредства");
  
 
   Основные.ВыбратьЭлементы(); 
   Пока  Основные.ПолучитьЭлемент()=1 Цикл 
   ПерВал = СоздатьОбъект("Периодический");
   ПерВал.ИспользоватьОбъект(как тут в);
   ПерВал.ВыбратьЗначения();
   Пока ПерВал.ПолучитьЗначение() = 1 Цикл
      
      
         ПерВал.Удалить();
      
КонецЦикла;
КонецЦикла
КонецПроцедуры
 
 
   work92
 
1 - 13.10.16 - 11:11
Как правильно прописать строку ПерВал.ИспользоватьОбъект(«»тут»»); 
Идентификатор ВосстановительнаяСтоимость
   Fedor-1971
 
2 - 13.10.16 - 11:14
(0) пробовал Основные.ТекущийЭлемент()?
   Builder
 
3 - 13.10.16 - 11:14
Продам СП, дорого!
ИспользоватьОбъект(<?>)
Синтаксис:
ИспользоватьОбъект(<ИмяРеквизита>,<Объект>)
Назначение:
Сопоставляет объект типа 'Периодический' периодическому реквизиту справочника или периодической константе.
Возвращает: 1 - если вызов метода закончился успешно, 0 - иначе.
Параметры:
<ИмяРеквизита> - строка с названием периодического реквизита справочника или периодической константы;
<Объект> - значение элемента справочника, для которого задается применение периодического реквизита (для констант не нужен).
   work92
 
4 - 13.10.16 - 11:16
Процедура Выполнить()
     Основные = СоздатьОбъект("Справочник.ОсновныеСредства");
   Основные.НайтиПокоду("01");
      ГруппаОС = Основные.ТекущийЭлемент(); 
      
      Основные.ИспользоватьРодителя(ГруппаОС);
 
   Основные.ВыбратьЭлементы(); 
   Пока  Основные.ПолучитьЭлемент()=1 Цикл 
   ПерВал = СоздатьОбъект("Периодический");
   ПерВал.ИспользоватьОбъект("ВосстановительнаяСтоимость",Основные.ТекущийЭлемент);
   ПерВал.ВыбратьЗначения();
   Пока ПерВал.ПолучитьЗначение() = 1 Цикл
      
      
         ПерВал.Удалить();
      
КонецЦикла;
КонецЦикла
КонецПроцедуры
   Это_mike
 
5 - 13.10.16 - 11:17
(4) на скобках - экономит?
   work92
 
6 - 13.10.16 - 11:19
Укажите в каком месте ошибка.
   work92
 
7 - 13.10.16 - 11:20
Пишет
ПерВал.ИспользоватьОбъект("ВосстановительнаяСтоимость",Основные.ТекущийЭлемент);
{D:\БУХГАЛТЕРИЯ ОТ 13102016\ОЧИСТКА.ERT(12)}: Поле агрегатного объекта не обнаружено (ТекущийЭлемент)
   Fedor-1971
 
8 - 13.10.16 - 11:22
(6) Основные.ТекущийЭлемент - ?
ГруппаОС = Основные.ТекущийЭлемент(); 

Странно в одной процедуре, у тебя экран в 10" что она не помещается целиком?

(7) не удивительно.
   work92
 
9 - 13.10.16 - 11:23
Проверил работает. Всем Спасибо
   Эльниньо
 
10 - 13.10.16 - 13:54
Стоп. А выборка не сбивается?
 
 Рекламное место пустует

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует