Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Как вызвать обработку при добавлении новой записи

Как вызвать обработку при добавлении новой записи
Я
   MAPATNK2
 
12.10.16 - 15:59
Здравствуйте. Такая проблема. Есть у нас SQL база и регистр заполняется по ней, как таковой формы у него нет, просто по реквизитам собирается. Регистр этот телефонных звонков, т.е кто и когда куда звонил. Пишу оповещатель, который будет отправлять сообщение в телеграмм пользователю, если ему не дозвонились. Только вот в чем проблема. Нужно, чтобы при добавлении новой записи в регистр сведений вызывалась обработка, проверяла на условие, и если все ок, тогда отправляла. Финты типа (ПриЗаписи (в форме записи)) не прокатывают, эта процедура вообще не вызывается. Обновление регистра писал не я, не знаю как в него записи добавляются. Нужно просто, чтобы при добавлении новой записи вызывалась обработка. Как это сделать? Вариантов нужно много, потому как большинство известных мы опробовали. Заранее спасибо
 
 
   DrShad
 
1 - 12.10.16 - 16:02
с этого и нужно было начинать что ты не прогер 1С, естественно что при записи из формы не вызывается ибо формы нет
   DrShad
 
2 - 12.10.16 - 16:03
используй при записи из модуля набора записей
   MAPATNK2
 
3 - 13.10.16 - 10:33
(2) Можно поподробней, как это осуществить?
   MAPATNK2
 
4 - 13.10.16 - 10:34
(2) Где этот модуль набора записей?
   Naf_kultura
 
5 - 13.10.16 - 10:36
ПКМ - открыть модуль набора записей
   MAPATNK2
 
6 - 13.10.16 - 10:39
Ясно. Модуль открыли. Добавили код:
Процедура ПриЗаписи(Отказ)
    vv = ЭтаФорма.ЭлементыФормы.ВходящийНомер.Значение;
    мм = ЭтаФорма.ЭлементыФормы.ИсходящийНомер.Значение;
    дат = ЭтаФорма.ЭлементыФормы.Дата.Значение;
    Если СтрДлина(vv)>9 тогда
        запрос = новый запрос;
        Запрос.Текст =       
        "ВЫБРАТЬ
        |    КонтактнаяИнформация.Объект,
        |    КонтактнаяИнформация.Вид,
        |    КонтактнаяИнформация.Представление
        |ИЗ
        |    РегистрСведений.КонтактнаяИнформация КАК КонтактнаяИнформация
        |ГДЕ КонтактнаяИнформация.Вид = &ВидКон и
        |   КонтактнаяИнформация.Представление = &Ном";
        Запрос.УстановитьПараметр("ВидКон",справочники.ВидыКонтактнойИнформации.НайтиПоКоду("000000069"));
        Запрос.УстановитьПараметр("Ном",мм);
        Результат = Запрос.Выполнить().Выгрузить();
        Если Результат.Количество()>0 тогда
        Польз = Результат[0].Объект;
        запрос1 = новый запрос;
        Запрос1.Текст =       
        "ВЫБРАТЬ
        |    КонтактнаяИнформация.Объект,
        |    КонтактнаяИнформация.Вид,
        |    КонтактнаяИнформация.Представление
        |ИЗ
        |    РегистрСведений.КонтактнаяИнформация КАК КонтактнаяИнформация
        |ГДЕ КонтактнаяИнформация.Вид = &ВидКон и
        |   КонтактнаяИнформация.Объект = &Ном";
        Запрос1.УстановитьПараметр("ВидКон",справочники.ВидыКонтактнойИнформации.НайтиПоКоду("000000111"));
        Запрос1.УстановитьПараметр("Представление",Польз);
        Результат1 = Запрос1.Выполнить().Выгрузить();
            Если Результат1.Количество()> 0 тогда
                IDTel = Результат1[0].Представление;
                Токен = "248221822:AAEVaXZ7OaNeZDgQnDGa7erOCc6kSPRZxv4";
                Ресурс = "bot" + Токен + "/sendMessage?chat_id=" + СтрЗаменить(Формат(IDTel, "ЧДЦ=; ЧС=; ЧРГ=."), ".", "") + "&text= " + "Вам только что звонил абонент с номером -  8"+vv+" Дата разговора: "+дат+". ";
                Соединение  =  Новый HTTPСоединение("api.telegram.org",443,,,,,Новый ЗащищенноеСоединениеOpenSSL());
                Запрос = Новый HTTPЗапрос(Ресурс);
                Ответ = Соединение.Получить(Запрос);
                //сообщить(vv);

            КонецЕсли;
        КонецЕсли;
    КонецЕсли;
КонецПроцедуры


Конечно не поперло. Не подскажете как получить данные которые записываются типа "ЭлементыФормы.ВходящийНомер.Значение"?
   MAPATNK2
 
7 - 13.10.16 - 10:41
Или тут нужно по особому код писать? Конечно понимаю, что всем будет лень полностью описать как пользоваться этим модулем, но может есть примеры7
   DrShad
 
8 - 13.10.16 - 10:46
вообще не понятно что ты хочешь сделать и нафига тебе форма на серванте?
   Naf_kultura
 
9 - 13.10.16 - 10:47
(6) забудь про форму, ее нет
   Naf_kultura
 
10 - 13.10.16 - 10:47
и представляю как все это будет тормозить
 
 Рекламное место пустует
   MAPATNK2
 
11 - 13.10.16 - 11:06
Всем спасибо, все сделал. Ничего не тормозит))
   MAPATNK2
 
12 - 13.10.16 - 11:07
(8) Я для примера привел обращение к форме. Тут же я использую для каждого ЭтотОбъект

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует