Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Отключение зависших сеансов на сервере.

Отключение зависших сеансов  на сервере.
Я
   Юзер123
 
12.10.16 - 10:19
Доброго дня.

Подскажите пож-та, как можно по расписанию отключать зависшие сеансы?.
Бывает такое, что при глюках в сети сеансы зависают.  И ночные копии средствами 1С не проходят.  Или по той же причине блокируются документы.  

В общем очень актуальный вопрос.
Помогите. Пожта
 
 
   Asaqura
 
1 - 12.10.16 - 10:22
Терминалка?
   Юзер123
 
2 - 12.10.16 - 10:24
нет.  Клиент - сервер.
   John83
 
3 - 12.10.16 - 15:54
в регл. задании

СеансыИнформационнойБазы = ПолучитьСеансыИнформационнойБазы();

Для Каждого СеансИБ Из СеансыИнформационнойБазы Цикл
    Если ПредставлениеПриложения(СеансИБ.ИмяПриложения) = "Конфигуратор" Тогда
        Продолжить;
    КонецЕсли;
    Если СеансИБ.Пользователь = Неопределено Тогда
        Продолжить;
    КонецЕсли;
    Если СеансИБ.Пользователь.Роли.Содержит(Метаданные.Роли.ПолныеПрава) Тогда
        Продолжить;
    КонецЕсли;
    
    
    Сообщение = "";
    Отключено = СоединенияИБКлиентСервер.ОтключитьСеанс(СеансИБ.НомерСеанса, Сообщение);

КонецЦикла;

Список тем форума
Рекламное место пустует  Рекламное место пустует
Здесь можно задать вопрос "Как сделать?" и получить кучу ответов, что тебе это делать не надо. Ymryn
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует