Вход | Регистрация


Вывести две диаграммы в рядок (горизонтально)

Вывести две диаграммы в рядок (горизонтально)
Я
   myr4ik07
 
11.10.16 - 15:46
Есть 3 диаграммы, 2 диаграммы мне нужно вывести одна возле другой, а третью под выше диаграммами
Макет = РеквизитФормыВЗначение("Объект").ПолучитьМакет("Макет"); 
 
 Д1Макет = Д1(Макет);
 Д2Макет = Д2(Макет);
 Д3Макет = Д3(Макет);
 
// Д1Макет и т.д. - табдок в который помещается диаграмма, которая // береться из макета


 Результат.Присоединить(Д1Макет);
 Результат.Присоединить(Д2Макет);
 Результат.Вывести(Д3Макет);

как бы должно вывести две табдок (диаграммы) в рядок?

но выводит все  3 диаграммы в столбик.
 
 
   myr4ik07
 
1 - 11.10.16 - 15:55
Результат - табдок на форме (управл форма)
   myr4ik07
 
2 - 11.10.16 - 16:42
?
   anatoly
 
3 - 11.10.16 - 18:13
...вывести 7 взаимно-перепендикулярных красных линий... рядком.
   Мойдодыр
 
4 - 11.10.16 - 18:15
Д1Макет = Макет.ПолучитьОбласть("Строка|Колонка")
   myr4ik07
 
5 - 13.10.16 - 10:54
(4) и чет не могу понять как его присобачить к моей ситуации
   myr4ik07
 
6 - 13.10.16 - 11:53
Дошло, в макете нужно задать имя для горизонтальной области и вертикальной.

Процедура Сформировать()
        Макет = РеквизитФормыВЗначение("Объект").ПолучитьМакет("Макет"); 
    
        Д1Макет = Д1(Макет);
    Д2Макет = Д2(Макет);
        
    Результат.Вывести(Д1Макет);
    Результат.Присоединить(Д2Макет);

КонецПроцедуры

Функция Д1(Макет)
    
    График = Макет.ПолучитьОбласть("Д1|Д1Г");
    
КонецФункции

Функция Д2(Макет)
    
    График = Макет.ПолучитьОбласть("Д2|Д2Г");

КонецФункции

спасибо (4)

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует