Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Слетела синхронизация УТ 11.1.x - БП 3.0.44.x после обновления БП

Слетела синхронизация УТ 11.1.x - БП 3.0.44.x после обновления БП
Я
   1C_User_1992
 
11.10.16 - 11:06
После обновления бухгалтерии предприятия на версию больше чем 3.0.44.123 синхронизация с нетиповой УТ 11.1.x слетает.
Это связано с тем что 1С БП с версии 3.0.44.123 стала поддерживать универсальный формат обмена данными.
Инструкция как решить эту проблему не ломая УТ. Мож кому поможет, я голову порядком поломал.

1. Открываем в конфигураторе обновленную базу БП.
Далее через Поддержка - Настройка поддержки включаем возможность изменения конфигурации с сохранением поддержки.
2. Открываем общий модуль "ОбменДаннымиПереопределяемый", находим процедуру "ПолучитьПланыОбмена", и добавляем предпоследней строчку:
ПланыОбменаПодсистемы.Добавить(Метаданные.ПланыОбмена.ОбменУправлениеТорговлейБухгалтерияПредприятия30); где "ОбменУправлениеТорговлейБухгалтерияПредприятия30", это план обмена используемый до обновления. сохраняем.
3. В режиме предприятия В Администрирование - настройка синхронизации данных, у нашей настройки синхронизации через кнопки "Настроить", "параметры синхронизации данных" подгружаем правила конвертации объектов и правила регистрации объектов (они слеают при обновлении). Взять эти правила нужно подняв архив базы до обновления и выгрузить из ее настроек синхронизации эти правила.

Спасибо. Может кому поможет
 
 
   Boleev
 
1 - 11.10.16 - 11:16
Это бот от компании 1С.
   1C_User_1992
 
2 - 11.10.16 - 11:19
(1) Почему?)
   m0528
 
3 - 11.10.16 - 11:35
Охренеть
   zak555
 
4 - 11.10.16 - 11:36
почему расширениями  не пользовался ?
   Мойдодыр
 
5 - 11.10.16 - 11:40
(4) Переопределить модуь можно только в 8.3.9
   zak555
 
6 - 11.10.16 - 11:41
(5) ну да
   m0528
 
7 - 11.10.16 - 12:16
(1) Подскажите, пожалуйста, откуда эта информация:

"В конфигурации "Бухгалтерия предприятия" поддерживается обмен только с актуальными версиями Управления торговлей. Сейчас это версия 11.2. Обмен с данной конфигурацией поддерживается только в универсальном формате.
...
Позже будет удален и план обмена, срок окончательного удаления пока не определен." 

УТ 11.1.10.199 и БП 3.0.44 ?
   m0528
 
8 - 13.10.16 - 15:40
Вопрос актуален. Есть у кого информация о планах об удалении плана обмена(простите за тавтологию) БП-УТ?
...Или больше никому это не интересно и вопрос не актуален?
   Boleev
 
9 - 13.10.16 - 20:01
(7) от разработчиков.
   Барматолог
 
10 - 07.11.16 - 15:41
Поясните, пожалуйста

Захожу в модуль ОбменДаннымиПереопределяемый и вижу там, что ссылки на планы все заполняются, в т.ч и ОбменУправлениеТорговлейБухгалтерияПредприятия30.
Что еще нужно добавлять?
Процедура ПолучитьПланыОбмена(ПланыОбменаПодсистемы) Экспорт
    
    ОбменДаннымиУТУП.СписокПлановОбмена(ПланыОбменаПодсистемы);
    
КонецПроцедуры


Процедура СписокПлановОбмена(ПланыОбменаПодсистемы) Экспорт
    
    ЭтоБазоваяВерсия = СтандартныеПодсистемыСервер.ЭтоБазоваяВерсияКонфигурации();
    
    ПланыОбменаПодсистемы.Добавить(Метаданные.ПланыОбмена.СинхронизацияДанныхЧерезУниверсальныйФормат);
    Если Не ЭтоБазоваяВерсия Тогда
        
        ПланыОбменаПодсистемы.Добавить(Метаданные.ПланыОбмена.ОбменУправлениеТорговлейДокументооборот);
        ПланыОбменаПодсистемы.Добавить(Метаданные.ПланыОбмена.ОбменУправлениеТорговлейДокументооборот20);
        ПланыОбменаПодсистемы.Добавить(Метаданные.ПланыОбмена.ОбменУправлениеТорговлей_11_0_РозничнаяТорговля_1_0);
        ПланыОбменаПодсистемы.Добавить(Метаданные.ПланыОбмена.ОбменУправлениеТорговлейРозница);
        ПланыОбменаПодсистемы.Добавить(Метаданные.ПланыОбмена.ОбменУправлениеТорговлейБухгалтерияПредприятия);
        ПланыОбменаПодсистемы.Добавить(Метаданные.ПланыОбмена.ОбменУправлениеТорговлейБухгалтерияПредприятия30);
        
        ПланыОбменаПодсистемы.Добавить(Метаданные.ПланыОбмена.ОбменУправлениеТорговлейБухгалтерияПредприятияКОРП);
        ПланыОбменаПодсистемы.Добавить(Метаданные.ПланыОбмена.ОбменУправлениеТорговлейБухгалтерияПредприятияКОРП30);
        ПланыОбменаПодсистемы.Добавить(Метаданные.ПланыОбмена.Полный);
        ПланыОбменаПодсистемы.Добавить(Метаданные.ПланыОбмена.СОтборами);
        
    КонецЕсли;
    
КонецПроцедур
 
 Рекламное место пустует
   1C_User_1992
 
11 - 09.11.16 - 12:44
(10) Добрый день.
Поясните пожалуйста. До обновления БП у вас обмен работал нормально?
А версии ут и бП напишите пожалуйста.
   1C_User_1992
 
12 - 09.11.16 - 12:50
// Определяет список планов обмена, которые используют функционал подсистемы обмена данными.

//
// Параметры:

// ПланыОбменаПодсистемы - Массив - Массив планов обмена конфигурации,
//  которые используют функционал подсистемы обмена данными.

//  Элементами массива являются объекты метаданных планов обмена.
//

// Пример тела процедуры:
//

// ПланыОбменаПодсистемы.Добавить(Метаданные.ПланыОбмена.ОбменБезИспользованияПравилКонвертации);
// ПланыОбменаПодсистемы.Добавить(Метаданные.ПланыОбмена.ОбменСБиблиотекойСтандартныхПодсистем);

// ПланыОбменаПодсистемы.Добавить(Метаданные.ПланыОбмена.РаспределеннаяИнформационнаяБаза);
//

Процедура ПолучитьПланыОбмена(ПланыОбменаПодсистемы) Экспорт
    
    ПланыОбменаПодсистемы.Добавить(Метаданные.ПланыОбмена.Обмен1С_КАМИН_ЗарплатаБухгалтерия30);
    ПланыОбменаПодсистемы.Добавить(Метаданные.ПланыОбмена.Полный);
    ПланыОбменаПодсистемы.Добавить(Метаданные.ПланыОбмена.ПоОрганизации);
    ПланыОбменаПодсистемы.Добавить(Метаданные.ПланыОбмена.ОбменУправлениеТорговлей103БухгалтерияПредприятия30);
    ПланыОбменаПодсистемы.Добавить(Метаданные.ПланыОбмена.АвтономнаяРабота);
    ПланыОбменаПодсистемы.Добавить(Метаданные.ПланыОбмена.ОбменЗарплата3Бухгалтерия3);
    ПланыОбменаПодсистемы.Добавить(Метаданные.ПланыОбмена.СинхронизацияДанныхЧерезУниверсальныйФормат);
    ПланыОбменаПодсистемы.Добавить(Метаданные.ПланыОбмена.ОбменРозница1Бухгалтерия3);
    //++ 11.10.2016 изменений объектов нет

    ПланыОбменаПодсистемы.Добавить(Метаданные.ПланыОбмена.ОбменУправлениеТорговлейБухгалтерияПредприятия30);
    //-- 11.10.2016


    
    УчетОбособленныхПодразделений.ПолучитьПланыОбмена(ПланыОбменаПодсистемы);
    
КонецПроцедуры
   1C_User_1992
 
13 - 09.11.16 - 12:51
(12) Вот как у меня выглядит текст модуля предопределеяемый
Мб у вас версия другая.
   1C_User_1992
 
14 - 09.11.16 - 12:52
Попробуйте мб так.
Процедура ПолучитьПланыОбмена(ПланыОбменаПодсистемы) Экспорт
    
    ОбменДаннымиУТУП.СписокПлановОбмена(ПланыОбменаПодсистемы);
//Вставил

ПланыОбменаПодсистемы.Добавить(Метаданные.ПланыОбмена.ОбменУправлениеТорговлейБухгалтерияПредприятия30);

//Вставил    

КонецПроцедуры

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует