Вход | Регистрация



Причины возникновения задвоения значений характеристик номенклатуры

Причины возникновения задвоения значений характеристик номенклатуры
Я
   falselight
 
10.10.16 - 11:21
Может ли данный код, делать дубли подобных значений справочника характеристики номенклатуры 861512030456745 ? То есть задваивать одни и те же значения.

||
                НайденнаяХарактеристика = Справочники.ХарактеристикиНоменклатуры.НайтиПоНаименованию(СокрЛП(СтрТ.СерияНоменклатуры));
                Если НайденнаяХарактеристика = Справочники.ХарактеристикиНоменклатуры.ПустаяСсылка() Тогда
                    НоваяХарактеристика              = Справочники.ХарактеристикиНоменклатуры.СоздатьЭлемент();
                    НоваяХарактеристика.Владелец     = НоваяСтрока.Номенклатура;
                    НоваяХарактеристика.Наименование = СокрЛП(СтрТ.СерияНоменклатуры);
                    НоваяХарактеристика.Записать();
                    НоваяСтрока.Характеристика = НоваяХарактеристика.Ссылка;
                    Сообщить("У номенклатуры " + СТРОКА(НоваяСтрока.Номенклатура) + " создана новая характеристика " + СТРОКА(НоваяХарактеристика.Ссылка));
                Иначе
                    НоваяСтрока.Характеристика = НайденнаяХарактеристика;
                КонецЕсли;
 
 
   DrShad
 
1 - 10.10.16 - 11:23
конечно
   DrShad
 
2 - 10.10.16 - 11:23
при поиске характеристики нужно еще и владельца указывать
   falselight
 
3 - 10.10.16 - 11:24
(2) то есть так не поможет?
||

НайденнаяХарактеристика = Справочники.ХарактеристикиНоменклатуры.НайтиПоНаименованию(СокрЛП(СтрТ.СерияНоменклатуры), 1);
                Если НайденнаяХарактеристика = Справочники.ХарактеристикиНоменклатуры.ПустаяСсылка() Тогда
                    НоваяХарактеристика              = Справочники.ХарактеристикиНоменклатуры.СоздатьЭлемент();
                    НоваяХарактеристика.Владелец     = НоваяСтрока.Номенклатура;
                    НоваяХарактеристика.Наименование = СокрЛП(СтрТ.СерияНоменклатуры);
                    НоваяХарактеристика.Записать();
                    НоваяСтрока.Характеристика = НоваяХарактеристика.Ссылка;
                    Сообщить("У номенклатуры " + СТРОКА(НоваяСтрока.Номенклатура) + " создана новая характеристика " + СТРОКА(НоваяХарактеристика.Ссылка));
                Иначе
                    НоваяСтрока.Характеристика = НайденнаяХарактеристика;
                КонецЕсли;
   DrShad
 
4 - 10.10.16 - 11:25
не поможет
   falselight
 
5 - 10.10.16 - 11:25
(4) тогда вот так, да?
||
НайденнаяХарактеристика = Справочники.ХарактеристикиНоменклатуры.НайтиПоНаименованию(СокрЛП(СтрТ.СерияНоменклатуры), 1,, НоваяСтрока.Номенклатура);
                Если НайденнаяХарактеристика = Справочники.ХарактеристикиНоменклатуры.ПустаяСсылка() Тогда
                    НоваяХарактеристика              = Справочники.ХарактеристикиНоменклатуры.СоздатьЭлемент();
                    НоваяХарактеристика.Владелец     = НоваяСтрока.Номенклатура;
                    НоваяХарактеристика.Наименование = СокрЛП(СтрТ.СерияНоменклатуры);
                    НоваяХарактеристика.Записать();
                    НоваяСтрока.Характеристика = НоваяХарактеристика.Ссылка;
                    Сообщить("У номенклатуры " + СТРОКА(НоваяСтрока.Номенклатура) + " создана новая характеристика " + СТРОКА(НоваяХарактеристика.Ссылка));
                Иначе
                    НоваяСтрока.Характеристика = НайденнаяХарактеристика;
                КонецЕсли;
   DrShad
 
6 - 10.10.16 - 11:27
так должно помочь, если все остальное верно
   falselight
 
7 - 10.10.16 - 11:37
а как можно оперативно все дубли выявить?
   Lexey_
 
8 - 10.10.16 - 11:39
(7) запросом
   falselight
 
9 - 10.10.16 - 11:48
(8) Что бы разом отобразить все элементы номенклатуры у которой имеются дубликаты характеристик??? Как это?
   falselight
 
10 - 10.10.16 - 12:08
что бы только дубли отображались можно сделать?
||
ВЫБРАТЬ
    ХарактеристикиНоменклатуры.Ссылка,
    ХарактеристикиНоменклатуры.Владелец,
    ХарактеристикиНоменклатуры.Наименование КАК Наименование
ИЗ
    Справочник.ХарактеристикиНоменклатуры КАК ХарактеристикиНоменклатуры

УПОРЯДОЧИТЬ ПО
    Наименование
 
 Рекламное место пустует
   falselight
 
11 - 10.10.16 - 12:14
Как вообще делаются такие хитрости?
Кто либо покажет прием?
   falselight
 
12 - 10.10.16 - 12:17
обработку думаю писать 
с выводом в макет
   DrShad
 
13 - 10.10.16 - 12:24
чтобы только дубли, нужно группировку и количество ссылок считать по наименованию
   falselight
 
14 - 10.10.16 - 12:24
(13) чет не досигаемо до меня
   falselight
 
15 - 10.10.16 - 12:25
обработку если что напишу
в коде обработав
   DrShad
 
16 - 10.10.16 - 12:31
да что там осиливать? ща на коленке напишу
   DrShad
 
17 - 10.10.16 - 12:33
Выбрать
ХарактеристикиНоменклатуры.Владелец,
Количество(ХарактеристикиНоменклатуры.Ссылка) КАК КвоСсылок,
ХарактеристикиНоменклатуры.Наименование
Из
Справочник.ХарактеристикиНоменклатуры КАК ХарактеристикиНоменклатуры
Сгруппировать по 
ХарактеристикиНоменклатуры.Владелец,
ХарактеристикиНоменклатуры.Наименование
Имеющие
Количество(ХарактеристикиНоменклатуры.Ссылка) > 1
   DrShad
 
18 - 10.10.16 - 12:33
написано на коленке, посему могут быть ошибки синтаксиса
   falselight
 
19 - 10.10.16 - 12:36
похоже так, что то соорудил тоже

||

ВЫБРАТЬ
    КОЛИЧЕСТВО(ХарактеристикиНоменклатуры.Ссылка) КАК Количество,
    ХарактеристикиНоменклатуры.Владелец,
    ХарактеристикиНоменклатуры.Наименование КАК Наименование
ПОМЕСТИТЬ КоличествоДублей
ИЗ
    Справочник.ХарактеристикиНоменклатуры КАК ХарактеристикиНоменклатуры

СГРУППИРОВАТЬ ПО
    ХарактеристикиНоменклатуры.Владелец,
    ХарактеристикиНоменклатуры.Наименование

;

////////////////////////////////////////////////////////////////////////////////

ВЫБРАТЬ
    КоличествоДублей.Владелец,
    КоличествоДублей.Наименование,
    КоличествоДублей.Количество
ИЗ
    КоличествоДублей КАК КоличествоДублей
ГДЕ
    КоличествоДублей.Количество > 1
   falselight
 
20 - 10.10.16 - 12:38
да, похоже оба запроса
выводят идентичное количество записей
   falselight
 
21 - 10.10.16 - 12:39
счас дубли остается перебить
обработкой поиск и замена значений
да удалить лишние


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует