Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Количество символов на управляемой форме

Количество символов на управляемой форме
Я
   first_may
 
06.10.16 - 16:23
Добрый день.

Есть управляемая форма. На ней расположен элемент ПолеHTMLДокумента, у которого вид "Поле HTML документа". Подскажите пож, как сделать так, что бы когда пользователь вводит текст в нем, то элементе надписи отображалось количество введенных символов?
 
 
   Timon1405
 
1 - 06.10.16 - 16:25
спам по СМС автоматизируем?
   DrShad
 
2 - 06.10.16 - 16:26
закладочка

самому интересно ведь то что видит пользователь - далеко не весь текст HTML документа, а следовательно нужно выбирать редактируемый элемент документа и по innerHTML считать длину строки
   first_may
 
3 - 06.10.16 - 16:26
(1) нет.. хотим сделать описание товара, а затем html-код выгружать.. подсчет количество символов надо для статистики..
   DrShad
 
4 - 06.10.16 - 16:29
(3) для контент-менеджера!? так там только стилями можно такую статистику нагнать что мало не покажется
   Timon1405
 
5 - 06.10.16 - 16:33
БСП
// Получает обычный текст из текста HTML.

//
// Параметры:

//  ТекстHTML  - Строка - текст HTML.
//

// Возвращаемое значение:
//   Строка   - обычный текст

//
Функция ПолучитьОбычныйТекстИзHTML(ТекстHTML) Экспорт
    
    ФорматированныйДокумент = Новый ФорматированныйДокумент;
    ФорматированныйДокумент.УстановитьHTML(ТекстHTML, Новый Структура);
    Возврат ФорматированныйДокумент.ПолучитьТекст();
    
КонецФункции

PS сам не пробовал)
   first_may
 
6 - 06.10.16 - 16:33
все здорово.. но как посчитать количество символов? :)
   DrShad
 
7 - 06.10.16 - 16:36
(6) СтрДлина или ДлинаСТР все время путаю
   first_may
 
8 - 06.10.16 - 16:38
&НаКлиенте
Процедура ПолеHTMLДокументаПриИзменении(Элемент)
    Элементы.ЧислоСимволов.Заголовок = "Число строк: " + Строка(КодСимвола(Элементы.ПолеHTMLДокумента.Документ));
КонецПроцедуры



ничего не выводится :(
   DrShad
 
9 - 06.10.16 - 16:41
Строка(КодСимвола(Элементы.ПолеHTMLДокумента.Документ))

что это!?
   DrShad
 
10 - 06.10.16 - 16:42
хоть бы глянул что находится в Элементы.ПолеHTMLДокумента.Документ
 
 Рекламное место пустует
   first_may
 
11 - 06.10.16 - 16:44
(10)  элемент ПолеHTMLДокумента, у которого вид "Поле HTML документа".
   DrShad
 
12 - 06.10.16 - 16:48
(11) а тебя об этом вообще спрашивали?

Элементы.ПолеHTMLДокумента.Документ
элемент ПолеHTMLДокумента

чуешь разницу?
   first_may
 
13 - 06.10.16 - 19:22
(12) нет, поэтому и обратился к специалистам..

и еще, ставлю точку остановки в
&НаКлиенте 
Процедура ПолеHTMLДокументаПриИзменении(Элемент)
    Элементы.ЧислоСимволов.Заголовок = "Число строк: " + Строка(КодСимвола(Элементы.ПолеHTMLДокумента.Документ));
КонецПроцедуры

но в нее не попадаю.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует