Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Обращение к реквизиту объекта из модуля менеджера

Обращение к реквизиту объекта из модуля менеджера
Я
   lirt82
 
06.10.16 - 13:54
Необходимо доработать обработку а именно ее макет, по условию задачи нужно создать реквизит тип булево, разместить его на форме обработки и в зависимости от его значения выводить данные в макет обработки, процедура печати находиться в модуле менеджера. Вопрос как обратиться из модуля менеджера (процедура Печать) к значению реквизита объекта?
пробовал через Метаданные, получаю сам реквизит но его значения нет.
 
 
   DrShad
 
1 - 06.10.16 - 13:55
блин, только давеча была ровно такая же тема

НИКАК
   zak555
 
2 - 06.10.16 - 13:56
Передавай в менеджер объект
   DrShad
 
3 - 06.10.16 - 13:56
даже проверил, вчерашняя тема не ТС, откуда у людей массово такие мысли появляются
   Михаил Козлов
 
4 - 06.10.16 - 13:56
В процедуру Печать обычно передается "массив" объектов для печати.
   DrShad
 
5 - 06.10.16 - 13:58
(4) +1
но массив из одного элемента тоже массив )))
   Михаил Козлов
 
6 - 06.10.16 - 15:31
(5) ТС нужно сообразить, что он должен делать для массива.
   azernot
 
7 - 06.10.16 - 15:34
Нужно тупо передать в процедуру "печать" в менеджере нужный параметр.. в составе структуры других параметров, если таковая уже есть, или прямым параметром.

Например:

Процедура Печать(РеквизитТипБулево)

  Если РеквизитТипБулево Тогда

  Иначе

  КонецЕсли;

КонецПроцедуры
   lirt82
 
8 - 07.10.16 - 07:15
(7) да структура есть как этот параметр передать в процедуру печат в менеджере?
реквизит объекта формы создал имя ВыводитьПодвалСподписями тип Булево
вот код из менеджера обработки
// Формирует печатные формы.

//
// Параметры:

//  МассивОбъектов  - Массив    - ссылки на объекты, которые нужно распечатать;
//  ПараметрыПечати - Структура - дополнительные настройки печати;

//  КоллекцияПечатныхФорм - ТаблицаЗначений - сформированные табличные документы (выходной параметр)
//  ОбъектыПечати         - СписокЗначений  - значение - ссылка на объект;

//                                            представление - имя области в которой был выведен объект (выходной параметр);
//  ПараметрыВывода       - Структура       - дополнительные параметры сформированных табличных документов (выходной параметр).

//
Процедура Печать(МассивОбъектов, ПараметрыПечати, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода) Экспорт
    
    // Печать Опись ОС при вводе остатков

    НужноПечататьМакет = УправлениеПечатью.НужноПечататьМакет(КоллекцияПечатныхФорм, "СреднийЗаработок");
    Если НужноПечататьМакет Тогда
        УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(
            КоллекцияПечатныхФорм,
            "СреднийЗаработок",
            НСтр("ru = 'Печать'"),
            ПечатьСреднегоЗаработка(МассивОбъектов, ОбъектыПечати, ПараметрыПечати),
            ,
            "Обработка.РасчетПоСреднемуЗаработку.ПФ_MXL_Макет");
    КонецЕсли;
    
КонецПроцедуры

Функция ПечатьСреднегоЗаработка(МассивОбъектов, ОбъектыПечати, ПараметрыПечати)
    
    УстановитьПривилегированныйРежим(Истина);
    
    ДанныеОбъекта = ПараметрыПечати.ДанныеОбработки;
    
    ТабДокумент = Новый ТабличныйДокумент;
    
    Макет = ПолучитьМакет("ПФ_MXL_Макет");
    
    ТабДокумент = Новый ТабличныйДокумент;
   azernot
 
9 - 07.10.16 - 14:24
(8) Давай кусок кода из формы обработки. Где вызывается процедура из модуля менеджера?

Список тем форума
Рекламное место пустует  Рекламное место пустует
Оптимист верит, что мы живем в лучшем из миров. Пессимист боится, что так оно и есть.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует