Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Как добавить строку в табличную часть документа (управляемые формы)?

Как добавить строку в табличную часть документа (управляемые формы)?
Я
   katerinaUniv
 
06.10.16 - 13:42
Добрый день!

Есть в 1С:Бухгалтерия ТСЖ, ЖКХ, ЖСК документ регистрация оплаты. У него несколько табличных частей, в том числе табличная часть РасшифровкаОплаты. Мне нужно по кнопке добавлять туда строку. Программно добавляю, но на форме ничего не отображается. В то же время если закрыть и открыть документ, то новую строку видно. Что я упускаю?
 
 
   katerinaUniv
 
1 - 06.10.16 - 13:42
&НаСервере
Процедура шт_ДобавитьМесКвартплатыНаСервере(лСчет)
    //Добавляем месяц квартплаты в расшифровку платежа

    оДок = реквизитФормыВЗначение("объект");
    нСтрока = оДок.РасшифровкаПлатежа.Добавить();
    нСтрока.Объект = лСчет;
    нСтрока.Услуга = Справочники.КВП_Услуги.НайтиПоНаименованию("Квартплата");
    нСтрока.Сумма = 0;
    нСтрока.МесяцНачисления = ПолучитьСледМесяц(объект, нСтрока.ОБъект);
    оДок.Записать();
    //шт_ДобавитьМесКвартплатыНаСервере();

КонецПроцедуры

&НаКлиенте
Процедура шт_ДобавитьМесКвартплаты(Команда)
    текСтрокаЛСчета = этотобъект.Элементы.ЛицевыеСчета.ТекущиеДанные;
    шт_ДобавитьМесКвартплатыНаСервере(текСтрокаЛСчета.объект);
    этотОбъект.ОбновитьОтображениеДанных();
КонецПроцедуры

&НаСервере
Функция ПолучитьСледМесяц(док, лСчет)
    //узнаем, какой был последний месяц по лицевому счету и возвращаем следующий

    отбор = новый Структура;
    отбор.Вставить("Объект", лСчет);
    тз = реквизитФормыВЗначение("объект").РасшифровкаПлатежа.Выгрузить(
        реквизитФормыВЗначение("объект").РасшифровкаПлатежа.НайтиСтроки(отбор), "МесяцНачисления, Объект");
    тз.Сортировать("МесяцНачисления Убыв");
    Возврат ?(тз.Количество()>0, КонецМесяца(ДобавитьМесяц(тз[0].МесяцНачисления,1)), КонецГода(ТекущаяДата()));
КонецФункции
   DrShad
 
2 - 06.10.16 - 13:43
ты к другому экземпляру объекта добавляешь
   DrShad
 
3 - 06.10.16 - 13:44
оДок = реквизитФормыВЗначение("объект");
    нСтрока = оДок.РасшифровкаПлатежа.Добавить();

вместо этого


    нСтрока = Объект.РасшифровкаПлатежа.Добавить();
   katerinaUniv
 
4 - 06.10.16 - 13:58
(3)так вообще не добавляет
   katerinaUniv
 
5 - 06.10.16 - 13:58
(3)я так пробовала, и сейчас на всякий случай проверила
   DrShad
 
6 - 06.10.16 - 14:00
да ладно!? у меня работает, что я делаю не так?
   katerinaUniv
 
7 - 06.10.16 - 14:03
(6) тоже при повторном открытии формы показываются изменения
   katerinaUniv
 
8 - 06.10.16 - 14:03
мне кажется надо как-то после программных действий обновить форму
   katerinaUniv
 
9 - 06.10.16 - 14:03
перечитать
   katerinaUniv
 
10 - 06.10.16 - 14:20
(6)код одинаковый до последней строчки. что я тогда делаю не так?
 
 Рекламное место пустует
   katerinaUniv
 
11 - 06.10.16 - 14:21
У меня управляемое приложение
   katerinaUniv
 
12 - 06.10.16 - 15:11
Добавляется строка, но не могу увидеть изменения на форме. Помогите пожалуйста!
   andreymongol82
 
13 - 07.10.16 - 07:01
(12) Добавляй не в объект, а в данные формы

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует