Вход | Регистрация


Отладка внешней печатной формы на УФ

Отладка внешней печатной формы на УФ
Я
   Погрустин
 
06.10.16 - 11:10
Добрый день подскажите пожалуйста есть внешняя обработка которая подключается в дополнительных отчетах и обработках.(Обработка служит для формирования печатной формы)

Задача запустить ее выполнение через отладчик.

Пробую вот так , через добавление к обработке формы документа:

в Модуле объекта:

[CODE] 
Процедура Печать(МассивОбъектов, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода) Экспорт
    
    ПараметрыВывода.ДоступнаПечатьПоКомплектно = Истина;
    Макет_ПФ_MXL_Т1 = ПолучитьМакет("ПФ_MXL_Т1");
    Макет_ПФ_MXL_Т5 = ПолучитьМакет("ПФ_MXL_Т5");
    
    Если УправлениеПечатью.НужноПечататьМакет(КоллекцияПечатныхФорм, "ПФ_MXL_Т1") Тогда
        
        //ВывестиТабличныйДокументВКоллекцию(КоллекцияПечатныхФорм, ИмяМакета, СинонимМакета, ТабличныйДокумент,

        //Картинка = Неопределено, ПолныйПутьКМакету = "", ИмяФайлаПечатнойФормы = Неопределено)        

        
        УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(
                        КоллекцияПечатныхФорм,
                        "ПФ_MXL_Т1", НСтр("ru='Приказ о приеме'"),
                        ПолучитьТабличныйДокументПриказаТ1(ПолучитьМакет("ПФ_MXL_Т1"), МассивОбъектов, ОбъектыПечати), ,
                        "");
                        
    КонецЕсли;

Функция ПолучитьТабличныйДокументПриказаТ1(Макет, МассивОбъектов, ОбъектыПечати)
    
    ДокументРезультат = Новый ТабличныйДокумент;
    НомерСтрокиНачало = ДокументРезультат.ВысотаТаблицы + 1;
    
    ДокументРезультат.КлючПараметровПечати = "ПараметрыПечати_ПриказОПриеме";
    МассивДанныхЗаполнения = ПолучитьДанныеДляПечатиКадровогоПриказаТ1(МассивОбъектов);    
    
    ВывестиДанныеКадровогоПриказаВТабличныйДокумент(Макет, ДокументРезультат, МассивДанныхЗаполнения, ОбъектыПечати);
    
    Возврат ДокументРезультат;
КонецФункции

[/CODE]

В Модуле формы:

[CODE]
&НаКлиенте
Процедура ПечатьСправки(Команда)
  
  //Как здесь вызвать функцию формирования Табличного документа????

 
   ПечатьСправкиНаСервере(Объект.СсылкаДок);

КонецПроцедуры

&НаСервере
Процедура ПечатьСправкиНаСервере(Ссылка)
  
  //Как здесь вызвать функцию формирования Табличного документа????

   КоллекцияПечатныхФорм = 
  
   РеквизитФормыВЗначение("Объект").Печать(Ссылка);


КонецПроцедуры

[/CODE]


Выходит ошибка - Недостаточно фактических параметров

{ВнешняяОбработка.ПечатьКадровыхПриказов.Форма.Форма.Форма(15)}: Недостаточно фактических параметров
   РеквизитФормыВЗначение("Объект").Печать(Ссылка);
 
 
   Aleksandr N
 
1 - 06.10.16 - 11:12
(0)
"Процедура Печать(МассивОбъектов, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода)"

"Печать(Ссылка)"

Что непонятного?
   Aleksandr N
 
2 - 06.10.16 - 11:13
(0) И вообще так пишут код только му—ки.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует