Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

подписка на событие ОбработкаПроведения

подписка на событие ОбработкаПроведения
Я
   НубВ1С8
 
05.10.16 - 18:16
Надо, что б в списании с расчетного счета при операции перечисление налога проставлялось подразделение Дт. В счете учет по подразделениям включен, сейчас проставляют руками через редактирование операции документа.
делаю подписку

Процедура СтавимПодразделениеВПроводкуСписанияСРасчетногоСчетаОбработкаПроведения(Источник, Отказ, РежимПроведения) Экспорт
    Если Источник.ВидОперации = перечисления.ВидыОперацийСписаниеДенежныхСредств.ПеречислениеНалога  тогда
        
НаборДвиженийБУ  = Источник.Движения.Хозрасчетный.выгрузить();
Для каждого Стр из НаборДвиженийБУ Цикл
   если не Источник.ПодразделениеФилиал.Пустая() тогда
    Стр.ПодразделениеДт = Источник.подразделениеФилиал;
   иначе
    Стр.ПодразделениеДт = Источник.ПодразделениеОрганизации;
   Конецесли;
КонецЦикла;
        Источник.Движения.Хозрасчетный.Загрузить(НаборДвиженийБУ);
        
КонецЕсли;
КонецПроцедуры

- смотрю отладчиком, проставляется, в результирующй проводке - нет!

пробовал не выгружать в тз, а сразу "НаборДвиженийБУ  = Источник.Движения.Хозрасчетный" - отладчиком тоже все видно, в проводку ставится, но опять-таки, в результате дырка в подразделении дт...

пробовал Источник.Движения.Записать() и до и после ставить. не работает. Бухгалтерия 3.0
что я делаю не так?
 
 
   Генератор
 
1 - 05.10.16 - 18:19
попробуй набор записей прочитать по регистратору, поменять и записать
   craxx
 
2 - 05.10.16 - 18:19
(0) Родной, а записывать движения Пушкин будет??
   НубВ1С8
 
3 - 05.10.16 - 18:22
(2)

может я чего не понимаю, но я писал после изменения
Источник.Движения.Записать(); нифига не изменялось. Или не то?
   НубВ1С8
 
4 - 05.10.16 - 18:22
(1) сейчас попробую
   Генератор
 
5 - 05.10.16 - 18:24
(3) а надо вроде источник.движения.хозрасчетный.записать()
   Генератор
 
6 - 05.10.16 - 18:27
движения.записать() записывает все регистры, вроде у которых записывать = истина, можно и так но тогда движения.хозрасчетный.записывать = истина; перед записью
   НубВ1С8
 
7 - 05.10.16 - 18:28
источник.движения.хозрасчетный.записать() - сработало! спасибо огромное. надо доку перечитать, что-то явно пропустил...
   НубВ1С8
 
8 - 05.10.16 - 18:29
(2) тоже спасибо

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует