Вход | Регистрация


1С:Предприятие :: 1С:Предприятие 8 общая

Конвертация данных: Списание с расчетного счета, договор контрагентов

Конвертация данных: Списание с расчетного счета, договор контрагентов
Я
   lg2marvel
 
05.10.16 - 15:01
Добрый день!
Конвертация данных из "ДАЛИОН: Управление магазином.ПРО", ред. 1.2 (1.2.31.05) в Бухгалтерия предприятия КОРП, редакция 3.0 (3.0.44.115)

Нужно перебросить банковскую выписку и сформировать из нее списание с расчетного счета. Все хорошо, кроме договора контрагента в расшифровке платежа. Он туда не попадает.
В Перед выгрузкой ПКС ДоговорКонтрагента:

Сообщить(Источник.ВзаиморасчетыПодробно[0].ДоговорКонтрагента);
            Значение = Источник.ВзаиморасчетыПодробно[0].ДоговорКонтрагента.Ссылка;

выгружает, но не загружает.
 
 
   lg2marvel
 
1 - 05.10.16 - 15:05
Вид операций Возврат займа контрагенту
   piter3
 
2 - 05.10.16 - 15:06
ну не знаю,может стоит посмотреть договор в шапке
   lg2marvel
 
3 - 05.10.16 - 15:09
Правила
https://yadi.sk/d/ybGYwpcMwGuFs

ПКО ПлатежноеПоручениеИсходящее_Списание              

(2) В шапке указывается контрагент, в тч договора по которым списывается долг

Договор как бы передается из источника (сообщение выводится при выгрузке)
   lg2marvel
 
4 - 05.10.16 - 15:25
Не прокатывает  даже так:
Если Источник.Контрагент.ИНН = "110000000001" Тогда
    Значение = Справочники.ДоговорыКонтрагентов.НайтиПоНаименованию("№1/2015/Планета от 12.02.2015");
    сообщить(Значение);
КонецЕсли;
   piter3
 
5 - 05.10.16 - 15:30
хочешь давай описание конф,попробую посмотреть
   lg2marvel
 
6 - 05.10.16 - 15:43
   piter3
 
7 - 05.10.16 - 15:54
Источник.СтатьяДвиженияДенежныхСредств.КорреспондирующийСчет.Код = "66.03"
тогда уж.
и судя по всему тебе нужна подмена по твоим условиям так?
   lg2marvel
 
8 - 05.10.16 - 15:57
(7) Да, все верно, при условии что в источнике выбрана статья "Расчеты по кредитам и займам с контрагентами" я меняю Видоперации и ВидПлатежа в ТЧ приемника
   lg2marvel
 
9 - 05.10.16 - 16:02
   lg2marvel
 
10 - 05.10.16 - 16:03
Значит ли это что приемник не может быть типом ДоговорКонтрагента?
 
 Рекламное место пустует
   lg2marvel
 
11 - 05.10.16 - 16:04
(9) (10) не-не-не, не то смотрю, двоится в глазах. Сори.
   piter3
 
12 - 05.10.16 - 16:25
(8) а с договором чего нужно сделать?
   lg2marvel
 
13 - 05.10.16 - 16:39
(12) нет, он должен попасть в ТЧ приемника в поле ДоговорКонтрагента. Изначально никаких изменений в ПКС ДоговорКонтрагента не было. Кстати попробую выгрузить документы с другим видом операции.
   lg2marvel
 
14 - 05.10.16 - 16:50
(13) В документы с другим видом операции договор проставляется нормально
   lg2marvel
 
15 - 05.10.16 - 16:57
ВПК ВидОперации в перед выгрузкой

Если Источник.ВидОперации = Перечисления.ВидыОперацийПлатежноеПоручение.ПеречислениеНалога Тогда
    Значение = "ПеречислениеНалога";
ИначеЕсли Источник.ВидОперации = Перечисления.ВидыОперацийПлатежноеПоручение.ПрочийРасход Тогда
    Значение = "ПрочееСписание";
Иначе
    Если Источник.ВзаиморасчетыПодробно.Количество() > 0 И 
            Источник.ВзаиморасчетыПодробно[0].ДоговорКонтрагента.ВидДоговора = Перечисления.ВидыДоговоровКонтрагентов.СПокупателем Тогда
        Значение = "ВозвратПокупателю";
    Иначе 
        Значение = "ОплатаПоставщику";
    КонецЕсли;          
КонецЕсли;                  

//***+++

Если Источник.СтатьяДвиженияДенежныхСредств.КорреспондирующийСчет = "66.03" Тогда
    Значение = "ВозвратЗайма";
КонецЕсли;

ПКС ВидПлатежаПоКредитамЗаймам перед выгрузкой 
Если Источник.СтатьяДвиженияДенежныхСредств.КорреспондирующийСчет = "66.03" Тогда
    Значение = "ПогашениеДолга";
Иначе
    Отказ = Истина;
КонецЕсли;

Вроде же ничто не  влияет на договор контрагента, в приемнике при изменении вида операции просто добавляется колонка Вид платежа
   piter3
 
16 - 05.10.16 - 16:59
Открой ПКС договор в ТЧ
   hhhh
 
17 - 05.10.16 - 17:00
(15) ну вот здесть какая-то фигня
Если Источник.СтатьяДвиженияДенежныхСредств.КорреспондирующийСчет = "66.03" Тогда

счет сравниваешь со строкой
   piter3
 
18 - 05.10.16 - 17:01
(17) я в (7) уже писал ему
   lg2marvel
 
19 - 05.10.16 - 17:11
(17) (18) Если добавляю .Код - начинает ругаться ошибками. Тогда нужно сравнивать не со строкой уже а, как там правильно с кодом счета... Новедь условие срабатывает, значит причина не в этом
   hhhh
 
20 - 05.10.16 - 17:13
(19) условие дает ложь всегда. то есть никогда не бывает  Значение = "ВозвратЗайма"
   lg2marvel
 
21 - 05.10.16 - 17:19
(20) Не правда Ваша.
Если Источник.СтатьяДвиженияДенежныхСредств.КорреспондирующийСчет = "66.03" Тогда
    Значение = "ВозвратЗайма";
    Сообщить("ВозвратЗайма");
Иначе
    Сообщить("ОплатаПоставщику");
КонецЕсли;

И при выгрузке в окне сообщений:

ВозвратЗайма
ОплатаПоставщику
   piter3
 
22 - 05.10.16 - 17:32
Что есть СтатьяДвиженияДенежныхСредств?
Что есть КорреспондирующийСчет ?
(21)очень даже может быть
   piter3
 
23 - 05.10.16 - 17:38
если судить по метаданным у тебя нет такого реквизита КорреспондирующийСчет  у СтатьяДвиженияДенежныхСредств.

Может со свежей головой
   lg2marvel
 
24 - 05.10.16 - 17:38
(22) Справочник Статьи движения денежных средств
КорреспондирующийСчет - Тип Строка (7)
   lg2marvel
 
25 - 05.10.16 - 17:39
   piter3
 
26 - 05.10.16 - 17:40
Тогда Сокрлп используй
   hhhh
 
27 - 05.10.16 - 17:41
(21) может тогда действительно

Источник.ВзаиморасчетыПодробно[0].ДоговорКонтрагента
Источник.ВзаиморасчетыПодробно[0].СтатьяДвиженияДенежныхСредств

или

Источник.ДоговорКонтрагента
Источник.СтатьяДвиженияДенежныхСредств

или то, или это. А то у вас как-то неправильно: статья там, а договор здесь.


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует