Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Объект.Реквизит1 в двух формах УП

Объект.Реквизит1 в двух формах УП
Я
   SiMBa_R38
 
05.10.16 - 13:16
Здравствуйте уважаемые жители волшебного форума.
Растолкуйте мне, пожалуйста, как заполнить Объект.Реквизит1 в одной форме и воспользоваться им в другой форме.
Делаю так, на одной форме две кнопки: одна заполняет Объект.Реквизит1 значением, вторая открывает вторую форму.

&НаКлиенте
Процедура Команда1(Команда)
    // Вставить содержимое обработчика.

    Объект.Реквизит1 = "Привет мир";
КонецПроцедуры

&НаКлиенте
Процедура Команда2(Команда)
    // Вставить содержимое обработчика.

    ФормаОтчета = ПолучитьФорму("ВнешняяОбработка.ВнешняяОбработка1.Форма.Форма1", , ЭтаФорма);
    Если ФормаОтчета <> Неопределено Тогда
        ФормаОтчета.Открыть();
    КонецЕсли;
КонецПроцедуры

На второй форме в методе при открытии Сообщение(Объект.Реквизит1) - выдает пусто
Почитал http://catalog.mista.ru/public/153602/ в голове не прояснилось.
 
 
   hhhh
 
1 - 05.10.16 - 13:18
передать его ькак параметр
   SiMBa_R38
 
2 - 05.10.16 - 13:20
(1) Тогда не ясно для чего вообще придуман в обработке реквизиты
   hhhh
 
3 - 05.10.16 - 13:28
(2) чтобы работать с ними в одной форме. у обработки всегда одна форма.
   DrShad
 
4 - 05.10.16 - 13:31
надо на второй форме тоже объект поднимать как основной реквизит формы
   DrShad
 
5 - 05.10.16 - 13:31
сам не извращался но в обсуждениях встречал
   SiMBa_R38
 
6 - 06.10.16 - 05:19
(3) Ну вот возникла ситуация когда в основной форме видим список объектов, и куча настроек, а во второй производится обработка данных по указанным настройкам, пихать это все в параметр мне показалось не по феншую, есть ведь объект с четко обозначенными реквизитами.
(5) Оно там и так основным реквизитом сделано.

Можно еще сделать

&НаКлиенте
Процедура Команда2(Команда)
    // Вставить содержимое обработчика.

    ФормаОтчета = ПолучитьФорму("ВнешняяОбработка.ВнешняяОбработка1.Форма.Форма1", , ЭтаФорма);
    Если ФормаОтчета <> Неопределено Тогда
        ЗаполнитьЗначенияСвойств(ФормаОтчета.Объект,Объект);
        ФормаОтчета.Открыть();
    КонецЕсли;
КонецПроцедуры

Но мне кажется, что как-то не аккуратненько.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует