Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Выход из цикла по нажатию клавиши

Выход из цикла по нажатию клавиши
Я
   Den_B12
 
04.10.16 - 14:09
Всем привет.
В цикле крутятся презентации:
Пока 1 < 2 Цикл
 ...
 ЗапуститьПриложение(ЭлементМассива.Имя,,Истина);
...
КонецЦикла

Как обработать нажатие на клавиатуре например ESC и завершить цикл?
 
 
   Любопытная
 
1 - 04.10.16 - 14:10
ОбработкаПрерыванияПользователя() Обрывает по Ctrl+Breack
   Den_B12
 
2 - 04.10.16 - 14:23
Ctrl+Breack не срабатывает, может не успевает из-за цикла. Пробую вот так 
    Пока 1<2 Цикл
        Сообщить("1");
    КонецЦикла
   butterbean
 
3 - 04.10.16 - 14:24
(2) вставь ОбработкаПрерыванияПользователя()
оно не может не успевать, оно просто ждет следующего шага
   Den_B12
 
4 - 04.10.16 - 14:24
Видимо надо как-то отловить средствами винды нажата ли клавиша или нет
   Рэйв
 
5 - 04.10.16 - 14:24
(2)А ты попробуй вот так:

  Пока 1<2 Цикл
      ОбработкаПрерыванияПользователя() ;
      Сообщить("1");
  КонецЦикла
   Волшебник
 
Модератор
6 - 04.10.16 - 14:24
Пока Истина Цикл
   ОбработкаПрерыванияПользователя()
   <твои действия>
КонецЦикла
   FIXXXL
 
7 - 04.10.16 - 14:28
(0) по кнопе Отмена пиши служебный флаг, в цикле проверяй (и очищай) значение флага
   Den_B12
 
8 - 04.10.16 - 14:32
Пока 1<2 Цикл
      ОбработкаПрерыванияПользователя() ;
      Сообщить("1");
  КонецЦикла

Да, так работает. А если так долго не получается поймать.
Пока 1 < 2 Цикл 
ОбработкаПрерыванияПользователя() ;
ЗапуститьПриложение(ЭлементМассива.Имя,,Истина); 
...
КонецЦикла
   Ёпрст
 
9 - 04.10.16 - 15:32
(8) всё правильно, ибо запускаемое приложение идёт вне цикла
   cybfyv
 
10 - 04.10.16 - 15:35
(7) у тебя приоложение перехватывает ввод и естественно что 1с не реагирует
 
 Рекламное место пустует

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует