Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: установить выборку регистра по заданному ресурсу

v7: установить выборку регистра по заданному ресурсу
Я
   Lexxus79
 
04.10.16 - 06:40
Всем доброго утра !
Немного туплю, опять давно не занимался семеркой.
Есть регистр Касса. В нем есть измерения Валюта, Касса и Проценты (булево).
Надо: получить выборку в интервале дат со значением измерения Проценты Да.
Пишу:
    Валюта = Константа.БазоваяВалюта;
    Касса = Константа.ОсновнаяКасса;        
    Проценты = Перечисление.Булево.Да;
    Дата1 = Константа.ДатаОтсчетаПроцентов;
    Дата2 = ТекущаяДата();

    РегПроценты = СоздатьОбъект("Регистр.Касса");
    РегПроценты.УстановитьФильтр(Валюта,Касса, Проценты);
    
    Пока Дата1 <> Дата2 Цикл
        РегПроценты.ВыбратьДвижения(Дата1, Дата1);
        Пока РегПроценты.ПолучитьДвижение() = 1 Цикл  
                // есть движение

        КонецЦикла;      
        Дата1 = Дата1 + 1;        
    КонецЦикла;
    
Документы есть, а движений по этой конструкции нет. Посоветуйте плиз правильное решение. Спасибо.
 
 
   VladZ
 
1 - 04.10.16 - 06:48
Запросом
   Chameleon1980
 
2 - 04.10.16 - 08:43
+(1) +++
и не путайте чтоль ресурсы с измерениями - с толку не сбивайте
   Остап Сулейманович
 
3 - 04.10.16 - 09:06
(0)
РегПроценты.ВыбратьДвижения(Дата1, Дата1);
Пока РегПроценты.ПолучитьДвижение() = 1 Цикл  // есть движение

    Если РегПроценты.Проценты = Перечисление.Булево.Да Тогда
        ...
    КонецЕсли;
КонецЦикла;

Список тем форума
Рекламное место пустует  Рекламное место пустует
Компьютеры — прекрасное средство для решения проблем, которых до их появления не было.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует