Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Метод объекта не обнаружен (ПечатьПоВнешнемуИсточнику)

Метод объекта не обнаружен (ПечатьПоВнешнемуИсточнику)
Я
   Slava685
 
03.10.16 - 16:49
Всем доброго вечера)
Проблемы с внешней обработкой.
Пишет ошибку "{ОбщаяФорма.ПечатьДокументов.Форма(419)}: Метод объекта не обнаружен (ПечатьПоВнешнемуИсточнику)
            МодульДополнительныеОтчетыИОбработки.ПечатьПоВнешнемуИсточнику(Параметры.ИсточникДанных)"

Выбивает в общий модуль.Не понимаю,где я должен этот метод запихнуть?
Вот код общего модуля 

Функция СведенияОВнешнейОбработке() Экспорт
    
    
        ПараметрыРегистрации = Новый Структура;
        
            ПараметрыРегистрации.Вставить("Вид", "ПечатнаяФорма");
        Назначение = Новый Массив;    
        
            Назначение.Добавить("Документ.ТранспортнаяНакладная");
            ПараметрыРегистрации.Вставить("Назначение", Назначение);
            ПараметрыРегистрации.Вставить("Наименование", "Накладная на сборку");
            ПараметрыРегистрации.Вставить("Версия", "1.0");
            ПараметрыРегистрации.Вставить("БезопасныйРежим", Истина);
            ПараметрыРегистрации.Вставить("Информация", "Обработка формирования печатной формы документа ""Накладная на сборку""");
                
        Команды = Новый ТаблицаЗначений;
        
            Команды.Колонки.Добавить("Представление", Новый ОписаниеТипов("Строка"));
            Команды.Колонки.Добавить("Идентификатор", Новый ОписаниеТипов("Строка"));
            Команды.Колонки.Добавить("Использование", Новый ОписаниеТипов("Строка"));
            Команды.Колонки.Добавить("ПоказыватьОповещение", Новый ОписаниеТипов("Булево"));
            Команды.Колонки.Добавить("Модификатор", Новый ОписаниеТипов("Строка"));
            
            НоваяКоманда = Команды.Добавить();
            НоваяКоманда.Представление = "Накладная на сборку";
            НоваяКоманда.Идентификатор = "НакладнаяНаСборку";
            НоваяКоманда.Использование = "ВызовСерверногоМетода";
            НоваяКоманда.ПоказыватьОповещение = Истина;
            НоваяКоманда.Модификатор = "ПечатьMXL";

            
            ПараметрыРегистрации.Вставить("Команды", Команды);
    
    Возврат ПараметрыРегистрации;
    

КонецФункции

Процедура Печать(МассивОбъектов, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода,ДанныеПечати) Экспорт
    
    Если УправлениеПечатью.НужноПечататьМакет(КоллекцияПечатныхФорм, "Макет") Тогда

            ТабличныйДокумент = СформироватьПечатнуюФормуНакладнойНаСборку(МассивОбъектов,ОбъектыПечати,ДанныеПечати)//Запихиваем в ТабДок для вывода в табличной форме на форме вн.обработки

            УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(
                КоллекцияПечатныхФорм,
                "Макет",
                "Накладная на сборку",
                ТабличныйДокумент);

    КонецЕсли;
                
КонецПроцедуры


Функция СформироватьПечатнуюФормуНакладнойНаСборку(СсылкаНаОбъект, ОбъектыПечати,ДанныеПечати) Экспорт


Вот код на клиент сервере

&НаСервере
Процедура Команда1НаСервере()
    ОбъектОбъект=РеквизитФормыВЗначение("Объект");
    КолекцияПечатныхФорм=УправлениеПечатью.ПодготовитьКоллекциюПечатныхФорм("Макет");
    Результат=ОбъектОбъект.СформироватьПечатнуюФормуНакладнойНаСборку(ОбъектОбъект.СсылкаНаОбъект,"","");
КонецПроцедуры

&НаКлиенте
Процедура Команда1(Команда)
    Команда1НаСервере();
КонецПроцедуры


Выкидывает меня вот в эту функцию



Функция СформироватьПечатныеФормы(ИменаМакетов, Отказ)
    
    Результат = Неопределено;    
    // Формирование табличных документов.

    Если ЗначениеЗаполнено(Параметры.ИсточникДанных) Тогда
        Если ОбщегоНазначения.ПодсистемаСуществует("СтандартныеПодсистемы.ДополнительныеОтчетыИОбработки") Тогда
            МодульДополнительныеОтчетыИОбработки = ОбщегоНазначения.ОбщийМодуль("ДополнительныеОтчетыИОбработки");
            МодульДополнительныеОтчетыИОбработки.ПечатьПоВнешнемуИсточнику(Параметры.ИсточникДанных,
                Параметры.ПараметрыИсточника, Результат, ОбъектыПечати, ПараметрыВывода);
        Иначе
            Отказ = Истина;
        КонецЕсли;
 
 
   T3Mka
 
1 - 03.10.16 - 16:54
посмотри существует ли у тебя вообще данная процедура/функция
   Slava685
 
2 - 03.10.16 - 17:04
(1) Есть функция.Тоже идёт формирование.Но не в этом проблема наверное
Функция СформироватьПечатнуюФормуНакладнойНаСборку(СсылкаНаОбъект, ОбъектыПечати,ДанныеПечати) Экспорт
   Slava685
 
3 - 03.10.16 - 17:05
(1) всё дело с параметрами

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует