Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Ставка НДС в табличной части товаров.

Ставка НДС в табличной части товаров.
Я
   progaoff
 
03.10.16 - 16:03
Добрый день. Необходимо реализовать задачку что бы пользователь мог установить ставку НДС любую из предложенных трех. Как реализовать это в приходной. 1С 8.2 Не типовая
 
 
   Cyberhawk
 
1 - 03.10.16 - 16:04
Перечисление + 

Глобальный контекст.ПоказатьВводЗначения (Global context.ShowInputValue)
Глобальный контекст (Global context)
ПоказатьВводЗначения (ShowInputValue)
Синтаксис:

ПоказатьВводЗначения(<ОписаниеОповещенияОЗавершении>, <Значение>, <Подсказка>, <Тип>)
Параметры:

<ОписаниеОповещенияОЗавершении> (обязательный)

Тип: ОписаниеОповещения.
Содержит описание процедуры, которая будет вызвана после закрытия окна ввода значения со следующими параметрами:
<Значение> - выбранное значение или Неопределено, если пользователь отказался от ввода,
<ДополнительныеПараметры> - значение, которое было указано при создании объекта ОписаниеОповещения.
<Значение> (обязательный)

Тип: Произвольный. 
Значение, которое будет использовано в качестве начального значения в диалоге.
Если параметр <Тип> не задан или имеет значение Неопределено, тип данного значения используется в качестве типа вводимого в окне данного. 
<Подсказка> (необязательный)

Тип: Строка.
Текст заголовка окна ввода значения. Может использоваться в качестве подсказки пользователю.
Значение по умолчанию: Пустая строка. 
<Тип> (необязательный)

Тип: Тип; ОписаниеТипов. 
Тип вводимого значения. Если параметр не указан, используется тип параметра <Значение>.
Описание:

Показывает окно для ввода значения заданного типа.

Доступность:

Тонкий клиент, веб-клиент, толстый клиент, мобильное приложение(клиент).
Примечание:

Если тип начального значения не определен и тип значения параметра <Тип> является составным, то в поле ввода появляется кнопка выбора типа.
Пример:

Перем ВыбЗнач;
Массив = Новый Массив;
Массив.Добавить(Тип("Число"));
Массив.Добавить(Тип("Строка"));
Массив.Добавить(Тип("Дата"));
КЧ = Новый КвалификаторыЧисла(12,2);
КС = Новый КвалификаторыСтроки(20);
КД = Новый КвалификаторыДаты(ЧастиДаты.Дата);
ОписаниеТипов = Новый ОписаниеТипов(Массив, КЧ, КС, КД);
Оповещение =
    Новый ОписаниеОповещения("ПослеВводаЗначения", , Параметры);
ПоказатьВводЗначения(Оповещение,
    ВыбЗнач, "Введите значение", ОписаниеТипов);
//...



&НаКлиенте
Процедура ПослеВводаЗначения(ВыбЗнач, Параметры) Экспорт
    Если ВыбЗнач<>Неопределено Тогда
        // обработка введенного значения


        Сообщить("Введенное значение: " + ВыбЗнач);
    КонецЕсли;
КонецПроцедуры
 

--------------------------------------------------------------------------------

     Методическая информация
   progaoff
 
2 - 03.10.16 - 16:27
(1) к сожалению нет этой функции
   Cyberhawk
 
3 - 03.10.16 - 16:32
(2) Тогда

Глобальный контекст.ВвестиЗначение (Global context.InputValue)
Глобальный контекст (Global context)
ВвестиЗначение (InputValue)
Синтаксис:

ВвестиЗначение(<Значение>, <Подсказка>, <Тип>)
Параметры:

<Значение> (обязательный)

Тип: Произвольный.
Имя доступной в модуле переменной. В эту переменную будет помещено введенное значение. Если параметр <Тип> не задан или имеет значение Неопределено, тип данной переменной используется в качестве типа вводимого в диалоге данного. Начальное значение переменной будет использовано в качестве начального значения в диалоге.
<Подсказка> (необязательный)

Тип: Строка.
Текст заголовка окна диалога ввода значения. Может использоваться в качестве подсказки пользователю.
Значение по умолчанию: Пустая строка. 
<Тип> (необязательный)

Тип: Тип; ОписаниеТипов. 
Тип вводимого значения. Если параметр не указан, используется тип параметра <Значение>.
Возвращаемое значение:

Тип: Булево.
Истина - в диалоге было введено значение; Ложь - пользователь отказался от ввода значения.
Описание:

Вызывает диалог для ввода значения заданного типа. Если тип переменной не определен и <Тип> представляет собой составной тип данных, то в поле ввода появляется кнопка выбора типа.

Доступность:

Тонкий клиент, веб-клиент, толстый клиент, мобильное приложение(клиент).
Примечание:

Если для конфигурации свойство РежимИспользованияМодальности установлено в НеИспользовать, следует использовать метод ПоказатьВводЗначения.
Пример:

Перем ВыбЗнач;
Массив = Новый Массив;
Массив.Добавить(Тип("Число"));
Массив.Добавить(Тип("Строка"));
Массив.Добавить(Тип("Дата"));
КЧ = Новый КвалификаторыЧисла(12,2);
КС = Новый КвалификаторыСтроки(20);
КД = Новый КвалификаторыДаты(ЧастиДаты.Дата);
ОписаниеТипов = Новый ОписаниеТипов(Массив, КЧ, КС, КД);
Если ВвестиЗначение(ВыбЗнач, "Введите значение", ОписаниеТипов) Тогда
    // обработка введенного значения


    Сообщить("Введенное значение: "+ВыбЗнач);
КонецЕсли;
 

--------------------------------------------------------------------------------

     Методическая информация
   В тылу врага
 
4 - 03.10.16 - 16:35
вообще считаю, что ставки НДС как перечисление является методической ошибкой разработчиков типовых
   progaoff
 
5 - 03.10.16 - 16:38
спасибо решил более просто)
   Cyberhawk
 
6 - 03.10.16 - 17:46
(5) Пожалуйста. Как же?

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует