Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Очистить периодические реквизиты в справочнике

v7: Очистить периодические реквизиты в справочнике
Я
   work92
 
30.09.16 - 09:35
Может кто подскажет как очистить периодические реквизиты в справочнике.

СпрОС=Создатьобъект("Справочник.ОсновныеСредства");
ПП = СоздатьОбъект("Периодический");  
ПП.ИспользоватьОбъект("ВосстановительнаяСтоимость",СпрОС);
 
СпрОС.НайтиПокоду("01");
      ГруппаОС = СпрОС.ТекущийЭлемент(); 
      
      СпрОС.ИспользоватьРодителя(ГруппаОС);
      СпрОС.ВыбратьЭлементы();
 Пока СпрОС.ПолучитьЭлемент()=1 Цикл
Сообщить("СпрОС---"+СпрОС.Код);
ПП.ВыбратьЗначения();
Пока ПП.ПолучитьЗначение() = 1 Цикл
   ПП.Удалить(); 
КонецЦикла;
СпрОС.Записать() ;
КонецЦикла
 
 
   work92
 
1 - 30.09.16 - 09:35
1С 7.7
   пипец
 
2 - 30.09.16 - 09:38
есть обработка по очистке
   пипец
 
3 - 30.09.16 - 09:38
   Остап Сулейманович
 
4 - 30.09.16 - 09:39
(0)
СпрОС=Создатьобъект("Справочник.ОсновныеСредства");
ПП = СоздатьОбъект("Периодический");  
 
СпрОС.НайтиПокоду("01");
ГруппаОС = СпрОС.ТекущийЭлемент(); 
      
СпрОС.ИспользоватьРодителя(ГруппаОС);
СпрОС.ВыбратьЭлементы();
Пока СпрОС.ПолучитьЭлемент()=1 Цикл
    Сообщить("СпрОС---"+СпрОС.Код);
    //Привязка должна быть здесь

    ПП.ИспользоватьОбъект("ВосстановительнаяСтоимость",СпрОС.ТекущийЭлемент());
    ПП.ВыбратьЗначения();
    Пока ПП.ПолучитьЗначение() = 1 Цикл
        ПП.Удалить(); 
    КонецЦикла;
    //Вот это вот вообще не нужно.

    //СпрОС.Записать() ;

КонецЦикла

ЗЫ. И то только в том случае, если установлена фишка "Ручное изменение". Иначе нужно перепроводить документы.
   work92
 
5 - 30.09.16 - 09:44
Все равно не удаляет
   пипец
 
6 - 30.09.16 - 09:48
   пипец
 
7 - 30.09.16 - 09:50
можно еще кардинальнее - но говорить не буду )))
   Эльниньо
 
8 - 30.09.16 - 11:16
Если юзаете 1с++ подкину самую лутчую на свете обработку и пох на  "Ручное изменение".

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует