Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Выгрузка изображений в печатную форму.

Выгрузка изображений в печатную форму.
Я
   Ivanych
 
29.09.16 - 17:23
Проблема. Изображение дублируется в строках. Не могу разобраться, подскажите что делаю неправильно. Спасибо.

//////////

ВыборкаСтрокЦеха = ЗапросТовары.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам,"Цеха");
    
    Пока ВыборкаСтрокЦеха.Следующий() Цикл
        
            ВыборкаСтрокТовары = ВыборкаСтрокЦеха.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам,"Номенклатура");
            ОбластьСтрокаЦех.Параметры.Заполнить(ВыборкаСтрокЦеха);
            ТабДокумент.Вывести(ОбластьСтрокаЦех);    

            Пока ВыборкаСтрокТовары.Следующий() Цикл

        
            
            // Получаем основное изображение номенклатуры.

            ИзображениеТовара = ВыборкаСтрокТовары.Номенклатура.Ссылка.ОсновноеИзображение.Хранилище.Получить();
            
            Если ЗначениеЗаполнено(ИзображениеТовара) Тогда
                //вставляем рисунок

                Рис = ОбластьСтрока.Рисунки.Добавить(ТипРисункаТабличногоДокумента.Картинка);
                Хр=Справочники.ХранилищеДополнительнойИнформации;
                Сс=Хр.НайтиПоНаименованию(ВыборкаСтрокТовары.Номенклатура.Ссылка.ОсновноеИзображение);
                Если ЗначениеЗаполнено(Сс) Тогда
                    Дан=Сс.Хранилище.Получить();
                    Рис.Картинка=Новый Картинка(Дан.ПолучитьДвоичныеДанные());;
                    Рис.РазмерКартинки = РазмерКартинки.АвтоРазмер; 
                    Рис.Верх = 0;
                    Рис.Высота = 19;
                    Рис.Ширина = 23;
                    Рис.Лево = 159;
                    Рис.Линия = Новый Линия(ТипЛинииРисункаТабличногоДокумента.НетЛинии);
                КонецЕсли;    
            КонецЕсли;
        

         
    КонецЦикла;
    КонецЦикла;
 
 
   Tatitutu
 
1 - 29.09.16 - 17:31
"Все смешалось в кучу"

вот это особенно сильно:
Сс=Хр.НайтиПоНаименованию(ВыборкаСтрокТовары.Номенклатура.Ссылка.ОсновноеИзображение);

вообще плохой пример .
в самом макете картинки нет ?
   Ivanych
 
2 - 29.09.16 - 17:33
нет нету. Опыта мало. Картинку добавлял, а программно заполнить не допер как
   Ivanych
 
3 - 29.09.16 - 17:38
Может есть пример как лучше?
   Tatitutu
 
4 - 29.09.16 - 17:39
тектовар          =  ВыборкаСтрокТовары.Номенклатура;
ИзображениеТовара = ТекТовар.ОсновноеИзображение.Хранилище.Получить();                
            
            Если ЗначениеЗаполнено(ИзображениеТовара) Тогда
                //вставляем рисунок

                
                Рис = ОбластьСтрока.Рисунки.Добавить(ТипРисункаТабличногоДокумента.Картинка);
                
                Рис.Картинка      =  ИзображениеТовара;
                Рис.РазмерКартинки = ИзображениеТовара.Пропорционально; 
                Рис.Верх   = 0;
                Рис.Высота = 19;
                Рис.Ширина = 23;
                Рис.Лево   = 159;
                Рис.Линия = Новый Линия(ТипЛинииРисункаТабличногоДокумента.НетЛинии);
                
            КонецЕсли;
   Tatitutu
 
5 - 29.09.16 - 17:44
а так вставь в макет Картинку, дай ей имя например "МИНИКАРТ"

тектовар          =  ВыборкаСтрокТовары.Номенклатура;
НужнаяКартинка = ТекТовар.ОсновноеИзображение.Хранилище.Получить();
            
Если НужнаяКартинка=Неопределено Тогда                
    СтрТов.Рисунки.МИНИКАРТ.Картинка  = Новый Картинка;          
Иначе            
    СтрТов.Рисунки.МИНИКАРТ.Картинка  = НужнаяКартинка;    
КонецЕсли;
   Ivanych
 
6 - 29.09.16 - 17:45
А если в макете картинка создана как привязать?
   Ivanych
 
7 - 29.09.16 - 17:46
Спасибо.
   Ivanych
 
8 - 29.09.16 - 17:46
А как быть с повтором картинок в строках
   Tatitutu
 
9 - 29.09.16 - 17:49
(8) не понял
   Ivanych
 
10 - 29.09.16 - 17:55
Получилось. Все просто оказывается. Большое спасибо.
 
 Рекламное место пустует

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует