Вход | Регистрация


1С:Предприятие :: 1С:Предприятие 8 общая

Вернуть с сервера на клиент ТЗ

Вернуть с сервера на клиент ТЗ
Я
   Slon747
 
29.09.16 - 11:48
При возвращении на клиента ТЗ клиент получает ДанныеФормыКоллекция.
Как превратить обратно в ТЗ?
 
 
   mikecool
 
1 - 29.09.16 - 11:48
(0) снова на сервер
   mikecool
 
2 - 29.09.16 - 11:48
ДФК - если представлен на форме, но есть реквизит формы - ТЗ
   Рэйв
 
3 - 29.09.16 - 11:49
Верни с сервера:

Функция РазложитьТЗ(ТЗ) Экспорт
    мТЗ=Новый Массив;
    
    Для каждого Стр Из ТЗ Цикл
        струкСтрока=Новый Структура;
        Для каждого Кол Из ТЗ.Колонки Цикл
            СтрукСтрока.Вставить(Кол.Имя,Стр[Кол.Имя]);
        КонецЦикла;    
        мТЗ.Добавить(струкСтрока);
    КонецЦикла;
    
    Возврат мТЗ
    
КонецФункции
   Slon747
 
4 - 29.09.16 - 11:50
(2) что за ДФК?
   Лефмихалыч
 
5 - 29.09.16 - 11:51
блин, еще один...
(0) зачем тебе ТЗ на клиенте? Что ты с ней там делать хочешь?
   aleks_default
 
6 - 29.09.16 - 11:51
РеквизитФормыВЗначение()
   Рэйв
 
7 - 29.09.16 - 11:51
(5)Как что? Перебирать и настальгировать!:-)
   mikecool
 
8 - 29.09.16 - 11:52
(4) ДанныеФормыКоллекция
   Slon747
 
9 - 29.09.16 - 11:52
(5) компонента не работает на сервере. Нужно получить данные с сервера и прогнать через компоненту на клиенте.
   Лефмихалыч
 
10 - 29.09.16 - 11:54
(9) значит тебе УФ нельзя использовать. Только ОФ. Или выбрось в ЖПО компоненту
 
 Рекламное место пустует
   Slon747
 
11 - 29.09.16 - 11:55
(10) что значит нельзя если нужно?
Чем (9) не реализуемо?
   Лефмихалыч
 
12 - 29.09.16 - 12:34
(11) технологически нельзя. В УФ таблица значений не может существовать на клиенте. Ни как. Вообще. Совсем-совсем, вообще-вообще. Ты в УФ своей этой ВК не сможешь таблицу значений передать. А ВК не может принять ни чего другого.
Вот этим овт всем и не реализуемо
   mikecool
 
13 - 29.09.16 - 12:36
(12) эээ, а реквизит формы с типом ТЗ?
   Лефмихалыч
 
14 - 29.09.16 - 12:40
(13) что реквизит формы с типом ТЗ? На клиенте у него будет тип ДанныеФормыКоллекция
   Fedor-1971
 
15 - 29.09.16 - 12:44
(14) и что помешает передать ДФК в ВК?
Не кошерно, можно реализовать перебор и преобразовать в нечто для передачи ВК
   SSSSS_AAAAA
 
16 - 29.09.16 - 12:48
(15) "и что помешает передать ДФК в ВК? "
Это уже не передача ТЗ на клиента, это передача содержимого ТЗ в ВК с неизбежной таки переделкой ВК
   Orfin
 
17 - 29.09.16 - 12:48
На клиенте же можно перебрать тз через Объект.ТЗ
   Fedor-1971
 
18 - 29.09.16 - 12:50
(16) так не факт, ТС не озвучил что именно принимает его ВК. Вполне возможно, что ему хватит массива структур - почти аналог ТЗ.

(17) Всё равно перебор идёт для ДФК, а не ТЗ.
   Slon747
 
19 - 29.09.16 - 12:51
(3) Спасибо. Хоть как-то можно вернуть
   Fedor-1971
 
20 - 29.09.16 - 12:52
(19) а реквизит формы с типом ТЗ, совсем не подходит?
   Slon747
 
21 - 29.09.16 - 12:56
(20) Я не понял, как мне тогда заполнить реквизит формы ТЗ из сервера?
   Fedor-1971
 
22 - 29.09.16 - 13:10
(21) на форме создаётся реквизит с типом ТЗ (например, МояТЗ). Переходим на сервер, заполняем его данными как обычную ТЗ (нов=МояТЗ.Добавить(); нов.???=???;). При возврате на клиента ТЗ приедет вместе с данными формы (но будет иметь тип ДФК). Если очень нужно, то перебираем через: Для каждого стр из МояТЗ цикл и подготавливаем данные для передачи в ВК.

Как вариант, можно воспользоваться идеей в (3).
   Slon747
 
23 - 29.09.16 - 13:22
(22) Сначала я создал ТЗ как реквизит обработки, а не формы. В итоге так и получил ДФК.
Но насчет реквизита формы все равно не понял.
Если я перенесу ТЗ из реквизитов объекта в реквизиты формы откуда на сервере будет эта ТЗ?
   Лефмихалыч
 
24 - 29.09.16 - 13:40
(18) (3) а ВК-то поймет значение типа ДФК или Массив?
   Slon747
 
25 - 29.09.16 - 13:43
(24) В ВК я передаю строки и цифры
   Лефмихалыч
 
26 - 29.09.16 - 13:44
(25) нахрена тогда тебе ТЗ? Обходи ДФК и передавай
   Slon747
 
27 - 29.09.16 - 13:51
(26) Можно и так. Просто как-то не привычно
   РеализоВано
 
28 - 29.09.16 - 14:08


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует