Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Обработка: добавить значение в ТЧ (сохранив предыдущие)

Обработка: добавить значение в ТЧ (сохранив предыдущие)
Я
   dft2014
 
28.09.16 - 13:10
1С8.
Есть обработка по рассылке на электронные адреса, указанные в реквизите "ЭлектронныйАдрес" (тип - строка) таб.части обработки. Мне надо массово, к существующим эл.адресам, добавить еще один определенный эл.адрес, сохранив уже вбитые ранее эл.адреса. Для этого, на форме обработки сделала кнопку с командой, но эта команда не добавляет нужный адрес, а перезаписывает. Вот код:


Процедура ДобавитьЭлАдрес(Команда)
    
    Если Объект.ТЧ.Количество()>0 Тогда
        
        Для Каждого СтрокаТЧ из Объект.ТЧ Цикл
            СтрокаТЧ.ЭлектронныйАдрес = ДопАдрес;
        КонецЦикла;
        
    Иначе    
        Сообщить ("Табличная часть пуста");
    КонецЕсли;
    
КонецПроцедуры
 
 
   dft2014
 
1 - 28.09.16 - 13:12
В поле ввода "ДопАдрес" - я ввожу нужный эл.адрес, который надо массово всем добавить.
   Irbis
 
2 - 28.09.16 - 13:13
СтрокаТЧ.ЭлектронныйАдрес = СтрокаТЧ.ЭлектронныйАдрес + "; "+ДопАдрес;
   dft2014
 
3 - 28.09.16 - 13:21
(2) Точно! Спасибо!
А не подскажите, как потом массово также у всех убрать ДопАдрес?

P.S. Это все нужно провернуть один раз, для тестирования.
   Molinor
 
4 - 28.09.16 - 13:22
(3) СтрЗаменить

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует