Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Помогите передать ТЗ с Сервера на клиент

Помогите передать ТЗ с Сервера на клиент
Я
   breezee
 
27.09.16 - 14:06
&НаСервере
Функция ВернутьТЗ()
    
    мОбъект = РеквизитФормыВЗначение("СписокСчетов");
    мХранилище = Новый ХранилищеЗначения(мОбъект);
    Возврат мХранилище;
    
КонецФункции    

мОбъект - мое ТЗ. Там есть значения. Потом на клиенте получаю - пишет что там "Неорпделено". В чем может быть проблема?

Вот так получаю

&НаКлиенте
Процедура ПровестиАктыИРаспечатать(Команда)
    
    мТЗ = ВернутьТЗ();
    мТЗ = мТЗ.Получить();
 
 
   Timon1405
 
1 - 27.09.16 - 14:08
вернуть массив структур
   Mauser
 
2 - 27.09.16 - 14:08
Таблица значений на клиенте не существует. Только ДанныеФормыСтруктураСКоллекцией
   Garykom
 
3 - 27.09.16 - 14:08
Рекомендую изучить способы сортировки... очень помогает иногда...
   Лефмихалыч
 
4 - 27.09.16 - 14:15
(0) зачем она тебе на клиенте сдалась?
   breezee
 
5 - 27.09.16 - 14:16
(3) Как же?)
(1) Спасибо, у меня дальше цикл по строкам ТЧ, обошелся одной структурой, которой заполняю из строки формы коллекции. За идею - спасибо!
   hhhh
 
6 - 27.09.16 - 14:20
(5) на будущее: просто создаешь реквизит формы, тип ТЗ. Он виден и на клиенте и на сервере. И ничего никуда не надо передавать.
   Garykom
 
7 - 27.09.16 - 14:20
(5) А как будешь "массив структур" то сортировать на клиенте?
   breezee
 
8 - 27.09.16 - 14:22
(6) Дак я и создал, проблема в том что на клиете это "РеквизитФормыКоллекции", а на сервере это уже "ТЗ"
   hhhh
 
9 - 27.09.16 - 14:26
(8) дык РеквизитФормыКоллекции это и есть массив структур, одно и тоже. Только вы его вручную создавали, а так автоматом.
   Лефмихалыч
 
10 - 27.09.16 - 14:26
(8) в атрибуте ПутьКДанным у элемента формы выбери свою эту таблицу значений и удали весь свой код накуй
 
 Рекламное место пустует
   iceman2112
 
11 - 27.09.16 - 14:46
(10) *удали весь свой код накуй*
вот эт правильно
   1sanekmaloi1
 
12 - 27.09.16 - 14:54
Судя по последним темам ТС, боюсь даже предположить что там за нетленка.
   breezee
 
13 - 27.09.16 - 16:09
(12) Неужели выглядит так, будто я спрашиваю глупые вещи?
   Лефмихалыч
 
14 - 27.09.16 - 16:19
(13) ни чего не выглядит. Вещи и правда глупые.
   BormanMic
 
15 - 27.09.16 - 16:28
В типовой БП ОбщегоНазначения.ТаблицаЗначенийВМассив
   Necessitudo
 
16 - 27.09.16 - 16:29
(13) Именно так и выглядит)
   Niveus
 
17 - 27.09.16 - 16:32
мсДанные = Новый Массив;
    // Запишем в массив

    Для Каждого СтрокаТЗ Из тзДанные Цикл
        
       стСтрокаТаблицы = Новый Структура;
       Для Каждого ИмяКолонки Из тзДанные.Колонки Цикл
          стСтрокаТаблицы.Вставить(ИмяКолонки.Имя,          СтрокаТЗ[ИмяКолонки.Имя]);
        КонецЦикла;
        
        мсДанные.Добавить(стСтрокаТаблицы);
        
    КонецЦикла;
    
    Возврат мсДанные;
    
// ПреобразоватьТаблицуЗначенийВМассив()

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует