Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: ТекущийДокумент в регистре

v7: ТекущийДокумент в регистре
Я
   botman4
 
27.09.16 - 10:09
Подскажите пож.

    Запрос = СоздатьОбъект("Запрос");
    ТекЗапроса="
    |ПЕРИОД С ДатаНачала По ДатаКонца;
    |Валюта = Регистр.Касса_Т.Валюта;
    |Сумма  = Регистр.Касса_Т.Сумма;
    |ДокТ   = Регистр.Касса_Т.ТекущийДокумент;    
    |Функция НОст    = НачОст(Сумма);
    |Функция ПриходТ = Приход(Сумма);
    |Функция РасходТ = Расход(Сумма);
    |Функция КОст    = КонОст(Сумма);
    |Группировка Валюта;
        |Группировка ДокТ;
    |";  
    Если Запрос.Выполнить(ТекЗапроса) = 0 Тогда
        Возврат;
    КонецЕсли;

        Пока Запрос.Группировка("Валюта") = 1 Цикл
        Сообщить(Запрос.ДокТ);/// 

    КонецЦикла;

 не показывает документ.....
если выгружать в ТЗ - то там видны документы...
подскажите почему не показывает текущий документ?
СПАСИБО.
 
 
   botman4
 
1 - 27.09.16 - 10:11
Пока Запрос.Группировка("Валюта") = 1 Цикл
        Пока Запрос.Группировка("ДокТ") = 1 Цикл
                    Сообщить(Запрос.ДокТ);
        КонецЦикла;
    КонецЦикла;

вроде сработало...
   Остап Сулейманович
 
2 - 27.09.16 - 10:12
(0)
Пока Запрос.Группировка("Валюта") = 1 Цикл
    Пока Запрос.Группировка("ДокТ") = 1 Цикл
        Сообщить(Запрос.ДокТ);
    КонецЦикла;
КонецЦикла;

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует